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System Maintenance Overview 
Perform system maintenance functions to keep your Universe database, system applications, and 
system machine running smoothly. 

Monitor the system functions through the system's activity log, which records activities such as 
file backups, and through system reporting. Use system maintenance reports to verify file 
backups, identify disk free space, record system activity and errors, read process status, and 
generate performance statistics.  

Use the merge and purge utilities to free up disk space on your system. You can merge new 
product records with old ones, and then purge the old product records. You can also purge 
expired entries from logs, expired price sheets and system records, and report writer save-lists.  

Use the Eclipse Dictionary and File Definition Maintenance to define and access all system data. 
Data files hold all of your system records. You can define your own files to store additional 
information. Dictionaries in the system apply instructions and rules to files in order to translate 
data into readable information. Set up maintenance logs to record file activity. 

Only the system administrator and Eclipse personnel should perform system maintenance. The 
system administrator has complete access to the system and can lock other users out of the 
system in order to perform maintenance.  
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Setup Requirements for System Maintenance 
Following are the control maintenance records and authorization keys used for system 
maintenance. 

Control Maintenance Records 
Set the following control maintenance records: 

• Capture Login 

• Purge Login Info 

• System Backup Check Time 

• System Backup Variance % 

• Unix Backup Device Path Name 

• Valid Files 

Authorization Keys 
Assign the following authorization keys: 

• DICT.MAINT 

• SYSTEM.ACTIVITY.CMT.EDIT 

• SYSTEM.ACTIVITY.EDIT 

• SYSTEM.ACTIVITY.VIEW 

• SYSTEM.PROGRAMMING 



Rel. 8.6.6 (Eterm) System Maintenance 

© 2009  Activant Solutions Inc. All rights reserved. 3 

Setup Requirements for Phantom Processing 
Following are the control maintenance records and authorization keys used for phantom 
processing.  

Control Maintenance Records 
Set the following control maintenance records: 

• Phantom Log Exempt Programs 

• Phantom Log Purge 

• System Backup Check Time 

• System Backup Variance % 

Authorization Keys 
Assign the following authorization keys: 

• KILL.PHANTOM 

• KILL.PROCESS 

• PHANTOM.EDIT 

• PHANTOM.MANAGER.CONTROL 

• PHANTOM.MANAGER.PRIORITY 

• PHANTOM.THREAD.COUNT 
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System Maintenance for Eclipse Support Personnel 
The following programs should be used only by Eclipse Support personnel. 

Check System Lock Table 
At times, system resources lock during use. This lock restricts the system to only one update at a 
time for a record. Most locks are transient and rarely cause a problem. Occasionally an orphan 
lock, which is a lock initiated by a process that has become disabled, may occur. An orphan lock 
requires manual intervention. Support personnel use this program to check the system lock table 
and disable the processes responsible for the orphan locks. 

File Resizing 
Undersized files are the primary cause of speed degradation experienced while using the system. 
Support personnel do file resizing as part of the ongoing maintenance program. If your system 
files need to be resized, contact Eclipse Support.  

The File Resizing Report displays the files that have the biggest overflow in the far right-hand 
column, in descending order. Support personnel review this report to see if file resizing is 
necessary.  

The only files listed in the report are those defined in the Valid Files control maintenance record. 
These files can be used with the Report Writer and Mass Load program.  

You may perform file-resizing procedures under the direction of Eclipse Support. When you do 
a file resizing, no other processes can be running and no users can be logged on. You are 
responsible for any problems resulting from file resizing done independently.  

Load Eclipse Release 
Support personnel use this program to install software upgrades to your system.  

Phantom Errors Report 
This report lists phantom processes or reports that logged errors to the Phantom Errors (&PH&) 
file. The report shows the program and line where the error is located and other vital system 
information. After you run the report and note the errors, you can clear the Phantom Errors file. 

System Maintenance Control 
The System Maintenance Control function checks system processes to make sure they are 
running without errors and maintains the integrity of system data. Schedule this program to run 
every night at a pre-defined time.  



Rel. 8.6.6 (Eterm) System Maintenance 

© 2009  Activant Solutions Inc. All rights reserved. 5 

Monitoring the System Overview  
Use the following screens, reports, and programs to monitor general system activity and 
performance. 

System Activity Log 
The System Activity Log records events such as program compiles, e-commerce transfers, file 
saves, system backups, and record purges. It also logs users dialing into and exiting the system. 
Use the following programs to view and create log entries: 

• System Activity Log Viewing – Displays log entries describing activity recorded by the 
system. 

• System Activity Log Entry – Displays the screen where Eclipse Support personnel can 
create a system activity log entry. 

System Maintenance Programs 
Use the following programs to research system data and functions, such as free disk space and 
file backups: 

• Backup Table of Contents Readback – Verifies whether a backup of a file was successful. 

• Disk Free Space Report – Shows the amount of disk space available on your system.  

• Event Log Viewer Report – Records system, security, and application events for systems 
running on Windows NT. 

• Overnight Maintenance Report – Lists errors found in the system by check programs that 
run every night. 

• Process Status Report – Displays the status of all processes running. 

• System Performance Monitoring – Displays system performance statistics. 
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Verifying File Backups on Tape 
Use the Backup Table of Contents Readback function to verify that a backup of a file was 
successful. When a file backup is successful, the system updates the file's backup time and date 
in the tape's table of contents. 

After you load the backup tape in the drive, the function reads back the table of contents. You 
can then check the time and date of the last backup for the file in question. 

To verify a file backup on tape: 

1. From the System > System Programming > System Maintenance menu, select 
Backup Table of Contents Readback to display the CPIO Backup Table of Contents 
screen. 

The system populates the Backup Device field with the backup device name specified in 
the Unix Backup Device Path Name control maintenance record. For example, /dev/rmt/0 
may be the backup device name.  

To read from a drive other than the default drive, you must enter that drive name. 

2. Insert the backup tape into the drive and press Enter.  

Note: If there is no tape in the drive when you press Enter, the following 
message displays: Cannot find or open the file.  

The program reads the tape. File information scrolls onto the screen. If a file is listed, it 
was backed up.  

The following six columns of information display: 

• Size of file. 

• Owner of file. 

• Bytes of data in file. 

• Date and time the file was last updated. 

• Directory. 

• File name. 

3. Scroll through the displayed screen to locate the name of the file to check.   

4. When you locate the file name, look in the fourth column to find the date and time you 
made the last backup.  

5. When you are finished, enter Q following the colon on the screen to quit.  

It will take a moment to stop the process. The tape rewinds and must finish before you 
can exit the screen.  

6. When the backup tape is rewound, remove it from the tape drive. 
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Running the Disk Free Space Report 
Use the Disk Free Space Report to view the amount of disk space available on your system.  

Eclipse dials into each system on a daily basis to check the amount of disk space being used and 
reports any high percentages. 

To run the Disk Free Space Report: 

1. From the System > System Programming > System Maintenance menu, select Disk 
Free Space Report to display the report screen. 

2. View the following data: 

Column Description 

Filesystem File name. 

1024-blocks Number of 1024-byte blocks. 

Used Number of blocks used. 

Free Number of blocks free. 

%Used Percent of blocks used. This is the primary indicator of available space. 

Iused Number of I nodes used. 

Ifree Number of I nodes free. 

%Iuse Percent of I nodes used. 

3. Use the Hardcopy hot key to print the report. 

4. Press Esc to exit the screen. 
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Viewing Windows NT Event Logs 
For systems running on Windows NT, use the Event Log Viewer screen to view log records for 
system, security, and application events. The recorded logs display user logons and data for the 
programs users are running. 

To view Windows NT event logs: 

1. From the System > System Programming > System Maintenance menu, select Event 
Log Viewing to display the Event Log Viewer screen. 

2. In the Logs field, type an asterisk (*) next to each of the following logs you want to view: 

• System – System service functions. 

• Security – User logon functions. 

• Application – Application programs. 

3. In the Error Type field, type an asterisk (*) next to each of the following types of log 
entry you want to view: 

• Error – Program errors. 

• Warning – Program warnings. 

• Information – Program messages. 

• Audit Success – Successful user logons. 

• Audit Fail – Unsuccessful user logons. 

4. In the Previous field, place an asterisk (*) next to the period from which to select the log 
entries: 

• 24 hours – Displays log entries for the past 24 hours. 

• 24 days – Displays log entries for the past 24 days. 

5. To select log entries that contain a designated word or phrase, enter the text in the Search 
string field. 

6. Use the Begin hot key to display the requested information.  

The following information displays in the Event Log Viewer report: 

 

Column Description 

Date Date of log entry. 

Time Time of log entry. 

Log Log that contains the entry. 

Type Type of log entry. 
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Column Description 

Source The source of the log entry, such as the application or system service name. 

Message Log entry description. 

7. Use the Arrow keys to scroll through the log entry descriptions.  

8. Press Enter or Esc to exit the report and return to the System Maintenance menu. 
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Running the Process Status Report 
Use the Process Status Report to view which processes are using your system resources and 
whether any of them have been running too long. If you determine that a process has been 
running too long, there may be a problem that you need to address. 

This report uses the AIX ps command to display the status of all running processes. 

To run the Process Status Report: 

1. From the System > System Programming > System Maintenance menu, select Process 
Status Report to generate the report and display it on the Hold Entry Pre-View screen. 

2. View the following information: 

Column Description 

UID User ID. 

PID Process ID. 

PPID Parent process ID. 

C CPU number. 

STIME System time. 

TTY Terminal. 

TIME Total execution time. 

CMD Command. 

3. Use the hot keys on the Hold Entry Pre-View screen as needed. 

4. Press Esc to exit the screen. 

The system displays the following prompt: Save Report in Holdfile (Y/N). 

5. Enter Y or N in response to the prompt. 

The system returns you to the System Maintenance menu. 
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Running the User Logins Report 
Each time users log into or off UniVerse, the system records information in the 
USER.LOGIN.INFO file.  

The User Logins Report shows the maximum, minimum or total number of users logged in to 
UniVerse during a date range, along with a list of the user IDs. After the report completes, the 
system purges old data from the file. 

To ensure the accuracy of the report, run a cleanup routine that checks for abnormal terminations 
and cleans up the USER.LOGIN.INFO file. Run this routine every night. You can add the 
cleanup routine CHECK.USER.LOGINS to the overnight list or schedule the routine 
CHECK.USER.LOGINS.DVR to run as a phantom process. 

To run the User Logins Report: 

1. From the Reprts > End of Month Reports #2 menu, select User Logins Report to 
display the User Logins Report screen. 

2. In the Br/Tr/All field, enter the branch or territory for which to run the report. Enter all 
to run the report for all branches. 

3. In the Start Date and End Date fields, enter the date range of login activity to include in 
the report. You can enter an actual date or variable date in these fields. 

4. In the User ID(s) field, do one of the following: 

• To run the report for all user IDs, leave the field blank. 

• To run the report for a single user, enter the user's ID. 

• To run the report for multiple users, use the Multi hot key. 

5. In the Display field, press F10 and select whether the report should display the 
maximum, minimum, or total number of users logged in during the designated period. 
The options are: 

• Max # of Users – Displays the maximum number of UniVerse sessions running each 
day.  

• Min # of Users – Displays the minimum number of UniVerse sessions running each 
day. 

• Total # of Users – Displays the total number of users logged on each day. Users may 
have multiple sessions running, but the program counts each user only once. 

6. To override the value in the Purge Date field, enter an actual or variable date.  

This field displays the date the system uses to determine which records it will purge from 
the USER.LOGIN.INFO file after the report is done. The default is the current date less 
the number of days specified in the Purge Login Info control maintenance record. The 
system deletes all records with dates prior to the purge date. 
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7. In the Sort by field, press F10 and select from one of the following to determine how to 
sort the report: 

• Date – For each day in the date range, the report displays the maximum or minimum 
data for each branch. This is the default. 

Note: Due to the way the program counts logons, the sum of the maximums or 
minimums for each branch on a given date does not necessarily equal the 
maximum or minimum displayed for the date.   

• Branch – For each branch, the report displays the maximum or minimum data for 
each day in the date range. 

8. In the By field, press F10 and select the sequence in which to perform the sort: 

• Ascending – Sorts from lowest to highest branch and from earliest to latest date. This 
is the default. 

• Descending – Sorts from highest to lowest branch and from latest to earliest date. 

9. In the Detail/Summary field, press F10 and select the mode in which to run the report: 

• Detail – Displays the requested number of users for each branch along with the user 
IDs. This is the default. 

• Summary – Displays the requested number of users for each branch.  

Note: When running the report for Max # of Users, the summary report displays 
the maximum number of users for any day within the date range for each 
branch and, in parentheses, the number of days in the date range which 
reached this maximum.                                                  

10. Use the Column hot key to modify the default column layout for the report. 

Note: The first three columns on the report are required. 

11. Use the Print, Hold, or Opts hot keys as needed. 
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Monitoring System Performance Using AIX 
The System Performance Monitoring function runs the following AIX commands for analyzing 
system performance: 

• sar – Reports overall system activity. 

• vmstat – Reports virtual memory statistics. 

• iostat – Reports input/output statistics. 

The system maintains a series of counters that record system activities. This function extracts 
data from the counters, based on the sampling rate and number of samples you request. Collect 
this data over time to study system performance trends. 

To monitor system performance using AIX: 

1. From the System > System Programming > System Maintenance menu, select System 
Performance Monitoring to display the System Performance Monitoring screen. 

The system populates the fields on the screen with default values.  

2. In the Sampling Interval field, enter the amount of time between each sample. 

3. In the Number of Samples field, enter the total number of samples to take.  

The system populates the Total Sampling Time field by multiplying the values in the 
first two fields.  

4. Use one of the following hot keys to run the function: 

• Begin – Starts the monitoring. 

• Sched – Schedules the monitoring to run at designated times. 

Note: After you exit the Phantom Scheduler, use the Begin hot key on this screen 
to schedule the Phantom job.                                      
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Viewing the System Activity Log 
Use the System Activity Log to view the entries for system activities, such as a program 
compiles, file saves, or system errors. A log entry displays a record of the activity, the time it 
occurred, and the ID of the user, if any, who entered the activity. 

Users must be assigned the SYSTEM.ACTIVITY.VIEW authorization key to view this log.  

To view the System Activity Log: 

1. From the System > System Programming menu, select System Activity Log Viewing 
to display the System Activity Log Viewing screen. 

The screen displays the following information for each log entry in view-only mode: 

Field Description 
User ID User ID of the person, if any, who entered the log activity. 

Date Day the log activity occurred. 

Time Time of day the log activity occurred. 

Comment Description of the log activity that occurred.      

 

2. Use the following hot keys as needed: 

Hot Key Function 
View If a log entry identifies a record, such as a customer #, product #, sales order #, or 

invoice #, displays the selected record in view-only mode. 

Edit If a log entry identifies a record, such as a customer #, product #, sales order #, or 
invoice #, displays the selected record in edit mode. 

Sel  Displays the Selection Criteria screen, where you can enter selection criteria to 
filter the list of logs. 

New Displays the System Activity Log Entry screen, where you can create a log entry. 
Only Eclipse personnel should make log entries. 

Edit Item Displays the System Activity Log Entry screen for the selected log entry in edit 
mode. Only Eclipse personnel should edit log entries. 

Append Displays the Append Message screen for the selected log entry, where you can 
append a message. 

Expand Displays the entire text of each log entry's comment. 

Synop Displays the first line of each log entry's comment. 

UserQ Displays your User Job Queue Viewing screen. 
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Hot Key Function 
JobQ Displays the Call Tracking Entry screen, where you can create a tracker for a 

customer, vendor, or user.  
• The system first prompts you to select User, Customer, or Vendor.  
• Then the system displays the Call Tracking Entry screen and populates the 

Comment field with a reference to this log entry. 
• After completing the tracker, the system adds an entry to the System Activity 

Log, showing the ID of the tracker that you created.     

3. Press Esc to exit the screen. 
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Creating System Activity Log Entries 
The system creates entries in the System Activity Log to record dates and times of system 
activity or to record system errors. Eclipse personnel can make log entries, as needed, such as 
when they compile programs in the system. 

The following task describes how to create a system activity log entry. 

To create a system activity log entry: 

1. From the System > System Programming menu, select System Activity Log Entry to 
display the System Activity Log Entry screen. 

The system assigns an ID and populates the Entered By field with your user ID. The 
current time and date also display. 

2. To specify a security level for the entry, in the Sec Level field, enter a level from 1 to 99. 
Level 1 is low and level 99 is high. 

Note: Only users assigned a SYSTEM.ACTIVITY.EDIT authorization key 
security level equal to or greater than this security level can view this entry.  

3. To specify the source or reason for the activity, in the Source field, enter the reason, such 
as Purge for purging the save-lists from Report Writer. 

4. In the Comment field, enter a description of the issues for this log entry. 

5. Use the following hot keys as needed: 

Hot Key Function 

Delete Deletes the associated log entry. The system prompts you to confirm the deletion. 

View Log Displays the System Activity Log Viewing screen, where you can view other log entries. 

Followup Displays the Forward screen, where you can add a user to the followup list for this log 
entry. 

Append Displays the Append Message screen, where you can append a comment to the log entry. 

Msg Displays the Message System screen, where you can send a message to a user about this 
log entry. 

Prt Prints or faxes a copy of this log entry. 

6. Press Esc to create the log entry and exit the screen. 
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Viewing the Overnight Maintenance Report 
The Overnight Maintenance Report lists the status of check programs that run nightly to maintain 
the integrity of the database files. The system runs as many of the check programs as possible in 
the allotted time. If the system is unable to run all of the programs in the allotted time, it will 
pick up where it left off on the next day. 

From the report screen you can display the latest results for each program. Eclipse Support 
personnel use the report results for debugging purposes, when necessary. 

To view the Overnight Maintenance Report: 

1. From the System > System Programming > System Maintenance menu, select 
Overnight Maintenance Report to display the Overnight Maintenance Report screen. 

The screen displays the following information for the check programs that have run: 

Column Description 

Date Date of the display. To view the report for another day, use the Date hot key to 
change the date. 

Check Program Name of the check program, such as CHECK.MATRIX. 

Last Run Date and time the check program last ran. 

Hrs Min Amount of time required to run the check program.  

Errors Number of errors the check program found. 

Unfixed Number of errors the check program found that have not been fixed. 

Warning Number of warnings the check program found. 

Termination How the job terminated: 
• Timed Out – The check program did not run to completion, and will resume 

the next time the Overnight Maintenance Report runs. 
• Finished – The check program ran to completion. 
• A blank field indicates that the check program did not run. 

2. Use the following hot keys as needed: 

Hot Key Function 

View Errors Displays the error on which you position the cursor on the Hold Entry Pre-
View screen. 

Print Errors Prints the error on which you position the cursor. 

Clear Errors  Clears all the error lists in the file for all dates. Only Eclipse personnel 
should use this hot key. Typically, the check programs delete error lists over 
30 days old.   
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Hot Key Function 

Date  Changes the date of the report. Use the following guidelines for changing the 
date: 
• To see how many errors were found each time a designated check program 

ran, change the date back one day at a time and review the error counts.  
• Since all check programs may not finish in one night, you can change the 

date back to determine when a designated program last ran. Use this 
process to determine how long it takes to cycle through all programs.   

View Unfixed/ 
Warning Errs 

Displays the unfixed or warning error on which you position the cursor. 

3. Press Esc to exit the screen and return to the System Maintenance menu. 

                                                              



Rel. 8.6.6 (Eterm) System Maintenance 

© 2009  Activant Solutions Inc. All rights reserved. 19 

Overnight Check Programs 
Overnight check programs run nightly to maintain the integrity of the database files. The system 
runs as many of the check programs as possible in the allotted time. If the system is unable to run 
all of the programs in the allotted time, it picks up where it left off on the next day. 

CHECK.AR1 
The CHECK.AR1 program checks the integrity of the indexes in the AR (Accrual Register) file, 
which contains summary information for closed ledger transactions, such as sales invoices, 
received purchase orders, cash receipts postings, accounts payable invoices, and completed 
branch transfers. 

CHECK.ASUB 
The CHECK.ASUB program checks the integrity of the data in the AR (Accrual Register) file, 
which contains summary information for closed ledger transactions, such as sales invoices, 
received purchase orders, cash receipts postings, accounts payable invoices, and completed 
branch transfers. 

Note: Run the CHECK.ASUB program before running the CHECK.GLT 
program. 

CHECK.CCLOG 
The CHECK.CCLOG program deletes records older than 60 days from the CC.LOG (credit card 
log) file. 

CHECK.ENTD 
The CHECK.ENTD program checks the integrity of the ENTITY.DYNAM file, which contains 
records of all open, bid, and lot orders for specific entities. This program can update or delete 
records; it does not add new records. 

Note: The CHECK.LED2 program makes sure all open generations have an entry 
in the ENTITY.DYNAM file. 

CHECK.ETRX 
The CHECK.ETRX program checks the integrity of the ENTITY.ETRX file, which contains 
commissions, costs, totals, and sales for dollar entity transactions.        

CHECK.FDEF 
The CHECK.FDEF program checks the data in the FILE.DEFINE file and ensures that 
child/parent relationships are valid.    
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CHECK.GLT 
The CHECK.GLT program checks the integrity of the data in the GENLED.TRANS file, which 
is a summary file of all the G/L accounts broken down by JLI (journal) type.  

Note: Run the CHECK.ASUB program before running the CHECK.GLT 
program. 

CHECK.JLI 
The CHECK.JLI program checks the integrity of the JLI index on the AR file. 

Note: Run the CHECK.JLI program before running the CHECK.GLT program. 

CHECK.LED1 
CHECK.LED1 is the first of three programs that check the integrity of the LEDGER file. Use the 
CHECK.LED1 program to add missing A/R records. The program reads through the file and 
checks to see if the dependant A/R and JRL items are in sync. 

CHECK.LED2 
The CHECK.LED2 program checks the integrity of future ledger issues in the LEDGER file.  

The program rebuilds history in the PSUB file, as determined by the Number Of Years Sales In 
PSUB File control maintenance record, if necessary. 

Note: Run the CHECK.LED2 program before running the CHECK.PRDD or 
CHECK.PSUB programs. 

CHECK.LED3 
The CHECK.LED3 program checks the LEDGER file for internal balancing of branch, COGS, 
dollar, and total COGS amounts. 

CHECK.MATRIX 
The CHECK.MATRIX program checks the integrity of the records in the MATRIX file, 
including combo group issues. 

CHECK.MSGS 
The CHECK.MSGS program purges old received messages, as determined by the number of 
days entered in the Days Before Messages Purged control maintenance record. 

CHECK.ORDERQ 
The CHECK.ORDERQ program checks the validity of the records in the Order Queue records. 
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CHECK.PID.TABLE 
The CHECK.PID.TABLE program checks the integrity of the process IDs in the EPID (Eclipse 
Process IDs) file. 

CHECK.PLOC 
The CHECK.PLOC checks the integrity of product inventory locations in the PROD.LOCS file. 

CHECK.PRDD 
The CHECK.PRDD checks the integrity of product locations and on-hands in the future ledger. 

Note: Run the CHECK.LED2 program before running the CHECK.PRDD 
program. 

CHECK.PRDS 
The CHECK.PRDS program compares the contents of the PROD.SERIAL file, which stores 
serial numbers, to the PROD.DYNAM file which stores the serial numbers for each product and 
the onhand for each serial number.  

Note: Run the CHECK.LED2 program, then the CHECK.PRDD program, then 
the CHECK.PRDS program. 

CHECK.PRICE-GRP 
The CHECK.PRICE-GRP program checks the integrity of price lines referenced by buy and sell 
groups in the PRICE-GRP file. 

CHECK.PRINTQ 
The CHECK.PRINTQ program checks the integrity of the data for printing invoices in the 
PRINT.QUEUE file. 

CHECK.PRINTRVW 
The CHECK.PRINTRVW program checks the integrity of the data for printing shipping tickets 
in the PRINT.REVIEW file. 

CHECK.PROCURE 
The CHECK.PROCURE program checks the integrity of procurement data.  

CHECK.PROD.FAMI 
The CHECK.PROD.FAMI program checks the integrity of data in the PROD.FAM (product 
families) file.    
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CHECK.PRODUCT 
The CHECK.PRODUCT program checks the integrity of data in the PRODUCT file, including 
the price line, buy line, order sequence, and sort. 

CHECK.PSUB 
The CHECK.PSUB program checks the integrity of product sales history in the PSUB file and 
removes excess history, as determined by the Number Of Years Sales In PSUB File control 
maintenance record. 

Note: Run the CHECK.LED2 program before running the CHECK.PSUB 
program. 

CHECK.PUIFILE 
The CHECK.PUIFILE program checks the integrity of the PU.IDX file, which holds the UPC 
and user-defined cross-references for products. 

CHECK.REPORTS 
The CHECK.REPORTS program checks for documents that need to be deleted and removes 
them from the REPORTS file and the &HOLD& file, as determined by the Minimum Days 
Before Report Purge control maintenance record. 

CHECK.WHSEQ 
The CHECK.WHSEQ program checks the integrity of the data in the Replenishment and 
Warehouse Queues. 
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Monitoring Eclipse License Usage 
Use the Eclipse License Maintenance screen to monitor the number of Eterm and Solar Eclipse 
licenses currently being used. You can see who is using the licenses and how many connections 
each user has. 

The Licensing Usage Detail Maintenance screen shows detail information about a user's license 
connections. You can see the accounts to which the user is connected and how long the user has 
been connected to each account.  

When your system has reached its limit and all licenses are in use, you can review detail 
information about each user's connections and then send messages asking users to log off any 
inactive connections. When necessary, you can also kill a users' connections. 

Use the following procedures to: 

• View a summary of Eclipse and Solar license usage. 

• View a user's license usage information. 

To view a summary of license usage: 

1. From the System > System Programming > System Maintenance menu, select License 
Maintenance to view the Eclipse License Maintenance screen. 

The system displays the following information: 

Field Description 
Eclipse Licenses x of xxx - Number of Eterm Eclipse licenses in use, followed by the total 

number of Eterm licenses your company has. 

Solar Licenses x of xxx - Number of Solar Eclipse licenses in use, followed by the total 
number of Solar licenses your company has. 

User Each user connected to Solar Eclipse or Eterm. 

Solar The number of Solar Eclipse licenses being used by the designated user. 

Eterm The number of Eterm Eclipse licenses being used by the designated user. 

Connections The number of connections in use. 

Note: There are generally two connections per Solar license. 
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2. Use the following hot keys, as needed: 

Hot Key Function 
Select Displays the License Selection screen, where you can enter the following 

selection criteria: 
• Eclipse User – Enter a user ID to locate and display the license usage 

information for that user. 
• Solar Licenses – Enter a number to select and display all users with 

more than that number of Solar licenses in use. 
• Eterm Licenses – Enter a number to select and display all users with 

more than that number of Eterm licenses in use. 
• Connections – Enter a number to select and display all users with more 

than that number of connections in use. 
When you need to have some users log off the system, use this feature to 
determine who is using multiple licenses. 

Detail Displays the Licensing Usage Detail Information screen, where you can see 
the licenses in use and how long the user has been connected.  

To view user license detail: 

1. With the Eclipse License Maintenance screen displayed, select a user and then use the 
Detail hot key to display the Licensing Usage Detail Information screen. 

The system displays the following information: 

Field Description 
User User whose license usage information is displayed on the screen. 

Solar Licenses Number of Solar Eclipse licenses being used by this user. 

Eterm Licenses Number of Eterm licenses being used by this user. 

Connections Number of connections being used by this user. 

PID  

Account Eclipse account accessed using the designated license. 

OS User User's ID used to access the operating system. 

Login Time Time when user logged in. 

Login Date Date when user logged in 

T License type.  
• S – Solar 
• E – Eterm 

IP IP address of connection, if applicable. 

Port Port where connection is made, if applicable. 
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2. Use the following hot keys, as needed. 

Hot Key Function 
Kill Disconnects the user from the selected license. 

Send Message Displays the Message System screen, where you can send a 
message to the user, requesting that they disconnect and release 
some of the licenses they have in use. 

3. Press Esc to exit the screen. 
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System Administrator Lockouts and Access Overview 
At times the system administrator needs to lock out all users from accessing the system, log one 
user off the system, or access the system from another user's ID. The system provides the 
following functions for the system administrator to perform such lockouts and accesses: 

• System Lockout of All Users – Before you can resize files, the system must be in a quiet 
state with no processes running. You must lock the system so that no users can access it 
to run any more processes. You must then end all processes before resizing files. Once 
the resizing is done, you can end the lockout and start all processes back up. 

• Logging a User off the System – At times the system may not respond to a user's 
commands. You must log this user off and then back on again to force the system to 
respond to the user. Logging the user off can cause some damage to any processes that 
user is using. Use the Log off a Port function to log a user off the system and cause the 
least amount of damage to any programs that the user is running. 

• Accessing the System Through Another User's ID – Use the Change to Another User 
function when you need to access the system through that user's ID in order to research 
the user's current status in the system. When you use this function, you do not need to 
know the user's password. 
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Initiating a System Lockout 
When you need to perform critical system maintenance, nobody at the site can be logged on to 
the system. The person doing the maintenance needs to verify that nobody is logged on and then 
use the System Lockout Control program to restrict system access until the maintenance is 
finished. If you try to access the system during a lockout, the following message displays: 
System shut down for maintenance. 

Only the system administrator or Eclipse Support personnel should use this program. 

Use the following procedures to: 

• Initiate a system lockout. 

• Cancel a system lockout. 

To initiate a system lockout: 

1. From the System > System Programming > System Maintenance menu, select System 
Lock Out Control to display the System Lock Out Control screen. 

2. In the Lock Out System Access Until field, enter the date and time to free the system for 
access. 

3. In the Lockout Bypass Password field, enter a password authorized personnel can use 
during a lockout to bypass the System Lockout screen and access the system to verify, for 
example, that file resizing has finished.  

Note: Although this field is optional, we suggest that you enter a bypass 
password. 

4. In the Disable System Admin Phantom? (Y/N) field, enter Y to disable the normal 
phantom scheduling so that no jobs start from the Phantom Scheduler queue while the 
system lockout is in effect.  

When the lockout terminates, the Phantom Scheduler starts all jobs that were scheduled 
to run during the lockout time. 

5. Press Esc to exit the screen and begin the lockout. 

To cancel a system lockout: 

1. From the System > System Programming > System Maintenance menu, select System 
Lock Out Control to display the System Lock Out Control screen. 

Note: You need a password to access the system during a lockout. 

2. Do not complete the fields or change the default values on the screen. 

3. Press Esc to exit the screen and clear the lockout. 
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Logging Off Ports 
System administrators can log a user off the system if they know the user's port ID or tty 
(terminal) number. For example, if you need someone in the warehouse to log off a terminal and 
that person is not at the terminal, the system administrator can do it remotely. 

Access the Log Off Port screen to log a user off the system and cause as little damage as possible 
to the processes that user is running. This function runs the Kill command from Unix. This 
command does some cleanup prior to logging the user off, but it is still the least destructive way 
to log a user off the system.  

We recommend that you research the user's current processes within the system before running 
this command. For example, if the user is in the middle of processing an invoice that might be 
accessing more than one file, damage to multiple files can occur. Use this function with caution. 

To log a user off a port: 

1. From the System > System Files menu, select Log Off a Port to display the Log off a 
Port screen. 

2. In the Port field, enter the port ID or tty (terminal) number from which to log off. 

The system displays the process ID, port specification, and process that is running on that 
port. 

Note: Use the LogOn hot key on the Message System screen to determine the 
correct port ID or tty number. 

3. At the Are You Sure (Y/N) prompt, enter Y to log off the indicated port. 
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Logging in a New User from an Active Session 
From any terminal running Solar Eclipse, you can use the New User function to log the current 
user out and a different user in.  

To log in a new user from an active session: 

1. From the System > System Programming menu, select Change to Another User. 

2. If you have trackers on the stop watch, the system prompts you to view them. At the 
prompt, enter one of the following: 

• Y – Displays the Tracker Stop Watch screen, where you can pause or remove the 
trackers. 

• N – Leaves the trackers on the stop watch. 

3. If you have clocked in, the system prompts you to clock out. At the prompt, enter one of 
the following: 

• Y – Clocks you out and then logs you off. 

• N – Logs you off without clocking out. 

The system logs you off and prompts for the user ID of the new user. 

4. At the prompt, enter the new user ID.  

You are now logged on as the new user. 
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Eclipse Dictionary Overview 
Use the Eclipse Dictionary to define and access the information stored in data files. Every data 
file has a corresponding dictionary file. The dictionary file contains one or more dictionary items 
for each field in the file. Dictionary items translate data file information so you can easily view 
and understand it. The system stores the file data in an internal form, which is more efficient for 
processing the data, and uses dictionary items to display the data in an external form, which you 
can understand. 

The system uses dictionary items when loading information into a file from the mass load 
program or data entered on a screen, or when extracting information from the file to display on a 
screen or print on a report. The system uses a relational database to store information. When you 
design a report or mass load, you identify the data in the file using dictionary IDs. You must 
have a good understanding of the Eclipse Dictionary in order to use the Report Writer/Mass 
Load programs.  

To understand the difference between data files and dictionary files, remember: 

• Data files hold records. 

• Dictionary files are instructions and rules that apply to the data files. 

Data Files 
The system stores its information in a relational database. Data is easier to access and process 
when stored in the following way: 

• Data is separated and stored in files. For example, the Product file contains details about 
the products you sell and the Customer file contains details about your customers. 

• Each file contains records. For example, the Customer file contains a record for each 
customer. 

• Each record contains fields of information called attributes. Within each record the same 
type of information is stored in the same attribute. For example, as shown in the 
following table, attribute 1 stores the customer phone number and attribute 4 stores the 
accepted payment types from the customer.  

• Attributes can be multi-valued. In the following example, for customer Long, the 
payment type values are Credit Card and Check. 

• A multi-value can have sub-values. In the following example, for customer Long, Visa 
and MC are the sub-values for the Credit Card value. 

• A unique key identifies every record to the system. The key is a number, which the 
system assigns when you create the record. The system stores the key in attribute number 
0 (zero). 
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Customer File Example 

Record Attr 0 
Item 
ID 

Attr 1 
Phone # 

Attr 2 
First 
Name 

Attr 3 
Last 
Name 

Attr 4 
Payment Type 

1 001 303-444-
4444 

Susan  Long Value: Credit Card     
Sub-value: Visa                       
Sub-value: MC 
Value: Check  

2 002 303-555-
5555 

Billy  Wilson Value: Credit Card 
Sub-value: MC 

3 003 303-666-
6666 

Richard Short Value: Check 
Sub-value:  

Dictionary Files 
Every data file has a corresponding dictionary file. The following information applies to items in 
the dictionary file: 

• Each dictionary item identifies data in a file by name rather than attribute number.  

For example, attribute 1 in the previous table contains the customer phone number. The 
dictionary ID and description for this attribute can be Cust# and Customer Number. 

• Dictionary items for numerical data define a display format.  

For example, dates are stored in the database as numbers. You can use dictionary item 
definitions to display dates in different formats, such as September 15, 1997, 15 Sept 
1997, or 09/15/97. 

• You can define multiple dictionary items for a single attribute.  

For example, using the date in the previous example, you can set up each display type as 
a separate dictionary item. One dictionary item displays the date in the 15 SEP 1997 
format and another dictionary item displays the date in the 09/15/97 format.  

• You can create a dictionary item for each value in a multi-valued or sub-valued attribute.  

• There are two types of dictionary items: 

• D-type dictionary items define physical fields of data, such as the Name field in an 
entity record. 

• I-Descriptor dictionary items create new values by manipulating data from files.  
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I-Descriptors 
An I-Descriptor, or interpretive descriptor, is a type of dictionary item that calculates a new 
value using data from other dictionary items. I-Descriptors calculate new values by running a 
subroutine or a pre-defined formula on other dictionary items. Use I-Descriptors to manipulate 
strings of information or calculate values for selecting, sorting, and displaying data on reports 
and in screen fields. 

For example, the following I-Descriptor formula multiplies the values in the surplus quantity and 
replacement cost dictionary items to determine the value of the surplus:  

(SURPLUS * REPCOST)  

In this case, the SURPLUS and REPCOST dictionary items are also I-Descriptors. Subroutines 
calculate the values of these items.  

In another example, the AR file contains transactions. The customer number identifies each 
transaction. An I-Descriptor in the AR file can use the customer number to access the bill-to 
name from the customer file. The I-Descriptor is the tool you need to create a report in one file 
and use data from other files in your calculations.  

The system includes the I-Descriptors used by the standard reports. To learn how to create your 
own I-Descriptors, we require that you attend a class. 
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Viewing Dictionary Items Defined for Files 
Use the Dictionary Maintenance Summary screen to view all of the dictionary items defined for 
a data file.  

The screen shows the data file type and attribute number assigned to each dictionary item ID. D-
type attributes, which identify physical fields of data such as the Name field in an entity record, 
display first. I-Descriptors, which represent symbolic fields of data derived from a manipulation 
of real data, follow. 

The screen also shows the justification, width, and display formats, when applicable, for each 
dictionary item. You can sort the list of dictionary items by attribute number or dictionary IDs. 
When sorted by attribute number, you can see at a glance the file's record layout. 

From this screen you can also display another screen, where you can view and edit the detailed 
information for each dictionary item. 

To view dictionary items defined for files: 

1. From the Files > Eclipse Dictionary menu, select Dictionary Maintenance Summary 
to display the Dictionary Maintenance Summary screen. 

You can also display this screen using the Dict Summ hot key on the Report Writer/Mass 
Load Design screen. 

2. In the File Name field, enter the name of the file to view, for example 
PROD.CATALOG. 

The following view-only information displays for each dictionary item: 

Field Description 

Dict ID Unique ID assigned to an attribute in the file. The same attribute can have more 
than one dictionary ID assigned to it. 

Description/Prompt  Description or prompt, depending on the selected view. 
• Description – Brief description of the field referred to by this dictionary ID.  
• Prompt – Default column heading for the selected data when printed on a 

report. This is also the prompt if used in a Report Writer/Mass Load select 
statement with a variable value.  

Use the View hot key to toggle between the views. Use the Expand Desc hot 
key to view the expanded description. 

Typ  Dictionary item type. 
• D – Identifies physical fields of data such as the Name field in an entity 

record. 
• I – I-Descriptor identifies a symbolic field used for calculating values. 

Attr Attribute number, which indicates the numerical position of the field within the 
record for the dictionary ID. 
This field applies only to D-types. 

Val If this dictionary item represents a value within a multi-valued attribute, the 
numerical position of that value.  
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Field Description 

Sub If this dictionary item represents a sub-value, the numerical position of that 
sub-value. 

Just  Indication whether the data in this dictionary item is left-justified or right-
justified on a display/report column. 

Width  Maximum width given to the value in this dictionary item. 

Conv  If the data in this dictionary item is numerical, the Pick output conversion code 
that determines the display/report format of the data. 

3. Use the following hot keys as needed: 

Hot key Function 

Edit Dict Displays the Eclipse Dictionary Maintenance screen for the selected dictionary 
item. Use this screen to edit the dictionary item. 

I-Desc Displays the I-Descriptor Program Maintenance screen for the selected dictionary 
item. Use this screen to edit an  I-Descriptor. 

Expand Desc Displays the contents of the Description field in a screen that contains 3 lines that 
are 60 characters wide. Use this hot key to determine whether the description text 
fits on one line or wraps to a new line. 

Sortby  Sorts the displayed dictionary items numerically by attribute number or 
alphabetically by the dictionary ID. 

Print Listing Sends a copy of the displayed dictionary file summary to your Hold file or default 
printer. 

Select  Displays the Dictionary Selection Criteria screen, where you can enter any of the 
following selection criteria: 
• Dict ID – Enter the ID of the dictionary item you want to select. You can also 

press F10 and select from the list of items. 
• Description Pattern Search – Enter text that appears in the description of the 

dictionary items you want to select.  
• Dictionary Type – Enter D to select D-type items or I to select I-descriptors. 
• Show Archived Dictionaries – Enter Y to include archived dictionary items in 

the selection or N to exclude archived dictionary items from the selection. 
The system displays only the dictionary items that match the selection criteria on 
the Dictionary Maintenance Summary screen. 

View  Toggles between displaying the Description field or the Prompt field for each 
dictionary item.  

4. Press Esc to clear the screen and return the cursor to the File Name field.  

5. Do one of the following: 

• Display another file. 

• Press Esc to exit the screen. 
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Creating Dictionary Items 
Use the Eclipse Dictionary Maintenance screen to create user-defined dictionary items for 
attributes, attributes' multi-values, and multi-values' sub-values.  

On this screen, you can create: 

• D-type dictionary items – Define names and formatting characteristics for each field of 
information stored in data files. 

• I-type dictionary items – Represent symbolic fields derived from a manipulation of real 
data. 

Users must be assigned the DICT.MAINT authorization key to view, create, and edit dictionary 
items. 

To create a dictionary item: 

1. From the Files > Eclipse Dictionary menu, select Eclipse Dictionary Maintenance to 
display the Eclipse Dictionary Maintenance screen. 

Note: You can also display this screen using the Dict Maint hot key on the File 
Definition Maintenance screen. 

2. In the File Name field, enter the file containing the attribute for which to create the 
dictionary item.  

3. In the Dict ID field, enter the ID of the dictionary item.  

Note: Within a file, each dictionary ID must be unique. An exclamation point (!) 
or forward slash (/) cannot be the first character of the ID. 

4. Complete the following fields for this item: 

Field Description 

Dict Type Character representing the dictionary item type. 
• D  (Field Definition) – Identifies a physical field of data, such as a name, user ID, 

number, address, description, or quantity. 
• I (I-Descriptor) – Identifies a symbolic field the system can use for calculating 

values.  

Attr# Attribute number, which indicates the numerical position of the field within the 
record for the dictionary ID. 
This  field applies to D-types only. 
Use the Dictionary Maintenance Summary screen to view the defined dictionary 
items and corresponding attribute numbers for a file. 

Val# Numerical position of a value in a multi-valued field. For example, in a customer file 
with six contacts, the third contact would be identified as value 3. 

Subval#  Numerical position of a sub-value in a multi-valued field. For example, in a customer 
file with six contacts, each of which contains a contact name and a phone number, 
the phone number of the third contact person would be sub-value 2 of value 3. 
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Field Description 

Description  Description of the dictionary item. Dictionary descriptions cannot contain 
ampersands (&). 

Prompt  Default column heading for the selected data when printed on a report, and the 
prompt if used in a Report Writer/Mass Load select statement with a variable value.  
Dictionary prompts cannot contain ampersands (&). 
The system populates this field with the Dict ID, but you can enter your own heading 
or prompt in this field. 

5. Complete the following formatting fields for this item: 

Field Description 

Justify (L/R) Indicate whether this data item should align on the right or left side of the 
report column.  
Typically, text is left justified and numbers are right justified. Dates should 
be right justified. 

Maximum Width Enter the default maximum character width for the value. 

Multi-Valued (Y/N) Indicate whether this dictionary item can accommodate more than one 
entry.  
For example, in the entity file the ADDRESS dictionary item is multi-
valued, allowing two lines of street address. 

Note: If a dictionary item identifies a single value or sub-value of a multi-
valued field, set this field to N. 

Sub-Valued (Y/N)  Indicate whether this dictionary item contains sub-values within a  multi-
valued field.  
For example, a record in the customer file can have six contacts, which are 
multi-values. Each contact has a name and phone number, which are sub-
values. 

Required (Y/N) Indicate whether an entry for this dictionary item is mandatory when 
creating a record in the file. 

Allow Update (Y/N) Indicate whether this dictionary item can be updated using mass load or 
user-defined screens. 

Case Mapping Indicate whether the data stored in this field is set to Upper Case, Lower 
Case, Title Case (initial uppercase), or Alpha Only (all alpha characters are 
uppercase). Press F10 to select an option. 
Changing the case mapping has a from-this-point-forward effect; the 
system does not change existing data. 

SFA Category If the displayed dictionary item will be used in the Sales Force Automation 
application, press F10 and select an SFA category with which to associate 
this item. 

Format (Output) When needed, enter a standard Pick output conversion code that 
determines the report display format for the data stored in this field. 

Update Subroutine Identify a subroutine to be used to process the data entered from a screen 
or mass load to update the field. 
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Field Description 

Date / Year If this is a date field, enter an asterisk (*). Define the format of the year by 
entering the number of digits to be displayed. The number of digits can be 
0, 2, or 4.  
Ensure that the Maximum Width is set to allow for the separators, a two-
digit month, a two-digit day, and the selected number of digits for the year. 
If the Maximum Width is not large enough, the date wraps to the next 
line.  

Numeric / Decim / Negs If this field is numeric, enter an asterisk (*).  
You must define the number of decimal places, and indicate whether 
negative numbers are allowed. 

Y/N Only If this field requires a Y or N response, enter an asterisk (*). 

'*' Only If this field must contain an asterisk (*) to be activated, enter an asterisk 
(*.)  

Word Wrap Disp Lines 
/ Max Lines 

If the data in this field can wrap from one line to the next, enter an asterisk 
(*).  
• Disp Lines is the number of lines to display on the screen. 
• Max Lines is the maximum number of lines you can enter for this field. 

Eclipse Dictionary If this dictionary item is part of the core Eclipse system, this option 
displays an asterisk (*) and you cannot modify it. 

Archived If this dictionary item has been archived, this option displays an asterisk 
(*).  
An archived dictionary item is obsolete, but is still being used by various 
user-defined report writer reports and user-defined screens. If you access a 
report or screen that uses an archived dictionary item, the system displays a 
warning. We recommend that you replace it with a current dictionary item, 
but you can also ignore the warning. 
An archived dictionary item does not display the first time you press F10 
to add items to mass load, report writer, order entry prompts, and user-
defined screens. Press F10 again to access archived items. 
                                                   

6.  Use any of the following hot keys as needed: 

Hot Key Function 

Copy  Creates a dictionary item for the displayed file or another file, by copying the 
displayed dictionary item. 

Delete  Deletes the displayed dictionary item from the dictionary file. The system 
prompts you to confirm the deletion. 

Note: You cannot delete a dictionary item that is open for editing. The system 
deletes the latest revision, but does not delete the dictionary item. 

Valid Makes the dictionary item a validated field. 

I-Desc Displays the I-Descriptor Program Maintenance screen, where you can enter a 
formula that determines the value of this dictionary item.  
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Hot Key Function 

Expand Displays an expanded view of the Prompt or Description field. 
• The expanded Prompt field contains 3 lines the same width as the value in the 

Maximum Width field.  
• The expanded Description field contains 3 lines that are 60 characters wide.  
You can erase the displayed text and type new text for this field. Use this screen 
to determine whether the text fits on one line or wraps to a new line. 

Prompt  Lists the standard prompts that you can use with this dictionary item. 
When creating a dictionary item, press F10 to display the list of available 
prompts. 

Log  Displays the Maintenance Log Viewing screen for the displayed dictionary item. 

Test  Selects a record from the file and displays the output defined by this dictionary 
item. 

Access  Displays the Access Control List screen, where you can designate user IDs or 
group IDs that can access the data in this record from a laptop or Palm 
computing device and the level of access for each ID. 

Key  Use to identify the names of files for which this dictionary item is the key.  
For each entry, press F10 and select a file name. 

7. Press Esc to save the updated dictionary item information and exit the Dictionary 
Maintenance screen. 
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Editing Dictionary Items 
Edit user-defined dictionary items when you need to change any of the parameters that define the 
item. You cannot edit standard Eclipse dictionary items. 

To edit a dictionary item: 

1. From the Files > Eclipse Dictionary menu, select Eclipse Dictionary Maintenance to 
display the Eclipse Dictionary Maintenance screen. 

Note: You can also display this screen using the Dict Maint hot key on the File 
Definition Maintenance screen. 

2. In the File Name field, enter the name of the file to which the user-defined dictionary 
item applies. 

3. In the Dict ID field, enter the ID of the dictionary item to edit.  

4. Edit the fields on the screen as needed. See Creating Dictionary Items for field 
descriptions. 

5. Press Esc to save your changes and display the Reason for Change prompt.  

6. Type an explanation and press Esc to display the Program Change Log Entry screen. 

The screen displays the name of the file and dictionary item you updated, along with your 
user ID, the current date and time, and the record's version number incremented by 1.   

7. Complete the Program Change Log Entry screen as follows: 

• In the Comment field, enter a comment describing the changes you made. 

• In the Actv Log # field, enter the number of the tracker that prompted the change. 

To create a tracker, press Shift-F4 and select whether to assign the tracker to a user, 
customer, or vendor. Then complete the Call Tracking Entry screen. 

• Press Esc to exit this screen and return to the Eclipse Dictionary Maintenance screen. 

Though not displayed, the record for the updated dictionary item is now open to your 
user ID. Other users can view the record, but they cannot edit the record until you 
close it.  

8. Display the updated dictionary item again.  

The screen shows that the dictionary item is open to your user ID and displays the new 
version number followed by a modification number, which indicates how many 
modifications you have made to this version of the record while it is open to your user 
ID. 
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9. Do one of the following: 

• Make additional changes to the displayed record and press Esc. 

The system displays the Reason for Change prompt. Type an explanation and press 
Esc to return to the Eclipse Dictionary Maintenance screen. The system does not 
display the Program Change Log Entry screen again. Return to step 7. When you 
display the updated dictionary item, note that the modification number following the 
version number incremented by 1. 

• If you are satisfied and finished with the changes, use the Close hot key. 

The system releases the displayed dictionary item record from its open status and 
makes an entry in the change log for this new version of the record. 

• If you are not satisfied with the changes, use the Undo hot key. 

The system displays a prompt similar to the following: 
Undo Ver # 2 for Dict CONTACT COMPANY.NAME (Y/N) : N 

Type Y to undo all the changes you made in the new version or type N to exit the 
prompt. 
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Testing Dictionary Items 
Use the Dictionary Testing screen to make sure that a dictionary item displays correctly. You can 
test the dictionary item in one record, multiple records, or all records within a file. You can also 
list all selected records or just the records that contain a value in the field. 

To test a dictionary item: 

1. From the Files > Eclipse Dictionary menu, select Dictionary Maintenance to display 
the Eclipse Dictionary Maintenance screen. 

2. Complete the File Name and Dict ID fields for the item to be tested. 

3. Use the Test hot key to display the Dictionary Testing screen. 

4. In the File IDs field, do one of the following: 

• To test one record, enter the record ID.  

• To test multiple records, use the IDs hot key.  

• To test all IDs, leave this field blank. 

5. To list only those fields with values, enter N in the Show Blank Values field. The default 
value is Y. 

6. Use the Begin hot key to perform the test. 

The system displays a terminal control language (TCL) list of the results. 

• Press any key to scroll through the list.  

• Enter Q to exit the list and return to the Eclipse Dictionary Maintenance screen. 

7. Press Esc to exit the Dictionary Maintenance screen. 
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Validating Dictionary Items 
Use the Dictionary Validation screen to make a dictionary item a validated field. A field is 
validated when its values must meet pre-defined requirements. To define validation 
requirements, do one of the following: 

• Create a list of acceptable values for the field. 

• Identify a file or control maintenance record that contains a list of acceptable values. 

• Identify a subroutine that validates the field values.  

You can also define a subroutine to manipulate input before it is validated. For example, a pre-
input subroutine could strip spaces or capital letters from the data.  

To validate a dictionary item: 

1. From the Files > Eclipse Dictionary menu, select Dictionary Maintenance to display 
the Eclipse Dictionary Maintenance screen. 

2. Complete the File Name and Dict ID fields for the item to set up as validated. 

3. Use the Valid hot key to display the Dictionary Validation screen. 

4. To define a subroutine to manipulate input before the system validates it, in the Pre-
Input Subroutine field, press F10 and select a subroutine.  

5. In the Post Input Valid Type field, press F10 to select one of the following options: 

Options The data being validated... 

Control  must match the data in the control maintenance record identified in the 
Record/File/Subr field. 

File  must match one of the records in the file identified in the Record/File/Subr field. For 
example, you can use the PRICE.LINE file for validation of Price Line IDs. 

List  must match one of the items in the list created using the Valid List hot key. 

Subr  will be validated by the subroutine identified in the Record/File/Subr field. 

6. Enter one of the following in the Record/File/Subr field. Your entry depends on the 
option selected in the Post Input Valid Type field. 

If you selected... Then... 

Control, File or Subr enter the name of the control maintenance record, file, or subroutine to use 
for validation. 

List  an asterisk (*) displays in this field. Use the Valid List hot key to enter a list 
of data against which the system must validate the input for this dictionary 
item. Each line of text represents a valid entry. The text is case sensitive. 

7. Press Esc to save this information and return to the Dictionary Maintenance screen. 

8. Press Esc again to save the updated dictionary item. 
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Running the Dictionary Usage Report 
In Release 8, Eclipse standardized the naming conventions for dictionary items. We changed the 
internal programs to use the new names and then archived the old names. The archived names 
still work in programs, such as user-defined reports, files, forms, and order entry views created 
prior to Release 8, but we recommend that you update your reports and views to use the new 
dictionary items and then delete the old dictionary items.  

Run the Dictionary Usage Report to identify the dictionary items your system uses and where 
they are being used. You can run the report for a single file, multiple files, or all files. The 
program can check D-types, i-descriptors, or both types of dictionary items. You can report on 
used, unused, or all dictionary items. The report can include active, archived, or all dictionary 
items. 

In addition to creating a report, you can use this program to purge unused user-defined dictionary 
items from your system. We recommend that you create a report of the dictionary items not 
being used and review it before running the program with the purge option selected. 

To run the Dictionary Usage Report: 

1. From the Files > Eclipse Dictionary menu, select Dictionary Usage Report to display 
the Dictionary Usage Report screen. 

2. Enter selection criteria in the following fields, as needed: 

Field Description 
File The files for which to run the report. 

• To run the report for one file, enter the filename in this field. 
• To run the report for multiple files, use the Multi hot key and enter each 

filename. 
• To run the report for all files, leave this field blank. 

Dictionary Type The type of dictionary items to include in the report. Select from the 
following options: 
• Dictionary – Selects only D-type dictionary items. 
• I-Descriptor – Selects only i-descriptor dictionary items. 
• All – Selects D-type and i-descriptor dictionary items. 

Dictionary Usage Whether to report on used or unused dictionary items. Select from the 
following options: 
• Used – Selects only dictionary items being used by Eclipse reports and 

programs. 
• Unused – Selects only dictionary items not being used by any Eclipse 

reports and programs. 
• All – Selects used and unused dictionary items. 
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Field Description 
Dictionary Activity Whether to report on active or archived dictionary items. Select from the 

following options: 
• Active – Selects only active dictionary items. 
• Archived – Selects only archived dictionary items. 
• All – Selects active and archived dictionary items. 

Note: On the Dictionary Maintenance screen, an asterisk in the Archived 
field indicates that the dictionary item is archived. 

Purge Unused Archived Whether the system should purge unused archived dictionary items as it 
compiles the report. 
• Y – The system purges unused archived dictionary items.  

Note: To enter a Y in this field, you must set the Dictionary Usage 
Prompt and Dictionary Activity fields to include unused and archived 
dictionary items. The system will not purge special-purpose dictionary 
items that start with @, & or $. 

• N – The system does not purge any dictionary items. 

3. Use the Print, Hold, or Opts hot keys, as needed, to run the report. 

The report displays the following information for each dictionary item occurrence: 

Column Description 
File The file for which the dictionary item is defined. 

Dictionary Item The dictionary item ID. 

Type The dictionary item type. 
• A – Data descriptor. 
• D – Data descriptor. 
• I –  Interpretive descriptor 

Archived Indication whether the dictionary item is archived. 
• YES – Archived. 
• NO – Not archived. 

Where Used The program that uses the dictionary item. 
• Report Writer 
• File Definition Maintenance 
• User Defined Forms 
• Customer Uploads 
• File Sorts 
• OE Views 

Description The dictionary item description. 

Last Run For Report Writer reports, the time and date when the report was last run. 
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Running the Release 8 Dictionary Update 
Release 8 contains new branching logic, new files, and new structures for old files. Due to these 
changes, the dictionary items defined for all Eclipse files have been overhauled. The dictionary 
item naming conventions and usage are now standardized. 

When you upgrade your Eclipse system from Release 7 to Release 8, the upgrade program 
archives your original dictionary items and makes the new standard dictionary items available 
for use. Although archived dictionary items still function in the programs to which they are 
assigned, they might not produce the desired results. The following procedure explains how to 
replace your archived dictionary items with the new standard dictionary items. 

Note: This process applies to D-type dictionary items. The system cannot convert 
I-descriptors automatically. 

The Release 8 Dictionary Update program searches for dictionary items flagged as archived and 
replaces them with the standard equivalents. Run the program two times, as follows: 

• Run the program once to generate a report showing the changes that will be made. 

Each line on the report lists the original dictionary item to be replaced, the equivalent 
standard dictionary item, and the places that use the dictionary item, such as report writer 
reports, mass loads, order entry view elements, and user-defined screens. 

• After reviewing the report, run the program again in update mode to make the changes. 
                                                                                                  

To run the Release 8 Dictionary Update: 

1. From the Tools menu, select Release 8 Dictionary Update to display the Release 8 
Dictionary Update screen. 

2. In the Files field, select the file for which you want to update the D-type dictionary items. 
Use the Multi hot key to enter multiple file names. 

You can update dictionary items in the following files:  

AR  GENLED.TRANS OSUB  PROD.PRICE 

AR.COLLECTION GL.BUDGET PRICE.LINE PROD.TRX 

BUY.LINE INITIALS  PRICE.LINE.BR PRODUCT 

BUY.LINE.BR LEDGER  PRICE-GRP PSUB 

ENTITY  LEDGER.LOG PROCURE.GROUP SHIP.VIAS 

ENTITY.BR LEDGER.TOTALS PROCURE.GROUP.BR TERMS 

ENTITY.DYNAM MATRIX  PROD.BR TERRITORY 

ENTITY.TRX MATRIX.DATES PROD.CALC.BR   

GENLED  ORDER.QUEUE PROD.DYNAM  
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3. In the Include Eclipse Dicts field, indicate whether to include, exclude, or run the 
program only for dictionary items for which the Eclipse Dictionary field is flagged in 
Eclipse Dictionary Maintenance. The default is Include. 

4. In the Update Records field, indicate whether to update records as you run the report. 
The default is N. 

Note: The first time you run the program, set this field to N to create a report of 
the proposed updates. The second time you run the program, set this field 
to Y to generate the report and update the records. 
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File Definition Maintenance Overview 
Your installer defines and creates standard Eclipse files during system installation.  

Use the File Definition Maintenance screen to do the following:  

• Create User-Defined Files – Create and integrate user-defined database files with 
standard Eclipse files. Use these files to add unique functionality to the system. For 
example, create a user-defined file to record additional customer information, such as 
each customer's favorite sport. 

• Set Maintenance Logging Parameters – Set up the maintenance logging parameters and 
activate maintenance logging. Maintenance logs track changes made to files, but 
maintenance logging must be activated first before file changes are recorded.  

• Edit File Definition Parameters – View or edit the file definition parameters used for 
indexing the file, sorting the file for display lists, and updating the file. 
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Creating User-Defined Files 
Use the File Definition Maintenance screen to create and integrate new database files with the 
standard system. 

You can create the following: 

• A user-defined data file that is independent of any other standard file.  

For example, if you are a music buff and want to catalog your collection of recordings, 
you can create a MUSIC.CATALOG file. 

• A user-defined data file that is subsidiary to a standard file. Use this type of file to append 
new fields of data to a database file without affecting the integrity of the original file. 
You can create one subsidiary file for a parent file. 

For example, if your company wants to record additional information about each 
customer, such as the owner’s favorite sport, you can create a user-defined file that is 
subsidiary to the Customer file.  

• A user-defined data file that acts as a synonym for a another file. For example, the Entity 
file contains records for six types of entities, including customers and vendors. The 
Customer and Vendor files are synonyms for the Entity file. Use the synonyms to display 
just the customer or vendor types of records. The system displays records quicker when 
you use synonymous files. 

To create a user-defined file: 

1. From the System > System Files menu, select File Definition Maintenance to display 
the File Definition Maintenance screen. 

Note: You can also display this screen by selecting File Definition Maintenance 
from the Tools menu. 

2. In the File Name field, enter the name of the user-defined file.  

Note: An exclamation point (!) cannot be the first character of a file name. We 
recommend appending a unique prefix such as UD to all user-defined file 
names to clearly distinguish them from standard file names. For example, 
name a user-defined mail file UD.MAIL. 

The system prompts you to confirm that it is a new file name.  

3. Press Enter to create the file.  

The system populates the Physical, Parent, and Dictionary File fields with the same 
name. 

4. In the Description field, identify the contents or purpose of the file. For example, you 
might type Subsidiary to the Customer file. 
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5. Change the values in the Physical, Parent, and Dictionary File fields to designate the 
type of file you are creating as follows: 

If the new file is to 
be... 

Then... 

a stand-alone file leave the Physical, Parent, and Dictionary File names the same as the file 
name. 

subsidiary to an parent 
file 

leave the Physical File name the same as the File Name, but change the 
Parent File and the Dictionary File names to that of the parent file.  

a synonym for an parent 
file 

change the Physical File, Parent File, and the Dictionary File names to 
that of the parent file.  

 

Note: Use the Dict Maint hot key to display the Dictionary Maintenance screen, 
where you can view or create dictionary items for this file. 

6. In the Type field, press F10 and select the type of file you are creating. 

7. Set the maintenance logging parameters for this file. 

8. Set the file definition parameters for this file. 

9. To make this file branch-specific, use the Branch Specific hot key. At the prompt, enter 
the attribute number where the branches to which the file applies are stored. The attribute 
number must be a numeric positive integer. 

When a file definition is branch-specific, this hot key highlights. 

10. When all entries are complete, press Esc to create the file and exit the screen.  

Note: To delete the displayed file, use the Delete hot key. The system prompts 
you to confirm the deletion. 

To view additional details about a file: 

1. From the System > System Files menu, select File Definition Maintenance to display 
the File Definition Maintenance screen. 

You can also display this screen by selecting File Definition Maintenance from the 
Tools menu. 

2. In the File Name field, enter the name of the user-defined file or press F10 and select the 
file from the displayed list. 

3. Use the File Info hot key to display the File Information screen, which contains 
information such as the size, type, and last modified time of both the data file and the 
dictionary associated with the file.  

4. Press Esc to return to the File Definition Maintenance screen. 
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Setting Maintenance Logging Parameters 
Maintenance logs track changes made to file records. If enabled, a maintenance log can record 
one of the following: 

• The time and date of a change. 

• The time, date, and attribute that changed. 

• The time, date, attribute that changed, and old attribute value. 

Your installer sets the recommended maintenance logging parameters for files during system 
installation. Your system administrator can change these settings, if needed.  

To set maintenance logging parameters: 

1. From the System > System Files menu, select File Definition Maintenance to display 
the File Definition Maintenance screen. 

Note: You can also display this screen by selecting File Definition Maintenance 
from the Tools menu. 

2. In the File Name field, enter the name of the file whose maintenance logging parameters 
to change.  

3. Edit the following fields as needed: 

Field Description 

Maint Logging Indicate whether the system should log changes made to records in this file, 
and what type of information to log. Press F10 and select one of the 
following:  
• Disabled – No maintenance logging occurs. This is the default value. 
• 1-Update Only – The log records the date and time of the update. 
• 2-Attr Only – The log records the date and time of the update and the 

attribute that changed. 
• 3-Attr W/Old Values – The log records the date and time of the update, the 

attribute that changed, and the attribute's old value. 
• 4-Save Deleted Items – In addition to recording the information described 

in option 3, the system also stores deleted records in the log. 

Allow Account Sync 
(Y/N) 

Indicate whether to allow this file to be synced between accounts. 
• Y – The system allows users to sync this file. 
• N – The system prevents users from syncing this file.  

Log Change Rsn Indicate whether the system should prompt you to enter the reason for change 
when you press Esc after making the change:  
• Y – Displays the Reason for Change screen, which prompts you to enter a 

reason. 
• N – Does not prompt you to enter a reason for the change. This is the 

default value. 
If maintenance logging for this screen is disabled, skip this field. 
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Field Description 

Min Days Before 
Purge 

Enter the number of days to keep a log message before the system can purge 
it. 

Min # Logs to Save Enter the minimum number of messages the system should keep, regardless of 
the number of days they have been in the log. 

4. Press Esc to save the changes. 
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Editing File Definition Parameters 
The File Definition Maintenance screen displays parameters for database files. The system uses 
these parameters for indexing the file, sorting the file for display lists, and updating the file. 

Only the system administrator should edit file definition parameters. 

To edit file definition parameters: 

1. From the System > System Files menu, select File Definition Maintenance to display 
the File Definition Maintenance screen. 

Note: You can also display this screen by selecting File Definition Maintenance 
from the Tools menu. 

2. In the File Name field, enter the name of the file for which to set the file definition 
parameters. 

3. Edit the following fields as needed: 

Field Description 

Select Index Dict ID 
 

Defines the dictionary that indexes this file. 
Enter the dictionary item to index the file. This is usually set to the name of 
the key field, which Eclipse calls &INDEX&. 
If the Parent File is ENTITY or PRODUCT, you get the indexing capabilities 
of that file. Otherwise, you get the indexing capabilities defined in the File 
Definition Maintenance screen. Leave this field blank to select on record IDs. 

Select SortBy Dict ID Defines how a menu table, which lists the results of a search, sorts before it 
displays. 
Leave this field blank to sort on record IDs. Otherwise, enter the dictionary 
item by which to sort the file. 

Disp Conv Expr/Attb Displays the conversion expression/attribute, which defines the text 
describing the items displayed in a menu table. Menu tables list the results of 
a search. 
Leave this field blank to use the record ID. Otherwise, enter the name of the 
file attribute to display or enter an expression using PICK correlative 
commands.  

Input Validation 
Subr 

Identifies the subroutine the system uses in validating input data. If defined, 
the subroutine in this field overrides the subroutine in the Index Dict ID 
field. 

Pre-Index Conv Subr Identifies a conversion subroutine, which the system uses to remove 
unnecessary characters in attributes before indexing them. 
The only pre-index conversion subroutine the system uses is 
DICT.SOUNDA. 

Update Validation Identifies the subroutine to call for validating data in a record within the file. 
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Field Description 

Update Subr Identifies the subroutine to call for running another program whenever a user 
updates a record in this file. 
For example, you can have a subroutine that sends a message to the credit 
control manager whenever someone updates the credit controls file. 
Note: The subroutine must adhere to Eclipse standards to work properly. 

Select Filter Subr Identifies the subroutine to use to filter the displayed items. 

New ID Verification Indicates whether you can enter a new record using a user-defined screen. 
Select one of the following options: 
• No New – You cannot enter a new record from a user-defined screen. This 

is the default value and the designation used for all standard system files. 
• Sequential – The system assigns a unique ID to a new record. 
• Free Form – The user can assign a unique ID to a new record. 

Keep File in Sync 
with Parent (Y/N) 

Indicates whether to keep the Physical file and Parent file in sync.  
For example, when set to Y, when you delete a record from the Parent file, 
the system also deletes the record from the Physical file. 

Prevent Hot Sync 
(Y/N) 

Indicates whether the system prevents this file from syncing with the Hot 
Swap Server.  

Prevent Mass Load 
(Y/N) 

Indicates whether the system prevents users from mass loading information to 
this file. The default is N. 

Note: Before you can change the setting of this field, the file must be listed in 
the Valid Files control maintenance record. 

4. Press Esc to save the parameter information and exit the File Definition Maintenance 
screen. 
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Becoming PCI Compliant 
Important: We recommend that you walk through the credit card encryption process with 

the help of a customer support representative. 

Evolving credit card industry security mandates require that sensitive card data be stored in a 
database with encryption. Encrypting credit card data for sales order transactions encrypts credit 
card names and numbers for credit card information taken anywhere in the system. You do not 
have to be running the Credit Card Authorization companion product to encrypt credit card data. 
The process encrypts all sensitive credit card information in your database. However, if you are 
not running the Credit Card Authorization companion product, the utility to encrypt your data is 
not available on a system menu. Contact customer support for assistance. 

Encrypting Credit Card Data 
Prior to encrypting credit card data, ensure that there are no users logged in to your system. If 
you run a web site that pulls data from Eclipse, ensure that your web site is offline. We also 
recommend that you encrypt credit card data only when no phantoms are running, except for 
SYSTEM.ADMIN. The encryption process automatically shuts down all phantoms and closes all 
Solar Eclipse connections. 

Note: The encryption process can take a while to run depending on the amount of 
data and your system.  

   To encrypt your credit card data: 

1. From the System > System Files menu, select Credit Card Setup > Setup PCI 
Encryption to display the Setup PCI Encryption screen.  

Note: If you are not using the Credit Card Authorization companion product, 
contact customer support to add the PCI screens to your menu. 

2. In the Encryption Password field, enter your password for the encryption process. 

3. In the Verify Password field, re-enter your password. 

4. Use the Begin hot key to encrypt the credit card information in your database.  

Any credit card information you enter in to the system from this point forward will also 
be encrypted before it is saved. 

Any errors that occur display on the screen. If you experience errors during the 
encryption process, contact Eclipse customer support for assistance. 
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Changing Your Encryption Password 
You can change your encryption password periodically for security purposes, as you see 
necessary.  

We highly recommend that you have a separate "encryption user" set up on your UNIX system. 
Using a separate user log in to encrypt your data ensures that someone in your company can 
always log in and encrypt credit card data. If you use a standard system user to encrypt the data, 
for example your system administrator, only that user's log in is linked to the encryption 
password. If that user leaves your company and you do not have that user's UNIX login, you or 
Eclipse personnel cannot encrypt data or change the encryption password.  

Important: Do not lose your encryption password! After you set the password for encryption, 
Eclipse customer support cannot retrieve your password. Set the password to 
something you are guaranteed to remember or place the password in a secure 
location. 

  To change your encryption password: 

1. At the Eterm server log in screen, log in using the separate encryption user and log in to 
Eterm. 

2. From the System > System Files menu, select Credit Card Setup > Change PCI 
Encryption to display the Change PCI Encryption screen. 

3. In the Old Password field, enter the encryption user's current password. 

4. In the New Password field, enter the password you would like to use. Passwords must be 
at least 6 characters. 

5. In the Verify Password field, re-enter the password you would like to use. 

6. Use the Begin hot key to change the password. 
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Merge and Purge Utilities Overview 
The system provides several merge and purge utilities, which you can use to delete expired 
information and reduce the sizes of your files.  

For example, every time the system sends a fax, it creates an entry in the fax log. Each new entry 
increases the size of the log. When you no longer need the information stored in log entries, you 
can delete them and reduce the file size. This makes the file more manageable and frees disk 
space for other uses. 

Use the system's merge and purge utilities to do the following: 

• Merge Entity Records – The entity file contains records for all your customers and 
vendors. If one customer or vendor buys out another, you can merge their history and 
then purge the discontinued entity record. 

• Merge and Purge Product Records – The product file contains records for every product 
you sell. If a new product replaces a discontinued one, you can merge the history and 
then purge the discontinued product record. 

• Purge Expired Log Entries – Logs store file activity, such as trackers or records of sent e-
mails. Purge old entries from logs to free space for new entries.  

• Purge Expired Items – Purge files of records that are past their expiration dates. For 
example, purge price sheets with expired effective dates.  

• Purge Other Records – Purge other records from files to free up file space. For example, 
purge old save-lists from the report writer. 
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Entity Merge Overview 
Use the Entity Merge Utility to merge the history and open transactions from one or more 
entities into a single entity. You can merge customer or vendor entities.  

The entity to be retained is the key entity. The records whose information will be merged with 
that of the key entity are merge entities. The program can process multiple merge entities at one 
time.  

This utility is a merge and purge routine. The program retains and moves some data to the key 
entity and purges some data. 

Following are the results of a completed merge: 

• For each merge entity, the following data moves to the key entity:  

• All open orders. 

• Open bids.  

• Open A/R or A/P.  

• History records. 

• Contact records. 

• For each merge entity, the program purges the following data:  

• All customer-specific matrix records.  

• Customer/vendor-specific part numbers. 

• Customer/vendor class records. 

• The program updates the key entity and any related entity records that aren't in the 
Merge/Purge List to reflect the changes in entity relationships. For example, when 
merging a bill-to-only entity into a bill-to-only key entity, the system: 

• Updates the ship-to records associated with the merge entity to point to the key entity.  

• Updates the key entity to point to the ship-to records that are now related to it. 

• Following a completed merge, the system purges the merge entity records. 
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Preparing to Merge Entities 
Prior to initiating the Entity Merge Utility, you need to review, prepare, and back up the entity 
records. 

Creating a Data Backup 
We recommend having a current data backup whenever you run a procedure that manipulates or 
changes large amounts of data. Create an archived daily backup of your data files prior to 
initiating the merge program. The system cannot restore data that the program purges. 

Evaluating the Key Entity 
Define the data in the key entity record so it will be ready for use once the merge completes. The 
program moves data from the merge entity to the key entity, but it does not evaluate whether the 
merged data makes sense. The system does not cleanse or update the merged data. 

It is very important to set up the key entity properly prior to running the merge utility, because 
once the utility has completed processing in the phantom, the system purges the entity records on 
the Entity Merge/Purge List. The system cannot restore purged data. 

For example, review the following items for a customer entity: 

• Branch access. 

• Credit parameters. 

• Entity-specific matrix records you need to define for the key entity. 

• Customer/vendor specific part numbers you need to define for the key entity. 

Evaluating the Merge Entities 
Check that control maintenance records do not lists any entities you plan to merge. For example, 
the Consolidated Invoice Reports Remit To control maintenance record should not list any 
customer that you plan to merge. 

Entity Relationships 
Review the entity relationship pre-checks that the program performs, Update records, as needed, 
ahead of time. The program stops the merge if problems exist in the entity relationships. 

Postponing Overnight Phantom Jobs 
Suspend or postpone your site's overnight Phantom jobs, such as CHECK.AR and CHECK.LED, 
from running during the time that you have scheduled the Entity Merge program. Running the 
overnight jobs interferes with the merge program and may corrupt your data. 

Do not suspend or postpone any daily backups of data. 
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Merging Entities 
After you have evaluated, and updated as needed, the customer or vendor records to merge, you 
are ready to execute the merge. 

To merge entities: 

1. From the Files > Merge/Purge menu, select Entity Merge Utility to display the Entity 
Merge Utility screen. 

2. In the Key Entity field, enter the customer or vendor into which to merge other entities. 
The system retains this record. 

The word Entity in the screen title and field name changes to Customer or Vendor, 
depending on the type of entity you specify. The system displays the entity name, 
address, internal record ID, and type.  

3. In the Entity Merge/Purge List section of the screen, enter each entity whose history 
and open transactions to merge into the key entity before purging. 

The system displays the name, address, internal record ID, and type for each entity you 
enter. 

As you enter each merge entity, the system performs initial entity pre-checks to be sure 
that entity relationships are proper. 

4. Use one of the following hot keys to run the merge: 

• Begin – Runs the merge now. 

• Opts and select Scheduling – Schedules the merge to run at another time. 

For each entity in the Entity Merge/Purge List, the following prompt displays: Merge 
Entity, [Entity Name] has active branches. They will be deactivated. Continue? (Y/N). 

5. In response to each prompt, enter Y to change the accessibility of all branches assigned to 
the designated entity on its Accessible Branches screen to N. The system can now merge 
and purge the entity. 

• After you respond Y to each prompt, the system does additional pre-checks in the 
ENTITY and PRODUCT files for cross-references to the entities in the Entity 
Merge/Purge List.  

• If the program completes successfully, the system generates the Entity Merge 
Report and sends it to your Hold file. The report reflects the end results of the 
merge and includes information about any changes the system made to related 
entities as a result of the merge. 

• If any of the merge entities are cross-referenced, the system stops the merge and 
generates an edit listing. Use the listing to change or remove the cross-references 
and then restart the Entity Merge Utility. 
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• If you enter N in response to the prompt, the system halts the program and displays 
the following message: Phantom Report Not Run. The system then returns you to the 
Entity Merge Utility screen. 

6. Once the Entity Merge Utility program has completed, run the Credit Statistics 
Calculations program to recalculate the credit information for the key entity. 
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Entity Relationship Pre-Checks 
As you complete the Key Entity and Merge Entities fields on the Entity Merge Utility screen, 
the system performs the following pre-checks to be sure that entity relationships are proper: 

• Initial Pre-Checks 

• Additional Pre-Checks 

Initial Pre-Checks 
Whether accounts can be merged depends on their entity type, as shown in the following table: 

If the key entity type is 
a... 

Then the merge entity type can be... 

Customer Bill-To/Ship-To Bill-To/Ship-To, Bill-To-Only, or Ship-To-Only. 
When a ship-to is listed, its bill-to must also be listed, either as the 
key entity or another merge entity. 

Customer Bill-To-Only Bill-To-Only. 
The system changes any ship-tos pointing to this bill-to to point to 
the new bill-to. 

Customer Ship-To-Only Ship-To-Only. 
The key and merge ship-tos must all point to a common bill-to. 

Vendor Pay-To/Ship-From Pay-To/Ship-From, Pay-To-Only, or Ship-From-Only. 
When you list a ship-from, you must also list its pay-to, either as the 
key entity or another merge entity. 

Vendor Pay-To-Only Pay-To-Only. 
The system changes any ship-froms pointing to this pay-to to point to 
the new pay-to. 

Vendor Ship-From-Only Ship-From-Only. 
The key and merge ship-froms must all point to a common pay-to. 

* Customer accounts flagged as Prospect or Branch cannot be a key or merge entity. 

* Vendor accounts flagged as Freight Vendor or Manufacturer cannot be a merge entity. 

Additional Pre-Checks 
Several restrictions apply to merging customer and vendor accounts. After you initiate the utility 
using the Begin hot key and respond affirmatively to disable branch accessibility for the merge 
entities, the utility checks the ENTITY and PRODUCT files for any cross-references to the 
entities in the Entity Merge/Purge List. 

If either the ENTITY or PRODUCT files cross-reference any of the entities listed in the Entity 
Merge/Purge List, the system stops the merge and generates an edit listing. You must change or 
remove these cross-references and restart the Merge utility again. 
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Customer 
A customer entity to be purged cannot be listed as: 

• A customer service stock entity on the Product Maintenance > Primary Inventory 
Maintenance > User Inventory Controls > Product Inventory Customer Service Stock 
screen. 

• An add demand customer on the Product Maintenance > Primary Inventory Maintenance 
> User Inventory Controls > Add Demand > Add Demand Customer Information screen. 

• The Alternate Customer/Vendor on the Customer Maintenance > Customer/Vendor 
Specific Part Numbers screen. 

• A consignment ship-to entity on the Customer Maintenance > Additional Info > 
Miscellaneous Customer Information screen. 

• A contract pricing entity for another customer on that customer's Customer Maintenance . 
Customer Pricing/Printing > Contract Pricing screen. 

Vendor 
A vendor entity to be purged cannot be listed as: 

• A procure source in the Procurement Confirmation Queue. 

• An Emergency Procure Source in Procurement Group Maintenance. 

• The Default Direct Vendor for a product on the Product Maintenance > Additional Data 
> Miscellaneous Product Information screen. 

• The Alternate Customer/Vendor on the Vendor Maintenance > Customer/Vendor 
Specific Part Numbers screen. 
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Merging and Purging Products Overview 
The Product file contains records for every product you sell. If a new product replaces a 
discontinued one, you can merge the history and then purge the discontinued product record.  

History begins with the creation of a product record and includes all transactions that take place 
involving that product. A product's history is important for determining future demand. 

If there is no history in the system for a product, you can purge the product record from the file.  
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Merging Products 
Use the Merge Products program to merge two product records into one product record. You can 
combine on-hand amounts and product history or just the on-hand amounts. When merging 
products, the product being replaced is the merge product. The product being retained is the keep 
product. You cannot permanently delete the merge product if, after merging, history is still 
attached to it. 

After a product merge, the following merge product changes occur: 

• The status changes to Purge.  

• The index type changes to Catalog. 

• The product record is no longer accessible, except by the internal product ID number. 

• The product record can be permanently deleted from the system when you run the 
Product Purge program. 

After a product merge, the following keep product changes occur: 

• The on-hand value increases to include the merge product's on-hand amount. 

• The demand amount increases to include the demand of the merge product. 

• The system replaces the merge product with the keep product on all open sales orders, 
open bids and open purchase orders, which together make up the Future Ledger.  

• If indicated during a merge, the system replaces the merge product on all closed orders. 

• The system copies detail lots from the merge product if both products are assigned the 
Detail Lot type. The system assigns new lot IDs to the copied lots for the keep product. 
The system updates the change logs for both products. 

When merging serialized items, the following occurs: 

• A warning message displays if you try to merge a serialized item with a non-serialized 
item. 

• The system copies open serial numbers for the merge product to the keep product.  

• If indicated during a merge, the system deletes serial number history for the merge 
product and copies it to the keep product. 

To merge products: 

1. From the System > Merge/Purge menu, select Merge Products to display the Merge 
Products screen. 

2. In the Keep Product field, enter the ID of the product to keep.  

3. In the Merge Product field, enter the ID of the product to merge. 
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4. In the Move History field, indicate whether to include history in the product merge. The 
default value is Y. 

• Y – Merges the history, on-hand amount, and closed orders of the two products. The 
system deletes the serial number information for the merge product and copies it to 
the keep product. 

• N – Merges the on-hand amount and open orders, but not the history, of the two 
products. If you enter N, and the merge product has history information, the system 
cannot purge that product record. 

5. In the Keep Matrix Cells field, indicate whether to keep the price matrices of the item 
specified in the Merge Product field. 

• Y – Keeps the price matrices. 

• N – Does not keep the price matrices. 

Note: If a matrix of the merged product is a duplicate (ID is the same except for 
the product number), the system does not copy the matrix. 

6. In the Move Locations With Zero Onhand field, indicate whether to merge product 
locations even if the merge product has zero on-hand. 

• Y – Merges product locations with zero on-hand. 

• N – Does not merge product locations with zero on-hand. 

7. In the Merge Average Costs field, indicate whether to use the cost of the merge product 
to increase the inventory of the keep product. If the keep product had no average cost but 
the merge product did and you answer Y, you will get a correct average cost amount. If 
you select N, you get zero cost. 

• Y – Merges the costs. 

• N – Does not merge the costs. 

Note: Merging the average costs of two products completes an inventory 
adjustment. Set the Should Inventory Adjustment Update Avg/Last 
Cost control maintenance record to Yes for the branch in which you are 
working. 

8. In the Merge Price Sheets field, indicate whether the system should merge the keep and 
merge product price sheets. 

• Y – The system merges the price sheets. If the branch and price sheet for the keep and 
merge products match, the system copies the price sheet of the product that has the 
latest effective date with prices defined. If the price sheet is not defined for the branch 
for the keep product and is defined for the merge product, the merge product price 
sheet is copied. 

• N – The keep product maintains its assigned price sheet at each branch or territory. 
This is the default. 

9. Use one of the following hot keys to run the merge: 
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• Begin – Initiates the merge process. 

• Opts and select Scheduling – Schedules the merge to run at another time.  

A system message displays once the merge is in process. Upon successful completion of 
the merge, a blank Merge Products screen displays. The status of the merge product 
changes to Purge and the product is no longer accessible, except by the internal product 
ID number. 

 



Rel. 8.6.6 (Eterm) System Maintenance 

© 2009  Activant Solutions Inc. All rights reserved. 67 

Purging Products 
Use the Purge Products utility to delete all products in the Product file that have a status of 
Delete or Purge, as long as the products are not assigned to any control maintenance record and 
do not have sales history. In addition to deleting records from the PRODUCT file, the system 
also deletes the associated records from the PROD.NOTES, PROD.DYNAM, and PROD.PRICE 
files. 

Before you can purge a product record, you must remove the product's sales history and flag the 
record for deletion. To remove a product's sales history, do the following: 

• Use the Merge Products utility to copy all of its data over to the product with which you 
are merging it. 

• Then assign the status of Delete or Purge to a product record in one of the following 
ways: 

• Use the Merge Products utility to merge two products, The system sets the status of 
the merge product to Purge.   

• In Product Maintenance, set the product status to Delete.  

The following procedures describe how to: 

• Set a product status to Delete. 

• Purge product records marked for deletion. 

To set a product status to Delete: 

1. From the Files menu, select Product to display the Product Maintenance screen. 

2. In the Product ID field, enter the product to flag for deletion. 

3. In the Status field, enter the Delete status.  

4. Press Esc to save the updated product record. 

To purge product records with a Delete or Purge status: 

1. From the Files > Merge/Purge menu, select Purge Products to display the Product 
Purge screen. 

2. In the Line Type field, accept the default Price to run the purge for price lines or enter 
Buy to run the purge for buy lines. The option you select in this field sets the variable 
field and hot key names to Prc Line or Buy Line. 

3. Set the price line/buy line parameters by doing one of the following: 

• To run the report for all price lines, leave the Prc Line field blank. 

• To run the report for one price line, in the Prc Line field, enter the price line ID. 

• To run the report for multiple price lines, use the Prc Line hot key. *Multi* displays 
in the Prc Line field. 
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• To run the report for all buy lines, leave the Buy Line field blank . 

• To run the report for one buy line, in the Buy Line field, enter the buy line ID. 

• To run the report for multiple buy lines, use the Buy Line hot key. *Multi* displays 
in the Buy Line field. 

4. Use the Options hot key and select Scheduling to schedule the purge. 

5. Use one of following hot keys to run a purge report: 

• Print – Sends the report to the printer and your Hold file. 

• Hold – Sends the report to your Hold file. 

6. Type DELETE at the prompt to confirm your request to run the program. 

When you type DELETE, the system checks the flagged products to see if any of them 
have any current activity, on-hand quantities, or history. If a product has history, you 
cannot purge it. If a product is assigned to a control maintenance record, such as EDI 
Default Product If Not Found, the system does not purge that product. Otherwise, the 
system deletes all the items flagged with the Purge or Delete status. The system also 
deletes detail lots associated with deleted products. 
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Purging Logs Overview 
Logs store file activity, such as trackers or records of sent e-mails. Purge old entries from logs to 
free space for new entries.  
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Purge Maintenance Details 
File maintenance logs keep track of the changes made within files by entering a record for each 
change. Log entries contain information, such as who made changes, when the changes were 
made, and what the changes were. Purging a log, deletes records of these types of changes within 
the file. 

Note: You can keep the first entry in a file, such as the initial information on a 
product. Use the Keep First Log (Y/N) field in File Definition 
Maintenance. 

Use the Purge Maintenance screen to check status and run times for the purge processes: 

Column Description / Actions 
Purge File The system file scheduled for purging, such as MAINT.LOG. Press F10 for a list 

of logs available for purging. 

Keep Displays the current time frame set for the system to keep files before purging, 
such as six months. The system populates this column based on parameters 
required for the type of file you are purging.  
For example, the system displays "Preset" for MAINT.LOG to indicate that it 
pulls data from parameters set in File Definition Maintenance. 

Note: Based on the file information, this column may be view only. 

Next Run Date Displays the date the system will run the purge next. 

Last Run Date Displays the date the system purged the file last. 

Last Status Displays the status for the last purge: 
• Finished – Process completed without incident. 
• Sleeping – Process suspended based on parameters entered in Purge Detail 

Maintenance, such as running during normal working hours. 
• Disabled – Process suspended based on parameters entered in Purge Detail 

Maintenance, such as running during inventory maintenance or a holiday. 
• Running – Process is currently running. Use the View Log hot key to review 

actions on the file, such as how many records were purged during the last run. 
• Stopped – Process stopped manually. The system restarts the purge process 

during the next scheduled time frame. Use the View Log hot key in Purge 
Maintenance to review actions on the file, such as when the purged was 
stopped. 

Stop Defaults to No. Set this column to Yes to stop a running process, if needed. 

 



Rel. 8.6.6 (Eterm) System Maintenance 

© 2009  Activant Solutions Inc. All rights reserved. 71 

Scheduling Maintenance Log Purges 
File maintenance logs keep records of the changes made within files. Log entries contain 
information, such as who made changes, when the changes were made, and what the changes 
were.  

We recommend purging files on a regular basis. Logs can be set to purge as often as needed. 
Purging frequency will depend on the type of log you need to purge. For example, you want to 
keep product file records for two years, but maintenance records are not as critical and should at 
a minimum be purged every six months. Deleting expired log entries from the system reclaims 
disk space on the server for other uses. 

Note: You must have permission to purge logs from your system. See your 
system administrator for more information. 

Important: Depending on the number of files set to purge, the purging process can take 
several days or weeks to complete. The deletion process can slow down 
system processes and should be run during off hours. Set parameters (step 7 
below) to ensure that the system purges files only during non-working 
hours. The system suspends the purge during the specified times. 

To schedule a maintenance log purge: 

1. Define the following parameters in File Definition Maintenance: Min Days Before 
Purge and Min # Logs to Save for the file you want to purge. 

2. From the File > Merge/Purge menu, select Purge Maintenance to display the Purge 
Maintenance screen. 

3. In the Purge File column, enter MAINT.LOG to populate the Purge Maintenance 
screen. 

4. Use the Schedule hot key to display the Phantom Scheduler screen and schedule the 
purge for  regular intervals. For more information about using the Phantom Scheduler, 
see Scheduling Phantom Processes. 

5. Press Esc to save changes and return to the Purge Maintenance screen. 

6. Use the Detail Schedule hot key to display the Detail Purge Schedule screen. 

7. Use the following areas to set parameters and ensure that the system purges files only 
during non-working hours. The system suspends the purge during the specified times: 

Area Field Description 

Main Purge File (View Only) Displays the file you want to purge, such 
as MAINT.LOG, as displayed on the Purge 
Maintenance screen. 
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Area Field Description 
Next Run Date / Time Displays the date on which the system will next purge 

records for the log. 

Note: You can only edit this field if the file is already 
scheduled for purging. 

M-F Sleep From / To 

Sat Sleep From / To 

Sleep During 
Business 
Hours 

Sun Sleep From / To 

Enter your normal business hours to keep the purge 
process from running during these times and ensure that 
your system runs at normal speed. 

Disable Start Date / Time Temporarily 
Disable Purge Disable End Date / Time 

Enter any specific time frame for which you want to 
suspend any purge that may occur.  
For example, you are conducting monthly inventory the 
last three days of the month. Enter the dates and times 
for that period.  

Note: Use the View Log hot key from the Purge Maintenance screen to review 
the status when the log was last purged and what changes have been made 
to the log purge process, to determine if records need to be reviewed or 
checked.  

8. Press Esc to save your changes and return to the Purge Maintenance screen. 
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Stopping Purge Processes 
Depending on the number of files set to purge, the purging process can take several days or 
weeks. The deletion process can slow down system processes and should be run during off 
hours.  

You can stop a process if you begin a purge process and find that you need to stop that process 
due to system resource impacts. 

To stop a purge process: 

1. From the File > Merge/Purge menu, select Purge Maintenance to display the Purge 
Maintenance screen. 

2. In the Purge File column, enter MAINT.LOG to populate the Purge Maintenance 
screen. 

3. Locate the line item you want to stop and do one of the following to stop the process: 

• Press Alt-Delete. 

• Enter a Y in the Stop column. 

The system changes the status of the purge to Stopped. The system runs the purge again 
at the next available time based on the schedule set up in File Definition Maintenance. To 
adjust the schedule for the purge, see Scheduling Maintenance Log Purges. 
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Manually Purging Maintenance Logs 
File maintenance logs keep records of the changes made within files. Log entries contain 
information, such as who made changes, when the changes were made, and what the changes 
were. Delete expired maintenance log entries from the system to reclaim disk space on the server 
for other uses. 

We recommend purging files on a regular basis. Maintenance logs can be purged less frequently 
then others, but should at a minimum be purged every six months.  

Important: You can purge records manually. Depending on the number of files set to 
purge, the purging process can take several days or weeks. The deletion 
process can slow down system processes and should be run during off 
hours. 

We recommend using the Phantom Scheduler to set up regular purging 
when it will least impact your company resources. 

Note: You must have permission to purge logs from your system. See your 
system administrator for more information. 

To manually purge maintenance logs: 

1. Define the following parameters in File Definition Maintenance for the file you want to 
purge:  

• Min Days Before Purge 

• Min # Logs to Save  

• Keep First Log (Y/N) 
Note: If prompted, log into the character-based system for this part of the task. 

2. From the File > Merge/Purge menu, select Purge Maintenance to display the Purge 
Maintenance screen. 

3. In the Purge File column, enter MAINT.LOG to populate the Purge Maintenance 
screen. 

4. Use the Schedule hot key to display the Phantom Schedule screen. 

5. In the Start Time field, enter the time at which you want the purge to begin.  

Note: The start time must be at least a few minutes after the current time in order 
for the system to recognize it. 

6. Press Esc to begin the process. 

Note: You can stop a purge at any time, if needed.  
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Purging Activity Logs 
The Customer, Vendor, User, Product, System, and EDI files have activity logs that store 
trackers. Delete old entries from these activity logs to reclaim disk space for other uses.  

The utility uses the following two parameters to qualify log entries for purging: 

• A minimum number of days old.  

• A minimum number of entries to leave in the log.  

The program purges a log entry only if it meets both requirements. 

  To purge activity logs: 

1. From the Files > Merge/Purge menu, select Purge Activity Logs to display the Activity 
Log Purge screen. 

2. For each activity log listed in the Entry Type column, enter the following purge 
parameters: 

• In the Purge field, indicate whether to purge expired entries from that log. 

• In the Minimum Days Before Purge field, enter the minimum number of days the 
entry must be in the log before it qualifies for purging. 

• In the Min # Logs to Save field, enter the minimum number of entries to keep in the 
log regardless of age. 

3. Use one of the following hot keys to run the purge: 

• Begin – Purges the expired activity log entries. 

• Schedule – Schedules the purge to run at another time. 

The system returns you to the Merge/Purge menu. When the purge completes, then 
system sends you a message indicating the number of purged log entries. 
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Purging the E-mail Log 
Every time the system sends an e-mail message, it creates an entry in the e-mail log. Purge 
expired entries from the e-mail log to reclaim disk space for other uses. 

To purge the e-mail log: 

1. From the Files > Merge/Purge menu, select Purge E-mail Log to display the Purge E-
mail Logs screen. 

2. In the Purge As Of field, enter the e-mail sent date before which the system purges all e-
mails in the log. 

For example, if you enter 10/01/2002, the system purges all entries in the e-mail log sent 
before October 1, 2002. 

3. Use one of the following hot keys to run the purge: 

• Begin – Purges the indicated log entries. 

• Opts and then select Scheduling – Schedules the purge to run at another time. 

The system returns you to the Merge/Purge menu. When the purge completes, then 
system sends you a message indicating the number of purged log entries. 
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Purging the Fax Log 
Every time the system sends a fax, it creates an entry in the fax log. Purge old entries from the 
fax log to reclaim disk space for other uses. 

To purge the fax log: 

1. From the Files > Merge/Purge menu, select Purge Fax Log to display the Fax Log 
Purge screen. 

2. In the Minimum Days Past Log Date Before Purge field, enter a number of days for 
which to purge faxes sent more than this many days ago. 

3. Use one of the following hot keys to run the purge: 

• Begin – Purges the expired log entries. 

• Schedule – Schedules the purge to run at another time. 

The system returns you to the Merge/Purge menu. When the purge completes, then 
system sends you a message indicating the number of purged log entries. 
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Purging the Remote Archive/Log 
Use the Purge Remote Archive/Log screen to purge old XML transactions from the Remote 
Archive Maintenance Queue and old entries from the Remote Activity Log. Delete old entries to 
reclaim disk space for other uses.  

To purge the remote archive and log: 

1. From the Files > Merge/Purge menu, select Purge Remote Archive/Log to display the 
Fax Log Purge screen. 

2. In the Purge Remote Archive As Of field, enter the date before which the system purges 
all XML documents from the Remote Archive Maintenance Queue. 

For example, if you enter 10/01/2002, the system purges all documents placed in the 
queue dated before October 1, 2002. 

3. In the Purge Remote Log As Of field, enter the date before which the system purges all 
entries from the Remote Activity Log. 

For example, if you enter 10/01/2002, the system purges all log entries dated before 
October 1, 2002. 

4. Use one of the following hot keys to run the purge: 

• Begin – Purges the selected log entries. 

• Schedule – Schedules the purge to run at another time. 

The system returns you to the Merge/Purge menu. When the purge completes, then 
system sends you a message indicating the number of purged log entries. 
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Purging Expired Items Overview 
Purge files containing records that are past their expiration dates. For example, purge price sheets 
with expired effective dates.  

To select records to purge, define a minimum number of days past the record expiration date. If a 
record's expiration date is older than the minimum number of days, the system purges it.  

 



Eclipse System Maintenance Rel. 8.6.6 (Eterm) 

80 © 2009  Activant Solutions Inc. All rights reserved. 

Purging Expired Bids 
Bids list the products for which customers have requested price quotes. Bids stay in the system 
until you convert the bid to an order or delete it. Delete expired bids to reclaim disk space for 
other uses. 

The Purge Bids utility uses the following two parameters to qualify bids for purging:  

• A minimum number of days past the pricing expire date.  

The Number Of Days Before Bid Pricing Expires control maintenance record determines 
when the pricing on a bid expires. 

• A minimum number of days past the ship date.  

The program purges bids that meet both requirements. The program does not delete master job 
bids, junior orders, or change orders. 

To purge expired bids: 

1. From the Files > Merge/Purge menu, select Purge Bids to display the Bid Purge screen. 

2. In the Minimum Days Past Pricing Expire Before Purge field, enter the minimum 
number of days that must pass beyond the pricing expiration date on a bid before the 
program can delete the bid. 

3. In the Minimum Days Past Ship Date Before Purge field, enter the minimum number 
of days that must pass beyond the ship date on a bid before the program can delete the 
bid. 

4. Use one of the following hot keys to run the purge: 

• Begin – Purges bids immediately. 

• Schedule – Schedules the purge for another time. 

5. At the prompt Are You Sure You Want to Purge? Bids Will Be Unrecoverable After 
Purge, enter Y. 

The system deletes the expired bids and returns you to the Merge/Purge menu. 

Note: The program does not delete master job bids, junior orders, or change 
orders. 
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Purging Expired Matrix Cells 
Purge expired price matrix cells to reclaim disk space for other uses  

Before doing this purge, verify that the Valid Customer Price Classes control maintenance record 
defines all customer price classes used in the cells. The program does not purge matrix cells that 
use undefined price classes. 

To purge expired matrix cells: 

1. From the Files > Merge/Purge menu, select Purge Expired Matrix Cells to display the 
Matrix Purging screen. 

2. At the Purge All Matrix Cells that Expire Before prompt, enter the date of the earliest 
matrix cell to keep. 

3. At the Type 'Delete' to start purge prompt, enter delete to start the purge. 

4. When prompted for the Reason for Change, enter the reason for deleting the matrices 
and press Esc. The system records the reason in the change log. 

The system deletes the expired matrix cells, displays a message noting the number of 
deleted cells, and prompts you to press Enter to continue. 

5. Press Enter to return to the Merge/Purge menu. 
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Purging Expired Recurring Journal Entry Templates 
Recurring journal entry templates define standard journal entries for the system to post at regular 
intervals. If you set up templates with expiration parameters, you can delete the templates from 
the system after they expire.  

To purge expired recurring journal entry templates: 

1. From the Files > Merge/Purge menu, select Purge Recurring Journal Entries to 
display the following prompt: This will delete any expired recurring IDs, continue: 

2. At the prompt, enter Y. 

The system purges expired template IDs and returns you to the Merge/Purge menu. 
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Purging Expired Reminder Notes 
Reminder notes, which display when users log on or off the system, can have expiration dates. 
Purge expired notes from the Reminder Notes file to reclaim disk space for other uses. 

To purge expired reminder notes: 

1. From the Files > Merge/Purge menu, select Purge Reminder Notes to display the 
Purge Reminder Notes screen. 

2. In the Purge Reminder Notes with Expire Date Before field, enter a date. The system 
will purge all reminder notes that expired before this date. 

3. Use one of the following hot keys to run the purge: 

• Begin – Purges the expired log entries. 

• Schedule – Schedules the purge to run at another time. 

The system returns you to the Merge/Purge menu. When the purge completes, the system 
sends you a message indicating that the Purged Reminder Notes Report is in your Hold 
file. 
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Purging Expired Price Sheets 
The system uses price sheets to determine product prices. Every time you update the system with 
vendor or promotional price changes, the system creates new price sheet effective dates.  

Purge price sheets with effective dates that are no longer valid to reclaim disk space for other 
uses. To run the purge, you need to specify the following parameters: 

• A cut-off date. 

• The number of price sheet effective dates to keep regardless of the cut-off date.  

The system can purge a price sheet effective date only if it meets both requirements.  

For example, price line ABC has a price sheet with the following three effective dates: 
03/15/1997, 03/15/1998 and 03/15/1999.  

• If you specify 01/01/1998 in the Purge Price Effective Dates Before field, and 3 in the # 
of Price Effective Dates to Keep field, the system does not purge any effective dates. 
None of the existing effective dates meets both requirements.  

• If you specify 01/01/1998 in the Purge Price Effective Dates Before field, and 2 in the # 
of Price Effective Dates to Keep field, then the system purges prices for the effective 
date of 03/15/97. 

The number of days entered in the Purge Age (days) field on the Price Sheet Entry 
screen does not affect this purge routine when creating a new effective date. 

Use the following tasks to: 

• Purge expired prices sheets. 

• Verify that all price sheet purges are complete. 

To purge expired price sheets: 

1. From the Files > Merge/Purge menu, select Purge Price Sheets to display the Product 
Prices Purging screen. 

2. In the Purge Price Effective Dates Before field, enter the cut-off date before which to 
purge effective date prices for the specified price sheets. 

3. In the # of Price Effective Dates to Keep field, enter the minimum number of price sheet 
effective dates to maintain for the indicated price sheets regardless of the cut-off. 

4. In the Price Line field, enter the price line whose price sheet information to purge.  

• To enter multiple price lines, use the Price Lines hot key. 

• If you leave this field blank, the system purges expired price sheets for all price lines.  

By default, the system displays *ALL* in the Price Sheet field and deletes all expired 
price sheets in the designated price lines.  

5. To delete a single expired price sheet, enter the price sheet ID in the Price Sheet field. 
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6. To delete multiple expired price sheets, use the Price Sheets hot key. 

7. Use the Begin hot key to start the purge routine.  

The system returns you to the Merge/Purge menu. When the routine completes, the 
system notifies you with a message. 

To verify that all price sheet purges are complete: 

1. From the Files > Merge/Purge menu, select Purge Price Sheets to display the Product 
Prices Purging screen. 

2. Use the Check Incomplete Purge hot key to list the purges that aborted before 
completion or are still running. 

You can run the purges again, as needed. 

3. Press Esc to exit the Purge Price Sheets screen and return to the Merge/Purge menu. 

 



Eclipse System Maintenance Rel. 8.6.6 (Eterm) 

86 © 2009  Activant Solutions Inc. All rights reserved. 

Purging Other Records Overview 
Purge the following expired records or files to free up file space: 

• Physical count files. 

• Rebate detail. 

• Schedule detail. 

Select the records and files to delete based on dates and IDs. 
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Purging Physical Count Files 
Use the Purge Physical Count utility to purge old count control files.  

If your system has cycle count control files older than 30 days or physical count control files 
older than one year, we recommend that you delete them to recover disk space.  

The system numbers cycle count control files sequentially as it creates them. The purge routine 
prompts you to enter an ID and then deletes all the files with IDs less than the one entered. 

To purge physical count files: 

1. From the Files > Merge/Purge menu, select Purge Physical Count Files to display the 
following prompt: Delete All PHYS Files with a Count# Less Than 

2. At the prompt, enter a count ID. 

The system deletes all count control files with IDs less than this count ID. It lists the 
deleted files and displays the number of files deleted. 

Note: To view a list of cycle count files, their numbers, and the dates they were 
run, press F10 with the cursor in the Count# or New field of the Generate 
Control File screen. 

3. Press Esc or Enter to return to the Merge/Purge menu. 
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Purging the Rebate Detail File 
The Rebate Detail file stores data for the Customer Sales Rebate Report when you run the report 
using the Book Letter of Credit option, which automatically creates a purchase order for the 
requested rebate. Use the Purge Rebate Detail utility to purge canceled purchase orders or orders 
that have been claimed from the vendor. 

We recommend purging the Rebate Detail file once a month. Use the scheduler to purge this file 
on a regular basis. 

To purge the rebate detail file: 

1. From the Files > Merge/Purge menu, select Purge Rebate Detail File to display the 
Purge Rebate Detail File screen. 

2. In the Purge Rebate Detail File as of field, enter the date on or before which the system 
purges all canceled purchase orders. 

For example, if you enter 10/01/2002, the system purges all canceled purchase orders 
created on or before October 1, 2002. 

3. Use one of the following hot keys to run the purge: 

• Begin Purge – Purges the expired rebate detail information. 

• Opts and then select Scheduling – Schedules the purge to run at another time. 

The system returns you to the Merge/Purge menu. When the purge completes, the system 
sends you a message. 
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Purging Schedule Detail 
Use the Purge Schedule Detail program to purge scheduled events that you created on or before a 
designated date. Removing old data from the schedule detail file speeds up the scheduling 
process. 

You must be assigned the SCHEDULER authorization key with one of the following levels to 
purge schedule detail: 

• Level 1 – Allows access to purge events that you created from your own schedule. 

• Level 2 – Allows access to purge events that you created from other users' schedules. 

The program deletes normal and timeless events that occurred and repeating events that ended on 
or before the designated date.  

To purge schedule detail: 

1. From the Files > Merge/Purge menu, select Purge Schedule Detail to display the Purge 
Schedule Detail screen. 

You can also display this screen by selecting Purge Schedule Detail on the System > 
Scheduler menu. 

2. In the Purge As Of field, enter the last date to purge. 

3. In the User ID field, specify the user whose schedule detail to purge. By default the 
system populates the field with your user ID.  

Change the ID, as needed. Use the Multi hot key to specify multiple users. 

4. Use one of the following hot keys to run the purge: 

• Begin – Purges events now. 

• Schedule – Schedules the purge for another time. 

5. At the prompt Are You Sure You Want to Purge? Entries Will Be Unrecoverable 
After Purge, enter Y. 

The system deletes the designated entries and sends you a message indicating the number 
of deleted events. 
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Phantom Processing Overview 
Use the Phantom to schedule processes, such as reports, to run on a regular schedule. You can 
still access your terminal and perform other tasks while using phantom processing. 

For example, schedule the Customer Calling Queue Report to run every afternoon to ensure that 
you call customers the same day that the order status changes. The phantom runs this report in 
the background so that users are not interrupted in other work they need to perform in the 
system. 

Note: Phantom processing is time zone specific so that you can view all processes 
within the phantom in the same time zone as set up for your ID in User 
Maintenance. On certain phantom processing screens, you can change the 
time zone view for that screen. 

Use the Phantom screens to complete the following tasks: 

• Schedule phantom processes 

• View process status 

• Edit phantom process schedules 

• Control the number of Phantoms running 

• Manage queued Phantom processes 

• Kill processes 

• View the Phantom Activity Log 

• View Phantom process parameters 
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Scheduling Phantom Processes 
When you schedule a process to run in the phantom, define the following: 

• The time of day it will run. 

• The number of times a day, month, week, or year it will run. 

• The date it will discontinue running. You can select to run a process indefinitely. 

To schedule a Phantom process: 

1. Use the Schedule, Run Scheduler, or Opts hot keys, which are available on various 
Eclipse screens, to access the Phantom Scheduler screen. 

2. In the Title field, enter a new name for the process, as needed. 

The system populates the field with the title of the program that brought you to the 
Phantom Scheduler screen, such as "Call When Complete Queue" if you accessed the 
Phantom Scheduler from the Customer Calling Queue Report. The system does not 
supply the title of a Report Writer report. Instead, you must enter such titles. 

3. In the Start Time field, enter the time of day you want the phantom to begin running the 
process. 

Note: The time zone is displayed to the right of this field. 

You can enter a time in a variety of ways. When including minutes with either normal or 
military time, type a colon between the hour and minutes.   

• 9a for 9:00 am 

• 9p for 9:00 pm 

• 09 for 9:00 am military time (a not required) 

• 21 for 9:00 pm military time (p not required) 

Note: To avoid interfering with a system backup, schedule all phantom processes 
to run early in the evening as soon as the system is clear of users. Early 
evening scheduling ensures that the day's work is backed up without delay. 

4. In the Start Date field, enter the date you want the phantom to begin running the process. 

After every running of a report or procedure, the phantom advances the date to that 
defined in the Reschedule area. 

5. To set an expiration date, enter the date in the Expire Date field. To have the process run 
indefinitely, leave this field blank. 
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6. In the Reschedule area, enter an asterisk (*) next to a selection to define how often to run 
a process. Select any or all days in the left hand column or make a selection in the right 
hand column.  

Repeating Option Repeats 

( ) Daily Daily 

( ) Weekly Weekly. Select a day for the process to repeat each week, such as every 
Wednesday. 

( ) Bi-Weekly Twice a week. Select the days for the process to repeat each week, such as 
every Monday and Wednesday. 

( ) Monthly Monthly by the date entered in the Start Date field. 
For example, if the start date is 9/12/02, then the process will repeat on the 
12th of each month. 

( ) Yearly Yearly by the date entered in the Start Date field. 
For example, if the start date is 9/12/02, then the process will repeat on 9/12 
every year. 

( ) Month-End The end of every calendar or fiscal month. Press F10 to select Calendar or 
Fiscal. 

( ) Quarterly Every three months by the date entered in the Start Date field. 
For example, if the start date is 9/12/02, then the process will repeat every 
third month on the 12th. 

7. To have the phantom run the report or procedure more than once a day, do the following: 

• In the Repeat Every: ___ Minutes field, enter the number of minutes between runs. 

• In the Until field, which references the Repeat Every field, enter the latest time you 
want the process to run.  

If you do not enter a value in this field, a repeating process runs 24 hours a day. On 
the next day, the process may start later than the time you indicate in the Start Time 
field. The entry in the Until field keeps the process from running 24 hours a day and 
from starting later than the start time on the next day. 

8. Press Esc to save the schedule and exit the Phantom Scheduler screen. 

The system returns you to the original screen from which you accessed the Phantom 
Scheduler screen.  

9. Do one of the following: 

• If you scheduled a report, use the Print or Hold hot key to run the report. 

Note: A report run from the phantom cannot print directly on a terminal's slave 
printer. To print to the slave printer, send the generated report to the Hold 
file and then print it from the print queue. To print the report directly, 
change the terminal's default printer to be a non-slave printer. 

• If you scheduled a procedure, use the Begin or Start hot key to start the procedure. 
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Viewing Process Statuses 
Use the Phantom Status screen to view all currently running phantom processes. The Phantom 
Status screen updates with each new process that runs so that you are always viewing real-time 
phantom action. 

From this screen, you can also perform the following actions: 

• View all system processes currently running, instead of just phantom processes.  

• Kill any process currently running, if authorized.  

• Access the Phantom Job Scheduler Maintenance screen to edit a phantom process. 

• Access the Phantom Manager view, where you can  

To view currently running processes: 

1. From the System menu, select Phantom Status to display the Phantom Status screen. 

The following fields, which are assigned to different views, display information for the 
terminal and each phantom process running: 

Field Description 
Your Time The current time (in 24-hour or military time) displayed in the time zone defined for 

your user ID in User Maintenance.  

System The current time (in 24-hour or military time) displayed in the time zone where the 
system resides.  

Start The time, in your time zone, when the report or program began running. 

Date The date when the report or program began running. 

User The user ID. 

PIDs The program ID. 

Program The name of the process that is running. 

Status The process status. 
For example, a program may be Sleeping until (an indicated time). 

Note: Note: A plus sign (+) displays next to processes that are using a UniVerse 
license.                                         
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2. Use the following hot keys as necessary: 

Hot Key Function 
Kill Prompts you to cancel or reschedule the phantom report on which the cursor is 

positioned. Select one of the following options or press F12 to abort: 
• Kill –  Cancels the report and sends a message to the user who originated the 

report. 
• Reschedule – Displays the Phantom Scheduler screen, where you can 

reschedule the report. The system then cancels the report and sends a message 
to the user who originated the report indicating when the report is rescheduled 
to run. 

Note: With any other type of process, the Kill hot key displays the “Kill 
‘program’ (Y/N) :” prompt. 

Detail Displays the Phantom Status Detail screen, where you can view the following 
detail information for the selected process: 
• Process ID – System ID number for the process. 
• Account – Eclipse account running the process. 
• User Number – System-generated number associated with the user running 

the process. 
• Start Time – Time when the process starts. 
• Start Date – Date when the process starts. 
• Phantom Name – Program name of the process. 
• Phantom ID – Eclipse table ID associated with the phantom program. 
• Process State – Current state of the process, such as Started. 
• Type – Process type, such as Phantom. 
• System User – User who initiated the process. 
• Status – What the process is doing now. 

Select Limit the phantom processes displayed by entering selection criteria.  
A screen prompts you to Enter Select Pattern. Enter characters from the Start 
Time, User ID, Program, or Status fields for the phantom processes you wish 
to view. 

Schedule If the cursor is placed on an Automatic Ship Ticket Printing, Report Writer, or 
G/L Report Generator process, the system displays the program driver screen, 
where you can edit the process parameters. 
For other processes, the system displays the Phantom Job Scheduler 
Maintenance screen, where you can edit the phantom process schedule. 

Kill Proc Select any process in the system, instead of only the displayed phantom 
processes, to kill. 
Note: Do not kill the SYSTEM.ADMIN process. 

Views Displays the following options for changing the screen view: 
• Start Time/Ecl. Users/Program/Status 
• Start Time/Start Date/Program/Status 
• Start Time/Process ID/Program/Status 

Proc Stat Displays the status of the process on which the cursor is positioned. 

Time Zone Displays a prompt where you can change the time zone in which the processes 
on the screen are displayed. 
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Hot Key Function 
Log Displays the Phantom Activity Log Viewing screen, where you can view the log 

of phantom process activities. 

Manage Toggles the Phantom Status view to the Phantom Manager view, where you can 
manage the queued processes. 

Opts Displays the Phantom Maintenance screen, where you can edit the system 
phantom parameters that control the number of phantoms running. 

3. Press Esc to exit the screen. 
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Editing Phantom Process Schedules 
Use the Phantom Job Scheduler Maintenance screen to edit the time and date when processes run 
or the user ID to notify when the process is complete. You can edit a process schedule 
temporarily without affecting the scheduled default. 

You might also need to reset the user ID for a scheduled Phantom process when an employee at 
your company leaves. You can search for scheduled Phantom processes by user ID that 
scheduled the Phantom and also by user IDs that are on the forward list for a process. 

To edit a Phantom process schedule: 

1. From the System menu, select Phantom Status to display the Phantom Status screen. 

2. Use the Schedule hot key to display the Phantom Job Scheduler Maintenance screen. 

3. In the User ID field, either press Enter to display every scheduled process, or enter a 
user ID to display only processes which that user has created, owned, or scheduled. 

The screen displays the name of the active phantom process, the ID of the user to notify 
when the phantom process is complete, and the Eclipse internal program name for the 
scheduled process in the Title, User ID, and Program fields, respectively. 

To search for all Phantoms that contain a particular user on the Forward To list, leave the 
User ID field blank to display every scheduled Phantom process. Then use the Select hot 
key and enter the user ID you want to search for in the Select Forward ID field. 

4. Edit the following fields, as needed: 

Field Description 
Next Run Date The date to make a temporary change to the run schedule of the program. 

Use the Adjust hot key to enter a temporary next run date for all jobs 
displayed on the screen. 

Next Run Time The time to make a temporary change to the run schedule of the program. 
Use the Adjust hot key to enter a temporary next run time for all jobs 
displayed on the screen. 

Title The title of the scheduled process. 

User ID The user to notify when the process is complete. 

 

Note: To permanently change a phantom process on this screen, place the cursor 
on the process and use the Edit hot key to display the Phantom Scheduler 
screen. You can make all permanent edits on this screen. Depending upon 
your authorization level, when you edit any Report Writer or G/L Report 
Generator processes, the system displays the report drivers for those 
processes, allowing you to edit as necessary. 
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5. Use the following additional hot keys as necessary: 

Hot Key Function 
Edit Displays the Phantom Scheduler screen, where you can permanently change any 

settings for the selected program. For more information, see Scheduling Phantom 
Processes. 

Delete Deletes the selected phantom program from the scheduler. The system asks you to 
confirm the deletion. 

Select Limits the processes displayed on the screen defined by your selection criteria.  
Use this screen together with the Adjust hot key to reschedule a group of processes 
all at once. The selection criteria follow: 
• Select Dates < – Selects processes scheduled to run before the indicated date. 
• Select Dates > – Selects processes scheduled to run after the indicated date. 
• Select Times < – Selects processes scheduled to run before the indicated time. 
• Select Pattern – Selects processes containing a pattern in the title or program 

name. 
• Select Forward ID – Selects processes that contain the user ID you enter in the 

Forward To list. Forward To lists are defined using the Forward hot key in the 
Phantom Job Scheduler Maintenance screen. 

Adjust Displays the Adjust All Selected Entries to screen. Enter a new date and time to 
adjust all of the displayed entries. 

Note:  A prompt displays warning you that you are about to adjust the time or date 
for every user's scheduled job, and asking you if you want to continue. 

Forward Forwards a copy of the process to other users. Enter the user IDs in the Forward To 
screen. 

Time Zone Displays a prompt where you can change the time zone in which the processes on 
the screen are displayed. 

6. Press Esc to save the changes and return to the Phantom Status screen. 
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Controlling the Number of Phantoms Running 
Use the Phantom Maintenance screen to set system-level parameters for improving system 
performance by controlling the number of phantoms that can be running at any given point in 
time.  

In addition to controlling the number of running phantoms, you can also control the number of 
queued phantoms. When the system reaches user or system-level thresholds, the system queues 
the phantoms until resources are free. 

Note: You can set phantom maintenance parameters at the user and system levels. 
When user-level settings do not exist, the system uses the system-level 
settings.  

To control the number of phantoms running: 

1. From the System menu, select Phantom Status to display the Phantom Status screen. 

2. Use the Opts hot key to display the Phantom Maintenance screen. 

3. In the System Phantom Manager Options area, complete the following fields: 

Field Description 
Account Eclipse account for which you are entering the following parameters. 

Maximum Number of 
Running Phantoms 

Maximum number of phantom processes that the system can be 
running before queuing other phantom processes. 

Maximum Number of 
Queued Phantoms 

Maximum number of phantom processes the system can queue. 

Queued Phantom Time Out Amount of time a process can be queued before the system takes 
another action. 

Action to take on timed out 
phantoms 

Action to take when a queued phantom times out: 
• Run – Runs the process immediately. 
• Kill – Kills the process. 
• Reschedule – Reschedules the process to run on the following day 

at its originally scheduled time. 

4. In the Phantom Priority Settings area, complete the following fields for managing 
queued phantom processes: 

Field Description 
Default Priority The priority the system assigns by default to phantom processes that 

it queues. The default is 3. 

Priority Range The range of priorities that users can assign to queued phantom 
processes. The default range is 1-5. 
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5. In the Phantom Categories area, complete the following fields, as needed, to identify 
phantom processes than cannot be throttled or logged: 

Field Description 
Type Press F10 and select the type of phantom processes to list: 

• No Throttling 
• No Logging 

Processes 
(unlabeled field) 

Add or delete processes to the displayed list. 

6. Use the Log hot key, as needed, to view the maintenance log for this screen. 

7. Press Esc to exit the screen. 
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Managing Queued Phantom Processes 
Use the Phantom Manager view of the Phantom Status screen if you are controlling the number 
of phantom processes that a single user or all users can run in total. For example, on the Phantom 
Status screen, use the Opts hot key. If you set the maximum number of phantom processes to 
100 and your system hit that threshold, all the phantom processes executed after that point get 
queued much like a print queue. 

Use the Phantom Manager screen to view the phantom processes the system is waiting to run. 
From here you can force the process to run or cancel the process. 

You can also set a phantom process limit for an individual user. For example, set an individual 
user up to run a maximum of five phantom processes, such as a reports, at a time. After the user 
has five processes running, anything else the user runs will be queued and the system will run 
them after the first five finish. 

To manage queued phantom processes: 

1. From the System menu, select Phantom Status to display the Phantom Status screen. 

2. Use the Manage hot key to change the view and screen title to Phantom Manager. 

The system displays the following information for each queued process. The processes 
display in the order in which they reside in the queue stack. 

Field Description 
Start The time, in your time zone, when the report or program began running. 

Date Date when the report or program began running. 

Program Name of the process that is running. 

User User ID. 

Process ID Phantom process ID. 

Priority Priority assigned to the process. 

Process State The process status. 

3. To change a phantom process priority, perform the following steps: 

• Select the process to move and use the Shift hot key. 

• Move the cursor to the position in the queue stack to which you want to move the 
process and press Enter. 
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4. Use the following hot keys, as needed: 

Hot Key Function 
Kill For reports, prompts you to cancel or reschedule the selected phantom report. 

Select one of the following options or press F12 to abort: 
• Kill –  Cancels the report and sends a message to the user who originated the 

report. The system prompts you to confirm this action. 
• Reschedule – Displays the Phantom Scheduler screen, where you can 

reschedule the report. The system then cancels the report and sends a message 
to the user who originated the report indicating when the report is rescheduled 
to run. 

Note: To use this hot key, users must be assigned 
PHANTOM.MANAGER.PRIORITY Level 3 authorization. 

Detail Displays the Phantom Status Detail screen, where you can view the following 
detail information for the selected process: 
• Process ID – System ID number for the process. 
• Account – Eclipse account running the process. 
• User Number – System-generated number associated with the user running 

the process. 
• Start Time – Time when the process starts. 
• Start Date – Date when the process starts. 
• Phantom Name – Program name of the process. 
• Phantom ID – Eclipse table ID associated with the phantom program. 
• Process State – Current state of the process, such as Started. 
• Type – Process type, such as Phantom. 
• System User – User who initiated the process. 
• Status – What the process is doing now. 

Select Limit the phantom processes displayed by entering selection criteria.  
A screen prompts you to Enter Select Pattern. Enter characters from the Start 
Time, User ID, Program, or Status fields for the phantom processes you wish 
to view. 

Shift Flags the phantom process on which the cursor is positioned for moving to a 
new location. After using this hot key, move the cursor to a new position in the 
list and press Enter. 

Run Runs the phantom process on which the cursor is positioned. 

Note: To use this hot key, users must be assigned 
PHANTOM.MANAGER.PRIORITY Level 3 authorization. 

Priority Prompts authorized users to change the priority assigned to the selected process. 

Views Displays the following options for changing the screen view: 
• Start Time/Ecl. Users/Program/Status 
• Start Time/Start Date/Program/Status 
• Start Time/Process ID/Program/Status 

Proc Stat Displays the status of the process on which the cursor is positioned. 
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Hot Key Function 
Time Zone Displays a prompt where you can change the time zone in which the processes 

on the screen are displayed. 

Log Displays the Phantom Activity Log Viewing screen, where you can view the log 
of phantom process activities. 

Status Toggles the Phantom Manger view to the Phantom Status view, where you can 
view process status. 

Opts Displays the Phantom Maintenance screen, where you can edit the system 
phantom parameters that control the number of phantoms running. 

5. Press Esc to exit the screen. 

 



Rel. 8.6.6 (Eterm) System Maintenance 

© 2009  Activant Solutions Inc. All rights reserved. 103 

Killing Processes 
The Kill a Process function stops selected active NT or Unix processes from running.  

Note: We recommend that only the system administrator use this function. 

To kill a process running in the Phantom: 

1. From the System > System Programming menu, select Kill a Process. 

Note: You can also access this function using the Kill Proc hot key on the 
Phantom Status screen. 

2. At the Enter Search Pattern prompt, enter selection criteria to match against the 
program IDs, user IDs, and program names in the system and press Enter.  

The system lists all processes that match the selection criteria on the Choose Process to 
Kill screen.  

Note: If you don't enter a search pattern, the system selects all processes. 

3. To kill a process, do one of the following: 

• Position the cursor on "Prompt" and press Enter to have the system prompt you to 
stop each listed process one at a time.  

• Position the cursor on "All" and press Enter to stop all listed processes. 

• Position the cursor on a process and press Enter to stop that process. 

Note: The system records killed processes in the System Activity Log. 

4. Press Esc to exit the screen. 

To kill or reschedule a report running in the Phantom: 

1. From the System menu, select Phantom Status to display the Phantom Status screen. 

2. Position the cursor on the report to kill or reschedule, and use the Kill hot key. 

3. At the Action to take on this process prompt, enter one of the following: 

• Kill – Stops the report from running. If you select this option, the system sends you a 
message telling you that the report was killed and by whom. 

• Reschedule – Displays the Phantom Scheduler screen, where you can reschedule the 
report for a future time. See Scheduling Phantom Processes for more information. 

4. Press Esc to exit the screen. 
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Viewing the Phantom Activity Log 
The Phantom Activity Log includes information about what phantom processes were run, who 
ran them, when they started, when they completed, and the parameters they used. Each log entry 
represents a single phantom process from start to finish. The system administrator can view the 
log to assist with root cause analysis and performance concerns. 

To view the phantom activity log: 

1. From the System menu, select Phantom Status to display the Phantom Status screen. 

2. Use the Log hot key to display the Phantom Activity Log Viewing screen. 

The screen displays the following information for each log entry in view-only mode: 

Field Description 

User ID User ID of the person, if any, who entered the log activity. 

Date Day the log activity occurred. 

Time Time of day the log activity occurred. 

Comment 
Description of the log activity that occurred. The system logs the following 
information: 

• When a process started, who started the process, all parameters the process used, 
such as branch, selection criteria, and sort criteria, and how long the process has 
been waiting to queue, if applicable. 

• When a phantom is stopped, including who killed the process. 
• When a phantom finishes, including the run time. 
• Whether the process was started from a menu or the scheduler. 
• Changes made when a schedule is edited, including the from and to values. 
• Process name. 
• Where the process ran: on the Hotswap or Local server and if the default value 

was overridden, even if you do not have a Hotswap server. 
• Processes queued because the user’s limit is exceeded. 
• Processes queued because the system’s limit is exceeded. 

3. Use the following hot keys as needed: 

Hot Key Function 
Select  Displays the Selection Criteria screen, where you can enter selection criteria to 

filter the list of logs. 

Parameters Displays the Phantom Parameters screen, where you can view the parameters 
assigned to the phantom process arguments. 

UserQ Displays your User Job Queue Viewing screen. 
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Hot Key Function 
JobQ Displays the Call Tracking Entry screen, where you can create a tracker for a 

customer, vendor, or user.  
• The system first prompts you to select User, Customer, or Vendor.  
• Then the system displays the Call Tracking Entry screen and populates the 

Comment field with a reference to this log entry. 
• After completing the tracker, the system adds an entry to the Phantom Activity 

Log, showing the ID of the tracker that you created.    

Delete By Date Use the Delete hot key to delete the log entry on which the cursor is positioned. 
The system does not prompt you for confirmation. 
Use the By Date hot key to delete all log entries older than a designated date. The 
system prompts you to enter the date. 

Error Displays the errors associated with a failed process. When errors exist, the hot 
key is red. 

4. Press Esc to exit the screen. 

 



Eclipse System Maintenance Rel. 8.6.6 (Eterm) 

106 © 2009  Activant Solutions Inc. All rights reserved. 

Viewing Phantom Process Parameters 
The Phantom Parameters screen displays the raw data values assigned to the arguments of a 
phantom process. 

To view phantom process parameters: 

1. From the System menu, select Phantom Status to display the Phantom Status screen. 

2. Use the Log hot key to display the Phantom Activity Log Viewing screen. 

3. Position the cursor on a log entry and use the Parameters hot key to display the Process 
Parameters screen. 

The screen lists each argument and value. Use the Multi hot key to view multiple 
parameters passed in for a designated argument. 

4. Press Esc to exit the screen. 
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Setting Up Branch Access to Eclipse Help 
Use the following instructions to set up branch access to the Eclipse Help from a: 

• Web server. 

• Share or local server. 

To set up branch access to Eclipse Help from a web server:  

1. Set up a web server whose home directory points to the default directory for Eclipse 
Help. For example, set up C:\Program Files\Eclipse\Eclipse Release 8 Help-Beta. 

2. On the Properties tab for the website you created for the Eclipse Help, select the 
Documents tab and enter MasterProject.htm in the Enable Default Contents Page 
field. 

3. From the System > System Files menu, select Control Maintenance to display the 
Control Maintenance screen. 

4. In the Keyword field, enter URL or UNC Path To Eclipse Help to display that control 
maintenance record.  

5. For each branch that you want to access the Eclipse Help system, enter the DNS name of 
the website you just set up followed by MasterProject.htm.  

The syntax for each branch should read: http://DNS_name/MasterProject.htm.  

To set up branch access to Eclipse Help from a share or local server: 

1. Set up share on your local server and share out with read permissions. 

2. From the System > System Files menu, select Control Maintenance to display the 
Control Maintenance screen. 

3. In the Keyword field, enter URL or UNC Path To Eclipse Help to display that control 
maintenance record. 

4. For each branch that you want to access the Eclipse Help system, enter the syntax 
file://ServerName/ShareName/Masterproject.htm, where ServerName is the name of 
the server off of which you set up the share, and ShareName is the name of the share you 
just created for the Eclipse Help folder. 
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