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Disclaimer 
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date of publication. However, Epicor Software Corporation makes no guarantee, representations or warranties with 
regard to the enclosed information and specifically disclaims any applicable implied warranties, such as fitness for a 
particular purpose, merchantability, satisfactory quality or reasonable skill and care. As each user of Epicor software 
is likely to be unique in their requirements in the use of such software and their business processes, users of this 
document are always advised to discuss the content of this document with their Epicor account manager. All 
information contained herein is subject to change without notice and changes to this document since printing and 
other important information about the software product are made or published in release notes, and you are urged to 
obtain the current release notes for the software product. We welcome user comments and reserve the right to revise 
this publication and/or make improvements or changes to the products or programs described in this publication at 
any time, without notice. The usage of any Epicor software shall be pursuant to an Epicor end user license 
agreement and the performance of any consulting services by Epicor personnel shall be pursuant to Epicor's standard 
services terms and conditions. Usage of the solution(s) described in this document with other Epicor software or 
third party products may require the purchase of licenses for such other products. Where any software is expressed 
to be compliant with local laws or requirements in this document, such compliance is not a warranty and is based 
solely on Epicor's current understanding of such laws and requirements. All laws and requirements are subject to 
varying interpretations as well as to change and accordingly Epicor cannot guarantee that the software will be 
compliant and up to date with such changes. All statements of platform and product compatibility in this document 
shall be considered individually in relation to the products referred to in the relevant statement, i.e., where any 
Epicor software is stated to be compatible with one product and also stated to be compatible with another product, it 
should not be interpreted that such Epicor software is compatible with both of the products running at the same time 
on the same platform or environment. Additionally platform or product compatibility may require the application of 
Epicor or third-party updates, patches and/or service packs and Epicor has no responsibility for compatibility issues 
which may be caused by updates, patches and/or service packs released by third parties after the date of publication 
of this document. Epicor® is a registered trademark and/or trademark of Epicor Software Corporation in the United 
States, certain other countries and/or the EU. All other trademarks mentioned are the property of their respective 
owners.  

Copyright © Epicor Software Corporation. All rights reserved. No part of this publication may be reproduced in any 
form without the prior written consent of Epicor Software Corporation. 
Publication Date: October 17, 2018 

 



Assigning and Updating Prices 

iii 

Table of Contents 
Pricing Management Overview .................................................................................................................... 1 

Product Pricing Overview ......................................................................................................................... 3 

About Product Prices on Orders................................................................................................................ 3 

Assigning Pricing Criteria to Products.......................................................................................................... 4 

Assigning Products to Buy or Sell Groups ................................................................................................... 6 

Assigning Products to Commission Groups ................................................................................................. 7 

Assigning Price Sheet Discount Classes to Products .................................................................................... 8 

Assigning Pricing Values to Product Price Sheets ........................................................................................ 9 

Assigning Product Level Quantity Breaks .................................................................................................. 12 

Quantity Break Guidelines .......................................................................................................................... 13 

Viewing and Editing Price Sheets in Product Pricing ................................................................................. 15 

Changing Product Ranking ......................................................................................................................... 17 

Viewing and Editing Branch Costs ............................................................................................................. 18 

Inquiring About Branch Costs .................................................................................................................... 20 

Defining Additional Product Pricing Criteria ............................................................................................. 22 

Pass-Along Discount Details ...................................................................................................................... 24 

Inquiring About Product Pricing ................................................................................................................. 25 

Auto Price Updating Overview ................................................................................................................... 27 

Importing Price Update Files into Eclipse .................................................................................................. 28 

Changing the Auto Price Update Format .................................................................................................... 30 

Defining Auto Price Update Parameters ..................................................................................................... 31 

Deleting Price Update Templates ............................................................................................................... 35 

Creating Price Sheets in Auto Price Update ............................................................................................... 36 

Assigning Formulas to Price Sheets............................................................................................................ 37 

Creating Default Product Profiles ............................................................................................................... 39 

Defining Unit of Measure Codes for Price Updates ................................................................................... 41 

Transferring Price Update Data to Product Notes....................................................................................... 42 

Scanning Price Update Files ....................................................................................................................... 44 

Verifying Data on Price Sheets ................................................................................................................... 45 

Matching Products During Price Updates ................................................................................................... 46 

Auto Updating Product Pricing Information ............................................................................................... 47 

Adding New Products While Updating Prices ............................................................................................ 49 

Preparing Vendor Update Files for the Matrix Upload Utility ................................................................... 50 



Table of Contents 

iv 

Defining the File Format for Price Updates ................................................................................................ 53 

Creating User-Defined Matrix Cells During Price Updates ....................................................................... 54 

Updating Trade Service Prices .................................................................................................................... 60 

Defining Product Details for Trade Service Updates .................................................................................. 63 

Price Sheet Entry Overview ........................................................................................................................ 64 

How Eclipse Handles Price Sheet Hierarchies ........................................................................................... 65 

Default Price Sheets ................................................................................................................................ 65 

Local Price Sheets ................................................................................................................................... 65 

About Product Price Sheet Dates ............................................................................................................ 65 

Selecting Price Sheets ................................................................................................................................. 67 

Changing Price Sheet Effective Dates ........................................................................................................ 68 

Limiting the Product List in Price Sheet Entry ........................................................................................... 69 

Printing Price Worksheets for Manual Updates .......................................................................................... 71 

Manually Updating Prices ........................................................................................................................... 72 

Copying Price Sheets .................................................................................................................................. 75 

Maintaining Price Sheets for Different Branches ....................................................................................... 76 

Generating Price Sheets .............................................................................................................................. 78 

Defining Data Sources and Columns for Price Sheets ................................................................................ 84 

Customizing Price Sheet Headers ............................................................................................................... 89 

Defining Price Sheet Download Parameters ............................................................................................... 91 

Buy and Sell Group Overview .................................................................................................................... 92 

Pricing Group Guidelines for Matrix Cells ................................................................................................. 93 

Creating Buy and Sell Groups .................................................................................................................... 95 

Assigning Group IDs to Buy or Sell Groups .............................................................................................. 97 

Naming Groups ....................................................................................................................................... 97 

Changing Buy and Sell Group IDs ............................................................................................................. 98 

Combination Group Pricing Details ............................................................................................................ 99 

Combining Sell Groups for Quantity Break Pricing ................................................................................. 101 

Quote Pricing Overview ........................................................................................................................... 103 

Quote Pricing Workflow ....................................................................................................................... 104 

Creating Quote Pricing ............................................................................................................................. 105 

Assigning Price Groups and Products to Quotes ...................................................................................... 106 

Price Tags Overview ................................................................................................................................. 108 

Regular Price Tags ................................................................................................................................ 108 

Special Price Tags ................................................................................................................................. 108 



Assigning and Updating Prices 

v 

Price Tag Print Queue ........................................................................................................................... 108 

Price Tag Reprint Queue ....................................................................................................................... 109 

Setup Requirements for Price Tags ........................................................................................................... 110 

Creating Sell Matrix Cells for Printing Price Tags ................................................................................... 111 

Defining Promotional Codes for Price Tags ............................................................................................. 112 

Adding Product Details on Price Tags ...................................................................................................... 113 

Adding Product Classifications to Product Files .................................................................................. 113 

Setting Classification Types in Price Maintenance ............................................................................... 113 

Checking for Price Tag Updates ............................................................................................................... 115 

Printing Price Tags .................................................................................................................................... 116 

Populating the Price Tag Print Queue ................................................................................................... 116 

Printing Price Tags ................................................................................................................................ 118 

Manually Adding Tags ......................................................................................................................... 118 

Purging the Price Tag Queue ................................................................................................................ 118 

Index ......................................................................................................................................................... 119 





1 

Pricing Management Overview 
Eclipse Pricing Management helps you maintain consistent costing and pricing information. From 
updating price sheets to reporting on sales outcomes and commissions earned, Pricing Management 
provides a reliable and accurate way of costing and pricing merchandise. 

This section of the documentation discusses standard pricing logic. For information about using the 
Strategic Pricing companion product, see Eclipse Strategic Pricing Overview. 

Price Updates 

Vendors supply their price information to you through price sheets or price update files. You can then 
update your pricing information manually or automatically. The system can also automatically add 
product records for new products during a price update. 

Price Lines 

When new products are added to the product file they are assigned to price lines. Price lines are groups of 
products used for sales performance reporting, unit of measure descriptors, and commission groups. Price 
lines provide default information for the products within a price line. 

Price Sheet Entry 

Vendors provide basis names associated with a dollar amount on the vendor's price sheet. Each vendor 
may use different basis names to define their pricing, so cross-reference vendor basis names with Eclipse 
basis names to create a standard pricing scheme for each price line. 

Pricing Matrix 

The system prices items using a pricing matrix. A sell matrix defines the pricing rules for your sales, 
branch transfers, and adjustments. A buy matrix defines pricing rules involving the costs for products on 
purchase orders. 

Within each matrix cell, a formula and a basis name calculation defines the cost or price on an order. You 
can include the following price- or cost-determining factors in matrix cells: 

• Buy and sell groups that share the same pricing rules. 

• Quantity break pricing that offer discounts for buying quantity. 

• Combination groups that offer quantity break discounts on the combined total of items. 

• Rebate pricing that offers customers discounts directly from your vendors. 

You can use the standard pricing matrix hierarchy set up in the Eclipse system, which is not configurable, 
or you can configure your system to use a pricing procedure designed for your business needs. 

Commissions 

Set up your salespeople with commission plans that regulate how the system calculates commissions for 
each salesperson. Set up commission plans to calculate commissions based on one of the following: 

• Gross profit dollars 

• Sales dollars 
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• Net sales dollars 

• Items sold as members of a product commission group 

Quotes 

Use Quote Maintenance to offer special pricing to customers during limited periods. 
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Product Pricing Overview 
When you create a product record in Product Maintenance or by adding a product through an automatic 
price update, the system uses the following criteria to determine the correct price or cost for the product: 

• Buy and sell groups - Classify buying and selling criteria into groups of products. 

• Discount classes - Assign each formula a price sheet discount class when price sheets have 
different pricing formulas for different items. 

• Commission groups - Assign products to commission groups if you calculate commissions on 
products. 

• Package quantities - Assign a sell package quantity for a product at each branch. 

• Freight charges and freight factors - Assign a freight charge to be added to a sales order each 
time a product is ordered from a branch. 

• Quantity breaks - Assign quantity breaks at the product level to encourage increased sales for 
some products. 

About Product Prices on Orders 
Standard sales orders do not display any special symbols or characters. However, when a prices displays 
in bold text, that indicates special pricing has been applies.  

The following symbols display after a price on an order when special pricing or overrides apply: 

Symbol Description 

L A lot billing item. 

* Indicates the price or cost show has a manual override. 

+ Indicates contract matrix pricing. 

# Price based on  customer-specific matrix pricing. 

! Price based on customer-specific cost matrix. 

R A rebate cost override. 

^ Strategic Pricing or Strategic Costing price cube factors applies. This can be displayed in 
combination with # or +. 

J Small Project Job pricing. 
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Assigning Pricing Criteria to Products 
Define pricing criteria for products in the product record to ensure that the product maintains these pricing 
criteria regardless of what group or branches are placed on an order. 

Set the following criteria for products in the product record: 

• Product-level quantity breaks 

• Product rank 

• Discount class 

• Commission group 

• Serial number tracking 

To assign pricing criteria to a product: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. In the Product field, enter a product ID to display the product record. 

3. Select Pricing > Product Price Maintenance to display the Product Price Maintenance dialog 
box. 

4. Select File > Hierarchy, enter a branch, and click OK to view the settings for a specific branch 
and where those settings came from. All territories that contain that branch display in the Branch 
/Territory  column below the branch, in the order of the  territory priority. For more information, 
see Branch Hierarchy Details. 

5. Complete the following fields as needed: 

Field Description 
Price As Enter the product ID whose pricing will be copied. Use this option for one of the 

following reasons: 
• To assign to this product the same price sheet that is assigned to another 

product. These price sheets use corresponding effective dates and prices. 
• When the product is a substitute for another product. This eliminates the need 

to populate the product's pricing information on the Product Price Sheet 
Maintenance window (Files > Product > Pricing > Price Sheet). 

Matrix Type enter the product matrix type to override the customer price class used to price 
this product. This field is required only if the Valid Product Matrix Types 
control maintenance record is populated. 
Without a matrix type defined, when pricing a product, the system determines the 
ship-to customer’s price class from either a branch-specific price class override 
or from the default price class override. 
With a matrix type defined, the system looks at the ship-to customer’s price 
class/product matrix type pairings to determine a price after looking at the 
branch-specific override, and before using the default price class. If the product 
has no matrix type, or if the customer has no price class/product matrix type 
pairing, then the system uses the default price class to determine a price. 
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Field Description 
Serial Number 
Option 

Do one of the following: 
• Enter a code to determine the tracking type use for the product in each branch. 

Set this option when the product is subject to serial number tracking. 
• Enter N (no serial tracking) if the product has no serial number tracking. 

Commission 
Groups 

Enter the appropriate commission group, if required. 

Sell Package 
Quantity 

Enter a number to allow only order quantities that are evenly divisible by this 
number. 
The unit of measure associated with the sell package quantity is the base unit of 
measure listed in Product Maintenance. 
Users assigned the SOE.PACKAGE.QTY authorization key can override this 
restriction. 

Price Sheet Enter a name of a price sheet to maintain different price sheets for different 
branches. 

Discount Class Assign price sheet discount classes to products in defined branches. 

6. Complete the following menu items as needed. 

Menu Item Description 
Pricing > Price Sheet Use to create a new effective date for a price sheet for a product, and then 

assign values to its cost and price bases. If you enter a product in the Price 
As field on the Product Price Maintenance window, pricing information will 
be copied from that product. 

Pricing > Ranks Displays the branch ranking information the last time the ranking process 
was run for a product. 

Pricing > Quantity 
Break 

Use to assign product-level quantity breaks to use for a product-specific 
pricing matrix cell that is assigned the P (product) matrix type. 

Pricing > Branch 
Costs 

Shows average cost, last cost, landed average cost, and landed cost for the 
product in the branches to which you have access. 

Pricing > Additional 
Data 

Use to assign the following settings for products on the Additional Price 
Maintenance window: 
• Freight factor 
• Freight charges 
• Pass-along discounts 
• Label printing specifications 

Pricing > Groups Use to assign a product to buy or sell groups. 

File > Find Branch At the prompt, enter the branch to find in the list and click OK. 

File > Insert Branch Adds the branch to the list that is selected at the prompt. 

7. Save your changes and exit the dialog box. 
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Assigning Products to Buy or Sell Groups 
Buy groups and sell groups are subsets of the product file that group products with common pricing. Buy 
groups and sell groups are assigned to products by branch, so a product can be in a different group at 
different branches. 

Set up sell and buy groups as follows: 

• Containing products from the same price line. For example, in the Delta price line, you buy and sell 
faucets priced in three different groups: CHROME, BRASS, and GOLD. 

• Containing the same type of product from different price lines. For example, you buy copper 
fittings from both the NEER and RACO price lines. Because the pricing is the same regardless of 
which price line you use, set up the group COPPER to include products from both price lines. 

• Containing products that you want to group together for any selling purpose. 

Define sell groups and buy groups before assigning products to groups. 

To assign a product to sell or buy groups: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. In the Product field, enter the product ID to display the product record. 

3. Use the Price hot key to display the Product Price Maintenance dialog box. 

4. Select File > Hierarchy, enter a branch, and click OK to view the settings for a specific branch 
and where those settings came from. All territories that contain that branch display in the Branch 
/Territory column below the branch, in the order of the  territory priority. For more information, 
see Branch Hierarchy Details. 

5. Select Pricing > Groups to display the Price Group Maintenance dialog box. 

6. Select Edit > Hierarchy to enter a branch. All the territories in which that branch resides display 
under the branch name in the Branch field. 

7. In the Sell Group and Buy Group fields, enter the sell group or buy group for each branch, up to 
20 characters, to which this product belongs. By default this field displays the name of the price 
line. 

8. Use the Multiple Item button to assign multiple buy or sell groups in each field. When a 
customer orders a product with multiple sell groups, the system checks the matrix cells for the 
sell groups in the list from top to bottom in search of a match. When it finds a match: 

• And Best Price Check is activated, the system continues searching through the group matrix 
cells for the best price. 

• And Best Price Check is not activated, it stops searching regardless of whether the matrix cell 
for a group lower in the list has a better price. 

To rearrange the order in which the system searches the group matrix cells, rearrange the group 
order. 

9. Save your changes and exit the dialog box. 
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Assigning Products to Commission Groups 
Commission groups organize products into categories used to determine commissions on sales. These 
groups help you customize the commission plans for your products and salespeople. For example, you 
may want to encourage your salespeople to push a certain set of products, so you set up a commission 
group that pays higher commissions on those products. You may want to pay commission on only 
selected products, so you set up commission groups only for those products; all other products do not 
contribute to a commission plan. 

Set up commission groups in the Valid Product Commission Groups control maintenance record. 

For more information, see Product Commission Group Details. 

To assign a product to a commission group: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. In the Product field, enter a product's name to display the product record. 

3. Select Pricing > Product Price Maintenance to display the Product Price Maintenance dialog 
box. 

4. Select File > Hierarchy, enter a branch, and click OK to view the settings for a specific branch 
and where those settings came from. All territories that contain that branch display in the Branch 
/Territory column below the branch, in the order of the  territory priority. For more information, 
see Branch Hierarchy Details. 

5. In the Commission Groups column, for each branch, enter a commission group, if necessary. 

If this column is blank for a branch, the system uses DEFAULT as its commission group. 
Therefore, if a commission plan is set up to calculate the sales commission on the sales order 
total, or if a product that is not assigned a commission group is sold, the system calculates 
commission using the default commission group. 

6. Save your changes and exit the dialog box. 
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Assigning Price Sheet Discount Classes to Products 
A discount class is a category set up for a product within a price line and is used to group products for 
pricing purposes. For example, within a price line, a vendor sells one group of items at LIST less 30, 
while selling another group at LIST less 40. When a price sheet has different pricing formulas for 
different items, classify the items by formula within that price sheet, and assign each formula a price sheet 
discount class. 

The vendor may give you the name of the discount classes to which some products belong, or the vendor's 
price sheets may display only the products and their discounts. In which case, you can define the 
appropriate number of discount classes within the price line. Then, manually assign each product to the 
correct discount class. 

A product cannot have different classes assigned to branches with the same price sheet assignments. For 
example, if branches 1, 2, 3, and 4 all use the same price sheet and a product in branch 1 is assigned to 
discount class A, the product must also be assigned to discount class A in branches 2, 3, and 4. 

To assign a price sheet discount class to a product: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. In the Product field, enter the product ID to display the product record. 

3. Select Pricing to display the Product Price Maintenance dialog box. 

4. Select File > Hierarchy, enter a branch, and click OK to view the settings for a specific branch 
and where those settings came from. All territories that contain that branch display in the Branch 
/Territory  column below the branch, in the order of the  territory priority. For more information, 
see Branch Hierarchy Details. 

Note: The system may adjust other branch information for updates on price sheets and 
discount classes to maintain a discount per price sheet requirement. We 
recommend reviewing the table after changes to verify any automatic adjustments. 

5. In the Discount Class column, do one of the following: 

• Enter a discount class. 

• Create a discount class by entering an alphanumeric name for the discount class, up to 10 
characters. Then enter different formulas for each discount class in Price Sheet Entry. Set up 
any discount classes you plan to use before entering price sheet information. 

Name the discount class in relation to the discount being offered. For example, define discount 
classes as 18, 20, 22 and Net for 18 percent, 20 percent, and 22 percent discounts, and for Net 
price, respectively. 

Note: When items in a price line are separated into discount classes, update the prices by 
discount class. In Price Sheet Entry, you can copy the prices from one discount 
class to another if many of the prices are the same. Then, make any necessary 
changes to the prices in the target discount class. 

6. Save your changes and exit the dialog box. 
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Assigning Pricing Values to Product Price Sheets 
Create a new effective date, assign values to the cost and price bases, and adjust quantities on the product 
price sheet to assign pricing criteria to a product. 

Apply the following guidelines to maintaining price sheets for products: 

• Use one price sheet for a price line if your company has one branch, or multiple branches that all 
use the same costs or prices. The system identifies that price sheet by one of the following: 

• The name of the price line followed by a tilde (~), which is called the null price sheet. 

• The name of the price line followed by a tilde followed by the same user-defined suffix that 
was assigned to all of the branches. 

• Use the name the system assigns as the null price sheet name when a price line has only one price 
sheet. 

• Use multiple price sheets when costs and prices for a product are not the same in all branches. 

A product might have more than one price sheet if your company has geographically widespread branches 
that cause different branches to obtain the same products from different vendors. Typically, a company 
does not use multiple price sheets because costs and prices are the same in all branches. 

The Number Of Days After Which Users Can Edit Old Prices control maintenance record and the 
PRICE.SHEET.MAINT authorization key work together to allow viewing and editing of information on 
the Product Price Sheet Maintenance window.   

To assign pricing values to a product price sheet: 

1. From the Maintenance menu, select Product to display the Product Maintenance window, and 
enter the product ID for which you want to assign a discount class. 

2. Select Pricing > Price Sheet Maintenance to display Price Sheet Maintenance window. 

When you display the Price Sheet Maintenance dialog box: 

• The price sheet effective dates display to the left of the table. 

• If the product is new, the table displays the cost and price basis names and the price sheet 
assigned by the system, but does not display prices for the effective dates. 

• If you entered a product in the Price As field on the Product Price Maintenance window, you 
can assign values to the cost and price basis names, and you can edit the values, if necessary. 

• If this product has different price sheets assigned to the price line, the screen displays a list of 
all the price sheets assigned to the product's price line. Select the price sheet for the branch 
whose prices you want to view or edit. The screen then displays basis values for as many as 
five effective dates for the price line. 

• If the price sheet inherits some values from the default price sheet (~ price sheet), the values 
display in gray, italicized text. 

• If the value is left blank, the system completes blank cells with the next active price in the 
dates below it. 

Note: The price sheet only inherits its value if the most recent date is blank. The local 
sheet settings take priority. This setup ensures that if you can use a default price 
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sheet to keep most settings for price sheets throughout your company the same, 
but adjust a setting for a local branch that make handle costs differently. For more 
information, see How Eclipse Handles Price Sheet Hierarchies. 

The following fields and columns apply to Price Sheet Maintenance: 

Field Description 
Description The product description from the Product Maintenance window. 

Price Sheet One of the following displays: 
• If the product's price line has only one price sheet, the product's price sheet displays 

having only a null price sheet, implies that the product's costs and prices are the 
same in all branches of the company. 

• Select a price sheet from the list of existing price sheets if the price line has 
multiple price sheets that contain data on this product. 

Currency Any foreign currency assigned to the basis in Price Line Maintenance. This field is 
read-only. 
• If a foreign currency displays in this field, the cost or price you enter in an effective 

date column for a basis is calculated in this foreign currency. 
• If this field is blank, the cost or price you enter in an effective date column for a 

basis is calculated in your company’s base currency. 

Per The unit of measure used to price the product. For example, per each, per box, per 
case, per c (hundred), per m (thousand), and so forth. 

Note: You must have a per quantity and per unit of measure (UOM) on a least one 
price sheet per product. By default, the system uses the default UOM from the price 
line and the lowest UOM. 

Per Qty The number of units contained in the unit of measure entered in the Per field. For 
example, if the Per is box, the Per Qty might be four per box. 

Note: You must have a per quantity and per unit of measure (UOM) on a least one 
price sheet per product. By default, the system uses the default UOM from the price 
line and the lowest UOM. 

Basis name 
columns 

The local basis assigned in the Basis Names column on the Price Line Maintenance 
window for the product's price line, supplied by the system after you enter all the 
information necessary to select the price sheet. You can have as many as 20 basis 
name columns. 

4. Save your changes and exit the dialog box. 

More Options 

The following are common options you might use while assigning pricing values to product price sheets: 

To... Select this menu option... 
return the screen to its settings before you started 
making changes 

File > Recall 

display all effective dates for a specific price sheet View > All Effective Dates 
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To... Select this menu option... 
select a specific effective date for the price sheet Edit > Effective Dates 

To edit blank entries, ensure that the All 
Effective Dates option under the View menu 
is selected. 

display a record of all pricing-related changes to the 
product on the price sheet, and any corresponding 
user-supplied reason for change 

File > Maintenance Log 

check the values set to inherit from a default price 
sheet 

Pricing > Price Line Maintenance 
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Assigning Product Level Quantity Breaks 
Assign product-level quantity breaks to be used for a product-specific pricing matrix cell. These matrix 
cells must be assigned the P matrix type. You can list up to five quantity breaks on a matrix cell. 

To assign a product-level quantity break: 

1. From the Maintenance menu, select Product to display the Product Maintenance window, then 
enter the Product ID to display the product record. 

2. Select Pricing > Product Price Maintenance to display the Product Price Maintenance dialog 
box. 

3. Select File > Hierarchy to enter a branch. All the territories in which that branch resides display 
under the branch name in the Branch or Territory column. 

4. Select Pricing > Quantity Break to display the Quantity Breaks dialog box. 

5. Select File > Hierarchy, enter a branch, and click OK to view the settings for a specific branch 
and where those settings came from. All territories that contain that branch display in the Branch 
/Territory  column below the branch, in the order of the  territory priority. For more information, 
see Branch Hierarchy Details. 

6. In the Break1 through Break5 columns, enter the quantity for each price break. 

For example, price breaks for a steel bolt with units of measure defined as ea and bx that comes 
100 to a box could be defined as follows: 

• Break1 - 25ea 

• Break2 - 50ea 

• Break3 - 1bx 

• Break4 - 5bx 

• Break5 - 10bx 

The default unit of measure is flagged as the default sell unit of measure on the Product 
Maintenance window. You can also create breaks with any unit of measure defined for the 
product, or use a weight or dollar amount. For more information, see Working With Quantity 
Breaks. 

7. Save your changes and exit the dialog box. 
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Quantity Break Guidelines 
Offering your customers quantity breaks encourages them to buy more product at a lower cost to them. 
For each point increase in quantity, the cost of items decreases, as shown below. 

 
For example, a customer who buys 25 to 50 of an item priced with this matrix cell receives a 20 percent 
discount, and a customer who buys 500 or more receives a 50 percent discount. 

This diagram shows the quantity break set up as follows: 

• Five quantity breaks in the Quantity Range column. 

• Quantity breaks start at 25 pieces. The first quantity break range is 25 to 49 pieces. The second 
quantity break range is 50 to 99 pieces. 

• The basis and formula for each quantity break determine the price for those package quantities. 

Note: When pricing items, the system looks to the product unit of measure first, and then 
to the price line unit of measure. 

You can price quantity on the following pricing factors: 

• Pieces 

• Weight (#) 

• Dollars ($) 

• Load Factor (L) (for sell matrix only) 

Pieces 

When using pieces as units, define the breaks using the lowest defined unit of measure for the product or 
products in the price line. The following table describes where the system finds unit of measure 
information. 

For the 
matrix type... 

The system... 

C (combination) defines the unit of measure and quantity breaks on the Combination Group 
Maintenance window. 

G (group) displays the unit of measure for the sell group in the Group Price Unit of 
Measure field on the Buy/Sell Group Maintenance window. 
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For the 
matrix type... 

The system... 

M (matrix) validates the entry against the lowest unit of measure defined for the product or 
price line. 

P (product) uses the unit of measure defined on the Product Maintenance window for the 
quantity breaks for the product. 

Weight 

Weight is the value assigned to a product in the LBS/ field on the Product Maintenance window. To use 
weight to define quantity breaks, enter the pound sign (#) after the number in the Quantity Breaks 
column on the Sell Matrix Maintenance window. 

Dollars 

To use dollars to define quantity breaks, enter the dollar sign ($) after the number in the Quantity Breaks 
column on the Sell Matrix Maintenance window. If you buy products by quantity break costing on a 
dollar amount, on the buy matrix, use LIST as the local basis, and assign it to the global basis PURC-
BREAK in the price line record associated with the product. The system uses this setup to determine if 
the break point has been reached. 

Note: To provide a discount to a customer who purchases large dollar amounts from you, 
use the global basis SELL-BREAK for sales orders. 

Load Factor 

Load factor applies only to the sell matrix. The cubic dimensions of a product or the point value of a 
product (as expressed on a vendor specification sheet). A load factor is assigned to a product in the Load/ 
field on the Product Maintenance window. To use load factor to define quantity breaks, enter L after the 
number in the Quantity Breaks column on the Sell Matrix Maintenance window. 

Requirements for Setting Up Quantity Breaks 

On the Price Line Maintenance window: 

• For the sell matrix, cross-reference the local basis name for customer price breaks to the SELL-
BREAK global basis. 

• For the buy matrix, cross-reference the local basis name for your price breaks from vendors to the 
PURC-BREAK global basis. For more information, see Creating a Price Line. 

To set up quantity breaks from your vendors use Buy Matrix Maintenance, and to set up quantity breaks 
for your customers use Sell Matrix Maintenance. 

The following control maintenance records work with quantity break pricing: 

• Quantity Break Display Percentage - Determines how close an order quantity must be to the next 
quantity break before the system informs you on the purchase order of how much more you need to 
buy to receive the next quantity break. 

• Display All Quantity Breaks - Works with the Quantity Break Display Percentage control 
maintenance record so all quantity breaks and corresponding costs are displayed. 
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Viewing and Editing Price Sheets in Product Pricing 
All the products in a price line typically experience price changes as a group. Maintain a record of the old 
prices and retain the prices on previous dates by creating a new effective date for the price sheet, instead 
of overwriting and losing the old prices. When you enter a new price sheet for a product, the system 
inserts the row at the top of the window. So, the most recent effective price sheet displays first. 

Each price sheet can have any number of effective dates. For example the price sheet DEL~ has three 
price sheets on file, one each for effective dates 01/01/06, 01/01/08, and 01/01/09. On each effective date 
the system starts to use the price sheet with that date's cost and prices. You can retain price sheets with 
expired effective dates for up to 999 days. 

You must have the NONSTOCK authorization key to access the Product Price Sheet Maintenance 
window for a nonstock. 

To create a new effective date or edit an existing effective date on a price sheet: 

1. From the Maintenance menu select Product to display the Product Maintenance window. 

2. In the Product field enter a product ID to display the product record. 

3. Select Pricing > Product Price Maintenance to display the Product Price Maintenance dialog 
box. 

4. Select Pricing > Price Sheet to display the Price Sheet Maintenance dialog box. 

The system displays all price sheets assigned to this product and determines the columns to 
display based on the settings in Price Line Maintenance. 

Note: If the UOM or Per Qty rows are blank, the row inherits the values from the 
previous (earlier) price sheet. If your cursor is on the blank row, the Per UM and 
Per Qty display in the status bar. 

5. Adjust information in the cost columns, as needed, for the current price sheet associated with this 
product. 

6. To edit effective dates for the price sheet, select Edit > Effective Dates to display the Price Line 
Dates dialog box and complete the following fields: 

Field Description 
Purge Age 
(days) 

Enter the number of days to retain the effective date list before it is purged (up 
to 999 days). The default is 365 days. 
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Field Description 
Effective Do one of the following: 

• To create a new effective date for this price sheet, select the first blank line of 
the Effective column, and enter the new date. If no blank line displays, click 
Alt+Insert to add a new line. 

• To edit an effective date, select the date you want to change, and enter the 
new date. 

The columns to the right of the Currency field on the Product Price Sheet 
dialog box are used to assign and display the values for the cost or price bases 
for the product that go into effect on the displayed date. 
Since replacement cost is typically the cost assigned by the system to a 
product on a purchase order, every time there is a price change by a vendor, 
update the replacement cost so that the next time you purchase the product, 
the correct cost displays on the purchase order. 
• If you have entered prices in advance of the actual effective date, the 

system uses the costs and prices associated with the current effective date, 
unless overridden, until the date with the new costs and prices arrives. 

• If a cost or price is missing from the current effective date, the system uses 
the values on the previous effective date. 

• If you make a change to information on this window, the system displays a 
Reason for Change prompt where you can enter why you made the change. 
If you supply a reason, it will follow the Eclipse supplied log comment on 
the Maintenance Log Viewing window. 

Note: To delete old price sheet formulas in the Eclipse Product File use the 
Rebuild Price Sheet/Discount Class Cache Utility. For example, if a vendor 
gives you disks with new price sheets and discount classes, run this utility to 
delete the old price sheets and discount classes in your Eclipse Product File. 

7. Click OK to return to Price Sheet Maintenance. 

8. Save your changes and exit the dialog box. 
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Changing Product Ranking 
Product ranking is a means of categorizing products by quantity sold over time. Checking the results of 
the last time the Product Ranking program was run for a product's price line helps you maintain accurate 
product pricing. The system calculates ranks, but you can manually change product ranking for any of 
your branches when necessary. 

For example, a customer purchased a large volume of a D-ranked product in one day, turning the product 
into an A-ranked product. You can manually change the rank back to D to reflect the product's true sales 
volume. 

To change product ranking: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. In the Product field, enter a product ID to display the product record. 

3. Select Pricing to display the Product Price Maintenance dialog box. 

4. Select Pricing > Ranks to display the Rank Maintenance dialog box. 

5. In the Branch/Territory/All field, enter a branch or enter All to view results for all accessible 
branches. 

The Rank #1 through Rank #5 columns show the product's current rank and the ranking method 
assigned to this rank number when the Product Ranking program for this product's price line was 
last run. 

6. To change a rank, select the Rank # column for the branch you want to change, and enter the new 
rank. 

Note: Access the Ranking window for the products in a price line from the Price Line 
Maintenance window (Maintenance > Price Maintenance > Price Line > 
Ranking). If a product's rank is not what you expected rerun the price line ranking 
to update the report. The last-run ranking date displays on the Ranking window. 

7. Save your changes and exit the dialog box. 
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Viewing and Editing Branch Costs 
Compare the average cost, last cost, landed average cost, and landed cost for products in your branches. 
These costs are maintained at the branch level because buying patterns may differ from branch to branch. 

Each branch may pay a different price for the same product. For example, branch 1 buys a product every 
week, while branch 2 buys the same product once every three weeks. Also, the prices at the time of 
purchase may be different between branches because of the date that vendor price changes go into effect. 

Average cost and last cost are maintained by the costs entered on purchase, transfer, and inventory 
adjustment orders. The landed cost and landed average cost include freight charges. Freight charges may 
vary from branch to branch due to location. 

You must be assigned the PRODUCT.MAINT authorization key to view or edit data on the Branch Costs 
window. 

To view or edit branch costs: 

1. From the Maintenance menu, select Product to display the Product Maintenance window, and 
enter the product ID to display the product record. 

2. Select Pricing > Product Price Maintenance to display the Product Price Maintenance dialog 
box. 

3. Select Pricing > Branch Costs to display the Branch Costs dialog box. 

4. In the Branch/Territory/All field, enter the branch or territory ID, or enter All to view all 
branches available to the user. 

The remaining fields display the following information: 

The field... displays... 
UM (unit of measure) the unit of measure from the Price Sheet Maintenance window. 

Qty the quantity from the Price Sheet Maintenance window. 

Average Cost the average cost. 

Average Cost Definition 
(Current On-hand Quantity x Current Average Cost) + ( Incoming Quantity 

x Incoming Cost) 
Current On-hand Quantity +  Incoming Quantity 

Last Cost the last incoming cost for the product. For child branches, this is the last 
transfer cost. 

Landed Average the landed average cost, which is the average of landed cost, based on 
quantity. 

Landed Cost the landed cost, which is the cost on the purchase order plus freight. 
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5. Use the following menu items as needed: 

Menu item Description 
Edit > Freight Factor A freight factor is an estimated freight charge for a product, applied as a 

percentage of the purchase price. The system uses the freight factor to 
estimate freight charges on the purchase order if the actual freight charge is 
not known. 

Edit > Maintenance 
Log 

Displays the Maintenance Log Viewing window, which shows a history of 
comments made regarding changes to Branch Costs window. 

Edit > Activity Log Displays the history of all changes made to the Branch Costs window and 
who made them. To view branch cost activity, you must be assigned the 
BR.COST.ACTIVITY.VIEW authorization key. 

6. Save your changes and exit the dialog box. 
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Inquiring About Branch Costs 
You can view branch cost updates and related cost and quantity data for a product within a branch. You 
can determine how average cost or landed average cost changed over time. Transactions that can affect 
average or landed average cost include the following: 

• Returns, if the Should Credit Sales Order Update Avg/Last Cost control maintenance record is 
set to Yes. 

• Received transfers. 

• Purchase orders. 

• Manual changes in Product Maintenance. 

• Inventory adjustments. 

You must have the BR.COST.ACTIVITY.VIEW authorization key assigned to you to access the Branch 
Cost Inquiry screen. 

To inquire about branch costs: 

1. Access the Branch Costs Inquiry window in one of the following ways: 

• From the Orders > Inquiries menu, select Branch Cost Inquiry. The Branch field defaults to 
your home branch, and the cursor displays in the Reference column. 

• From the Maintenance > Product Maintenance window, enter a product, and then select 
Pricing > Product Price Maintenance. Then select Pricing > Branch Costs to display the 
Branch Costs dialog box. Then select Edit > Branch Cost Inquiry. 

2. View or edit the following fields: 

Field Description 
Branch Your home branch, by default, or if accessing this dialog box from Product Pricing, the 

branch selected on the previous dialog box. 
Your authorization level determines whether you can access this field. 

Product If accessing from order inquiry, enter the description of the product whose costs are 
displayed, otherwise the dialog box displays the description of the product you accessed 
in Product Maintenance. 
Your authorization level determines whether you can access this field. 
The list sorts in either ascending or descending order. You can change the sort order by 
selecting View > Change View if accessing the dialog box from order inquiry. 

As Of Date Displays the as-of date for the product. You can change this date. 

Cost Type Select between the landed average cost and average cost. The currently displayed cost 
type displays in the lower part of the window. 
The selected cost type and settings display the next time you access the window. 

3. Click the Update button to update the columns according to your selections. 

Column Description 
Reference The order transaction number that affected the average cost. 
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Column Description 
Date Date of the change to average cost. 

Prev. On Hand Quantity on hand before change. 

Prev. Cost Average cost before change. 

Qty The quantity of the item on the order that the system factored into the new 
average cost calculation. 

Cost The actual cost on order. 

On Hand Quantity of the product on hand after change. 

On Hand Cost Average cost of product after change. 

Customer/Vendor The customer or vendor associated with the sales or purchase order. Select View 
> Change View > Customer/Vendor to display this field. 

4. Select the options as needed. 

To... Select this menu option... 
display the order for the selected transaction in view-only 
mode. 

File > View Reference 

display the last Branch Cost Inquiry Print report run for this 
item. 

File > View Report 

display the Product Activity Log Viewing screen for the 
product and branch. 

File > Product Change Log 

displays a product's availability and inventory information. Inquiries > Inventory Inquiry 

displays information about future commitments for the 
product and branch if you are fully authorized. 

Inquiries > Future Ledger 

displays all transactions for the product and branch if you 
are fully authorized. 

Inquiries > Inventory History Ledger 

displays the product record for the selected product. Inquiries > Product Maintenance 

toggles between the Customer/Vendor view, and the basic 
view. 

View > Change View > 
Customer/Vendor  
or View > Change View >Basic View 

5. When finished viewing branch costs, exit the dialog box. 
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Defining Additional Product Pricing Criteria 
Add features to a product's pricing criteria, including, pass-along discounts, freight pricing, and label 
printing. Each feature on the Additional Price Maintenance window is optional, so apply only the steps 
you need from these instructions. 

To define additional product pricing criteria: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. In the Product field, enter a product ID to display the product record. 

3. Select Pricing > Product Price Maintenance to display the Product Price Maintenance dialog 
box. 

4. Select Pricing > Additional Data to display the Product Price Additional Data dialog box. The 
name of the product displays at the top of the dialog box. 

5. Select File > Toggle Hierarchy, enter a branch, and click OK to view the settings for a specific 
branch and where those settings came from. All territories that contain that branch display in the 
Branch /Territory column below the branch, in the order of the  territory priority. For more 
information, see Branch Hierarchy Details. 

6. In the Freight Charge column, to each branch, assign a static freight charge that is added to a 
sales order each time this product is ordered. 

7. In the Pass Along Discount column, enter the percentage discount to offer on this product. This 
amount is subtracted from the sale price of the product when purchased. A pass-along discount is 
a percentage discount from the vendor that you can pass-along to your customers. You can also 
assign pass-along discounts at the price line level. 

Note: Terms codes may affect the system's ability to apply a pass-along discount to a 
product. 

8. In the Print One Label Per column, enter the number of this product needed on an order before a 
product label prints, for example, one label per every 100 items. 

9. In the Freight Factor % column, enter an estimated freight charge for the product for this 
branch, as a percentage of the purchase price. The system uses this charge when the freight 
charge is not known at the time the purchase order is written. 

10. In the Print Price Sheet column, check the box to respect the product price maintenance 
Additional Data branch-specific flag to exclude a product from the price sheet report when 
selected by the Print Price Sheets Parameters tab.  This field works with the entry in the Respect 
Print Flag field on the Print Price Sheets window. The following table describes the results of 
your entries in these fields. 

If the entry in the product 
maintenance Print Price 
Sheets (Y/N) field is... 

and the entry in the 
Respect Print Flag (Y/N) 
field is... 

then... 

Yes (default) Yes the product is included on price 
sheets for the branch. 

No Yes the product is not included on 
price sheets for the branch. 
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If the entry in the product 
maintenance Print Price 
Sheets (Y/N) field is... 

and the entry in the 
Respect Print Flag (Y/N) 
field is... 

then... 

Yes No (default) the product is included on price 
sheets for the branch. 

No No the product is included in the 
report for the branch. 

11. Select Restrict Price Changes in OE for any branch to restrict users without the 
SOE.OVRD.NO.PRC.CHANGE authorization key from making changes to the price of this item 
in Sales Order Entry. 

12. In the Economic Amount column, enter the amount below which the system recommends not 
returning items to inventory. For more information about this field see Determining the Economic 
Return Amount in the Purchasing documentation. 

13. Save your changes and exit the dialog box. 
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Pass-Along Discount Details 
Pass-along discounts are maintained at the product and price line level. To apply pass-along discounts for 
the products you place on an order, you need to set the terms code for sales orders to include a P prefix to 
indicate to the system that it should look for discounts set at the product an price line level. Setting a 
terms code with a P prefix uses the product's pass-along discount in place of the discount percentage 
assigned to the terms code. 

Note: A terms code with a pass-along discount is only valid on terms codes flagged for 
sales. You cannot use a terms code using a pass-along discount as a purchasing 
terms code. 
  

When you add products to an order, the system checks the terms code for the pricing branch on the order 
for a discount with the P prefix. If the terms code contains the P prefix, the system first checks the pass-
along discount set up for the product in the Pass Disc field in the Additional Price Maintenance window 
(accessed using the Price and then the Additional hot keys from Product Maintenance). If there is a pass-
along discount set here, that is the discount assigned to the product in lieu of the percentage assigned in 
the terms code. If a pass-along discount is not found for the product, the system then checks the price line 
to which the product belongs for any pass-along discounts. 

If the system finds a pass-along discount percentage for the price line, it uses that discount for the product 
in lieu of the percentage set in the terms code. If a pass-along discount is not assigned to the product or 
the price line, the discount for an order paid by the discount date is the percentage discount set in the 
Percent field for the terms code for the pricing branch of the order, regardless of whether or not the P 
prefix exists. 

If the terms code discount percentage assigned to an order does not contain the P prefix, the system 
ignores any pass-along discount set at the product level or price line level. 
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Inquiring About Product Pricing 
Display sell matrix data for a product from Inventory Inquiry to view the basic pricing setup for the 
matrix cells. This helps determine how the system prices the product. This information is view-only. 

You can view product pricing from a variety of places in the system. The pricing information is displayed 
for the branch where the order is being written when viewed from Sales Order Entry. When viewed at 
other places in the system, pricing information is displayed for the branch indicated on the Inventory 
Inquiry screen. 

To Inquire about product pricing: 

1. From the Orders > Inquiries menu, select Inventory Inquiry to display the Inventory Inquiry 
window. 

2. In the Product field, enter a product name to display the product inventory record. 

3. Select Maintenance > Product Pricing to display the Product Pricing window. 

4. Scroll through the list of price classes to view corresponding sell matrix information. 

The following table describes the read-only information in each field: 

Field Description of read-only information 
Branch The branch where the inquiry is taking place. Either the branch where the order is 

being taken, or the branch displayed on the Inventory Inquiry window. 

Group The product sell group. This provides the y axis for the matrix cell information 
displayed. The Class column displays the x axis. 

Price Sheet The product price sheet currently in effect for the product. 

Product 
Description 

The product description carried over from the Inventory Inquiry window. 

Class The customer price classes displayed in order from lowest to highest price class level 
according to the price class level assigned to you and the OE.PRICE.CLASS.LEVEL 
authorization key. 
The customer class is the x axis for the matrix cell information displayed. The Group 
column displays the y axis. 

Price/ea The price for the item as determined by the sell matrix. 

How the System Displays Product Pricing 
The system looks at the following to determine what price to display on the Product 
Pricing screen. 
• Your OE.PRICE.VIEW.LEVEL authorization key accessibility level. 
• The view level assigned to the local basis name on the Price Line Maintenance 

screen. 
For the basis name you are permitted to view, the system displays the price or cost 
from the Product Price Sheet Maintenance screen, followed by the calculated prices or 
costs for the class/group matrix cell determined by your price class accessibility and 
the OE.PRICE.CLASS.LEVEL authorization key. 

Basis The first three basis names listed display the first three basis names from the price 
line. The remaining basis names correspond to the matrix cells most likely to be used, 
based on the pricing hierarchy, and depending on your view level. 
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Field Description of read-only information 
Formula The formula corresponding to the basis name most likely to be used to determine the 

price depending on the pricing hierarchy, and depending on your view level. 

5. When finished reviewing product pricing, exit the window. 
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Auto Price Updating Overview 
Use Auto Price Updating to update product pricing using vendor-supplied information downloaded from 
the Internet or copied from a diskette or CD-ROM. 

You can format the update file in comma-delimited (variable) format with a .csv extension, fixed-field 
(blocked) format with a .txt extension, or in Excel spreadsheet format. 

Set the update to verify that product prices are updated correctly, or update quickly without verifying. 
You can also add new products to the product file by entering default product information that the system 
uses to create product records during the update. 

To ensure a successful update have a unique identifier for each product, so the system makes a correct 
match between the products in your product file and the products in the update file. 

The process for automatically updating products involves the following tasks: 

• Importing a price update file into the system. 

• Changing the screen format to match the update file. 

• Setting up the price update template. 

• Defining default product information for new products on the update file. 

• Scanning the update file to verify formulas and effective dates. 

• Updating a few records to test for accuracy. 

• Adding new products from the update file. 

Importing Price Update Files into Eclipse 

Changing the Auto Price Update Format 

Defining Auto Price Update Parameters 
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Importing Price Update Files into Eclipse 
Import a price update file into Eclipse from a folder on your workstation or directly from a diskette or 
CD. If the file is in Excel format or is a text file and you did not get a record layout sheet from the vendor, 
do not upload it directly from the diskette or CD drive. Copy it to a folder on your workstation, save it in 
.csv (comma delimited) format, and then upload it from the folder. 

Once you have uploaded the price update into the system, view the contents of the file to validate that the 
upload was successful and that the data is correct. 

This topic contains the following procedures: 

• Importing a price update file 

• Viewing the price update file 

To import price update files: 

1. Display the character based system. 

Note: The Auto Price Update functionality has not been incorporated into Solar Eclipse 
as of this release. 

2. From the System > Printers menu, select Your Hold Entries to display the Spooler Control 
screen. 

3. Use the Upload hot key to display the Select file window. 

4. Browse the file structure and select the price update file. 

5. In the Enter Spooler Title field, enter a title for the uploaded file and press Enter to display the 
Spooler Control screen. 

A running count of the bytes of data being uploaded displays in the message bar at the bottom of 
the screen. When finished, the total number of bytes uploaded displays. 

Note: The messages, 0 bytes Transferred to Host and Upload Impossible, display in the 
message bar when you have entered the path name incorrectly. 

6. Press Enter to complete the upload. 

The file name you uploaded displays at the top of the list on the Spooler Control screen. 

To view the uploaded file: 

1. Display the character based system. 

2. On the Spooler Control screen, scroll to the file name and use the View hot key to display the file 
in the Hold Entry Pre-View screen. 

3. Identify the columns in the file, so you can fill out the User Defined Auto Price Updating screen. 

• If the file is in .csv (variable) format, the data runs together and be separated by commas (or 
another delimiter). 
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• If the file is in fixed-width (blocked) format, the data displays in distinct columns. Fixed-width 
data files are normally accompanied by a vendor specification sheet that identifies the column 
descriptions and widths. Use this sheet to set the update parameters in the system. 

 

4. Verify that the data is correct and press Esc to redisplay the Spooler Control screen. 

5. Set update parameters and run the update. See Setting Auto Price Update Parameters for more 
information. 

Note: If you do not want to process the file immediately, it remains in your Hold file for 
the number of days defined in the Minimum Days Before Report Purge control 
maintenance record. 
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Changing the Auto Price Update Format 
Vendors send price updates in a variety of formats, such as CD-ROM, text file, or Excel spreadsheet. 
Determine the file format and prepare the system to receive that format. 

To change the auto price update format: 

1. Display the character based system. 

Note: The Auto Price Update functionality has not been incorporated into Solar Eclipse 
as of this release. 

2. From the System > Printers menu, select Your Hold Entries to display the Spooler Control 
screen. 

3. Select the name of the update file and use the Process hot key to display the User Defined Upload 
Processing screen. 

4. In the Processing Type field, enter Auto Product Price Updating. 

5. Use the Begin hot key to display the User Defined Auto Price Updating screen. 

6. In the Work ID field, enter the work ID for this update. See Setting Auto Price Update 
Parameters for more information. 

A work ID can determine a format-specific template for processing a spreadsheet. It does not 
have to be vendor-specific. You can use the same work ID for different vendors if several 
vendors send their data in an identical format. 

7. Use the Rec Layout hot key to display the Auto Price Updating Record Layout screen. 

8. In the Record Type field, enter one of the following formats for the update file: 

• Blocked - fixed-length. 

• Variable - comma-delimited. 

Note: A delimiter may also separate data elements in a blocked record. 

9. In the Record Length field, enter one of the following: 

• Enter the number of characters necessary if the vendor specifies a record length. 

• Leave the field blank if the vendor does not specify a record length. 

Note: This field is accessible only for blocked-type records. 

10. In the Delimiter Char field, enter the character that is used between each field as a delimiter. 
This field is active only for variable record type files. 

11. In the ASCII Value field, if applicable, enter the ASCII value for the non printable delimiter. For 
example, the ASCII value for a comma is 044. 

12. In the Delete Chars field, enter any characters you do not want read as data, such as quotation 
marks or the dollar sign. 

The system does not recognize the dollar sign ($) as a numeric value, so enter a dollar sign in this 
field if the vendor puts a dollar sign in front of prices. 

13. Press Esc to save the information and return to the User Defined Auto Price Updating screen. 
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Defining Auto Price Update Parameters 
The information entered in the User Defined Auto Price Update screen determines how the system reads 
and processes pricing information from a vendor. 

You can create a vendor-specific price update template that can be used each time you update prices from 
that vendor. 

To define auto update parameters: 

An asterisk (*) identifies the necessary fields for updating prices. 

1. Display the character based system. 

Note: The Auto Price Update functionality has not been incorporated into Solar Eclipse 
as of this release. 

2. From the System > Printers menu, select Your Hold Entries to display the Spooler Control 
screen. 

3. Position the cursor on the name of the update file and use the Process hot key to display the User 
Defined Upload Processing screen. 

4. In the Processing Type field, enter Auto Product Price Updating and use the Begin hot key to 
display the User Defined Auto Price Updating screen. 

5. In the Work ID field, do one of the following: 

• Leave the field blank - Does not save the template after this update. 

• Enter a name that identifies the vendor who sent the file or the price line being updated - 
Creates a new template for use with future updates. 

• Press F10 and select an ID - Uses an existing template. 

6. In the Desc* field, enter a complete description for the update. 

7. In the Br/Tr/ALL field, enter the branch or territory whose prices you want to update. Enter 
ALL to include all branches and territories. 

If your company uses multiple price sheets for a price line, use this option to select the price sheet 
by branch. 

8. In the Prc Upd Index* field, press F10 to select a criteria for the product file for searches in the 
vendor update file. This entry matches the product in the system to the product in the update file. 

Price Update Index Search 

You can search by the product's UPC number or by the data specified in the User Defined #1, 
User Defined #2, User Defined #3, or User Defined #4 field on the Price Updating ID Maint 
screen in Product Maintenance. 

For example, Instead of using UPC numbers to identify its products, a vendor might use its own 
part numbers. One of those fields would contain that user-defined part number. Point to that field 
by selecting User Defined #1, User Defined #2, User Defined #3, or User Defined #4. If you 
point to one of those fields and it does not contain any data, the update will not work because 
there is nothing to match. 
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Note: For the bulk of your products, an entry in any of these fields will typically have 
been loaded during the initial Eclipse data conversion, through Mass 
Load/Update, or by creating products using a vendor supplied diskette and this 
program. 

9. In the Upd ID Prefix field, if you have assigned a vendor prefix to the part number in the User 
Defined fields in the Data Format column, enter that prefix. 

For example, in the electrical industry, instead of using a UPC number, multiple vendors might 
use a manufacturer's catalog number that is the same for each vendor. Assigning a vendor prefix, 
such as MEC for Macon Electric Co., makes these items unique to each vendor. 

10. In the Upd UPC with Prefix (Y/N) field, enter one of the following: 

• Y - Uses a prefix to index products and stores the prefix with the part number. 

• N - Does not use a prefix with the part number. The default is N. 

11. In the New Items Mode field, enter one of the following: 

• Prompt - Selectively adds new products to the file. The Auto Price Updating Product 
Matching screen displays every time the system encounters a new product. This update may 
take several minutes if the update file contains many new products. See Adding New Products 
While Updating Prices for more information. 

• Ignore - Updates existing products without adding new products. Unless the update contains a 
new line of products only, use Ignore mode the first time you run the update. Run it a second 
time for existing products that were missed by the update, after correcting the records. See 
Auto Updating Product Pricing Information for more information. 

• Add - Updates existing products and adds any new products in the update file. Run the update 
in Add mode only after you have updated the products. If the file contains a new line of 
products only, you can use Add the first time you run the update. See Adding New Products 
While Updating Prices for more information. 

Note: We recommend running the update in Ignore mode the first time you run it. 

12. In the Start or Elmt# field of the Data Format section of the screen, scroll down the list to find 
the data format to match in the update file. 

For blocked records: 

• Start - Enter the number provided by the vendor for the data format you want to match. 

• Lngth - Enter the corresponding length of the field. 

For variable records: 

• Elmt# - Enter the column number from the update file for the data format you want to match. 

• Lngth - Leave blank. 

Data Format Description of column information from update file 
Prc Upd ID#* Price update ID. This is a required field. 

Description Description of products. 

Price Basis #1* to #5 Basis name you are updating. Price Basis #1* is a required field. 

Weight Weight of each product. 
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Data Format Description of column information from update file 
Load Factor Cubic dimensions or the point value of each product. 

User Dfnd ID #1- #10 User-defined data as defined in Product Maintenance on the Price 
Updating ID Maint screen (Files > Product > PU IDs hot key). 

UPC # UPC code of each product. 

Pricing U/M Unit of measure at which you sell the product. 

Price Line ID# Price line of the products. 

Buy Line ID# Buy line of the products. 

Commodity Code Commodity code assigned to the products. 

Buy Package Unit of measure at which you buy the product. 

Desc - Line #2 to # 6 Additional descriptive information that appends to the product 
description in the product record. 

Discount Class Discount class assigned to the products. 

Matrix Sell Group Sell group for the products. 

Keywords Extra words added to the update file that you may want to use to match 
products during the update. 

Prod Matrix Type Product matrix type in Product Maintenance that overrides the customer 
price class used to price a product. 
This field is required only if the Valid Product Matrix Types control 
maintenance record is populated. 

Prod Base U/M Unit of measure in the UM field in Product Maintenance. If left blank, 
the system uses the unit of measure from the price line. 

13. In the Dec# field, enter one of the following for numeric data: 

• The appropriate number of decimal places if the decimal point is not embedded, but the 
numeric data contains a defined number of decimal places. 

• A zero if the decimal point is embedded. 

14. Use the following hot keys, as needed. An asterisk (*) identifies the hot keys required for 
updating prices. 

Hot Key Description 
Begin Begins processing the upload file. Ensure the update criteria are set 

properly before using this hot key. 

New Profile* Defines the data for an initial product record for each new product the 
system encounters during the update. See Adding New Products While 
Updating Prices for more information. 

Rec Layout* Identifies the User Defined Auto Price Updating format of blocked or 
variable for the file you are importing. 

Del Deletes the current work ID. You are prompted for confirmation of the 
deletion. 

UM Table* Defines unit of measure codes and assigns the corresponding quantity to 
the code. 
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Hot Key Description 
Add'l Data Transfers information from the update file to notes in the product record 

during a price update. 

Scan Ensures the price update runs as expected by checking the displayed 
information. 

15. Press Esc to exit the screen. If you created a work ID the system saves the data as a template. 
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Deleting Price Update Templates 
A price update template is used to update pricing information from a vendor. You create price update 
templates to use repeatedly when updating vendor pricing information. If you no longer need a template, 
you can delete it as described in the following procedure. 

To delete a price update template: 

1. Display the character based system. 

Note: The Auto Price Update functionality has not been incorporated into Solar Eclipse 
as of this release. 

2. From the System > Printers menu, select Your Hold Entries to display the Spooler Control 
screen. 

3. Position the cursor on the name of the update file, and use the Process hot key to display the User 
Defined Upload Processing screen. 

4. In the Processing Type field, enter Auto Product Price Updating and use the Begin hot key to 
display the User Defined Auto Price Updating screen. 

5. In the Work ID field, enter the work ID that identifies the template to delete. 

6. Use the Del hot key to display the delete prompt. 

7. In the Type DELETE to Confirm field, type delete. 

The system deletes the update template. 

8. Press Esc to return to the User Defined Auto Price Updating screen. 
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Creating Price Sheets in Auto Price Update 
Maintain a history of pricing information by giving each price sheet a new effective date. When you 
receive new pricing information from a vendor, use the most recent price sheet, but change the effective 
date to the date you ran the latest update. This creates a new price sheet that maintains the old sheet's 
pricing information. 

To create a price sheet in Auto Price Update: 

1. Display the character based system. 

Note: The Auto Price Update functionality has not been incorporated into Solar Eclipse 
as of this release. 

2. From the System > Printers menu, select Your Hold Entries to display the Spooler Control 
screen. 

3. Position the cursor on the name of the update file, and use the Process hot key to display the User 
Defined Upload Processing screen. 

4. In the Processing Type field, enter Auto Product Price Updating and use the Begin hot key to 
display the User Defined Auto Price Updating screen. 

5. In the Work ID field, enter the appropriate work ID for the update file. 

6. Use the Scan hot key to display the Price Update Scan screen. 

7. Use the Edit Last Eff Dt hot key to display the Eff Date screen. 

8. Select New and press Enter to display the following fields on the Price Sheet Days screen. 

• ID - Displays the name of the new price sheet. 

• Purge Age (days) - Displays the number of days the data for the new sheet is saved. 

9. In the Effective field, scroll to the first available space and enter the new price sheet effective 
date. 

10. Press Esc to return to the Eff Date screen. 

The new effective date is highlighted on the screen. 

11. Press Enter to select the date and return to the Price Update Scan screen. 

The last effective date and the new effective date display. 

Note: To delete old price sheet formulas in the Eclipse Product File use the Rebuild Price 
Sheet/Discount Class Cache Utility. For example, if a vendor gives you disks with new price 
sheets and discount classes, run this utility to delete the old price sheets and discount classes in 
your Eclipse Product File. 

12. Press Esc to return to the User Defined Auto Price Updating screen. 
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Assigning Formulas to Price Sheets 
The first time you receive a price update for a price line, set up a price sheet for that price line. The basis 
names and formulas entered on the price sheet determine product prices from the update information. 

To assign a formula to a price sheet: 

1. Display the character based system. 

Note: The Auto Price Update functionality has not been incorporated into Solar Eclipse 
as of this release. 

2. From the System > Printers menu, select Your Hold Entries to display the Spooler Control 
screen. 

3. Position the cursor on the name of the update file, and use the Process hot key to display the User 
Defined Upload Processing screen. 

4. In the Processing Type field, enter Auto Product Price Updating and use the Begin hot key to 
display the User Defined Auto Price Updating screen. 

5. In the Work ID field, enter the appropriate work ID for the update file. 

6. Use the Scan hot key to display the Price Update Scan screen. 

7. Use the Edit Formulas hot key to display the Price Sheet Entry (Auto Updates) screen. 

• All entries in the CalcBase* field initially display NO UPDATE. 

• All formulas are *1. 

• The Rnd field displays a default entry for rounding digits. 

• The Prc Bas field is blank. 

8. For any basis you are updating, change NO UPDATE to AUTO. The system reads the basis from 
the update file when you begin the update. 

9. In the Rnd column, enter the number of characters for which you want to round the price. This 
field is used with the formula provided. 

For example, the Rnd column displays 3, so when you run the price update, prices display three 
characters beyond the decimal point. 

• The vendor's update diskette shows a LIST price of 10.00. 

• The formula for REP-COST is *.4873. 

• The updated REP-COST is 4.873. 

10. In the Prc Bas field, enter the number (1-5) that corresponds to the Update Basis # field on the 
User Defined Auto Price Updating screen that points to the price data in the update file. 

11. In the CalcBase* and Formula fields, enter the basis name and formula to use to calculate the 
price. For example, REP-COST is LIST less 40 percent, so enter LIST in the CalcBase* field 
and *.40 in the Formula field. 

Note: You receive an error message if you point the basis name to itself in the calculated 
field, for example, entering LIST next to the basis name LIST. 
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12. Press Esc to save your changes and return to the Price Update Scan screen. 
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Creating Default Product Profiles 
A product default profile is basic product information set up for the automatic creation of product records 
during a price update. Set up the product default profile before running the update, so that product records 
are created when the system encounters new products during the update. When you do this, new products 
in the update file do not slow the update process, and you can review and edit the new product records as 
needed during the update. 

To create a default product profile: 

1. Display the character based system. 

Note: The Auto Price Update functionality has not been incorporated into Solar Eclipse 
as of this release. 

2. From the System > Printers menu, select Your Hold Entries to display the Spooler Control 
screen. 

3. Position the cursor on the name of the update file, and use the Process hot key to display the User 
Defined Upload Processing screen. 

4. In the Processing Type field, enter Auto Product Price Updating and use the Begin hot key to 
display the User Defined Auto Price Updating screen. 

5. In the Work ID field, enter the appropriate work ID for the update file. 

6. In the New Items Mode field, type Add. 

7. Use the New Profile hot key to display the New Item Default Profile screen. 

8. In the Prd Status field, press F10 to select a product status. 

The default product status is Review so you can review new product records before the products 
are sold. After verifying that records are correct, you can use Mass Load to set the statuses to 
either Stock or Nonstock. 

9. In the Price Line field, enter the price line for the new products. 

10. In the Buy Line field, enter the buy line for the new products. 

11. In the Proc Group field, enter the procure group for the new products. Leave this field blank if a 
procure group has been determined in the buy line record. 

12. In the Comm Code field, enter the commodity code, if required, to assign to each new product. 

13. In the Sales Type field, enter the G/L product sales type for the new products. 

14. In the Index Type field, enter one of the following index types: 

• Primary - Stock items currently held in inventory. This is the default. 

• Catalog - Nonstock items available for order from the vendor catalog. 

15. In the Desc Prefx field, add a description prefix, up to 25 characters, to the first character of the 
description for new products. Enter a prefix as follows: 

• A vendor name or initial as a prefix - Displays a space between the prefix and the first 
character of the description. 
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• A prefix followed by a tilde (~) - No space displays between the prefix and the first character 
of the description. 

16. In the Word Wrap Desc to 35 Chars (Y/N) field, enter one of the following: 

• Y - Wraps product description exceeding 35 characters to the next line after the last whole 
word. 

• N - Does not wrap product descriptions exceeding 35 characters. 

17. Press Esc to save the data and return to the User Defined Auto Price Updating screen. 
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Defining Unit of Measure Codes for Price Updates 
A unit of measure code tells the system which units of measure and corresponding quantities are included 
in a price update. If you sell a product at a different unit of measure than that for which you buy it, the 
system uses the unit of measure code to calculate the update price according to the selling unit of measure 
on the product record. 

For example, you sell widgets in units of each (ea = 1). The vendor sells widgets to you in units of C 
(100). You enter the unit of measure codes of ea = 1 and C = 100 to maintain the correct widget pricing 
for the price update. 

Note: You must have a per quantity and per unit of measure (UOM) on a least one price 
sheet per product. By default, the system uses the default UOM from the price line 
and the lowest UOM. 

To define unit of measure codes for price updates: 

1. Display the character based system. 

Note: The Auto Price Update functionality has not been incorporated into Solar Eclipse 
as of this release. 

2. From the System > Printers menu, select Your Hold Entries to display the Spooler Control 
screen. 

3. Select the update file, and use the Process hot key to display the User Defined Upload Processing 
screen. 

4. In the Processing Type field, enter Auto Product Price Updating and use the Begin hot key to 
display the User Defined Auto Price Updating screen. 

5. In the Work ID field, enter the appropriate work ID for the update file. 

6. Use the UM Table hot key to display the U/M Code / Qty screen. 

7. In the U/M Code field, enter all units of measure for products in this update, including units of 
measure you buy from the vendor and units of measure you sell. List units of measure from 
smallest to largest. 

8. In the Qty field, enter the quantity for each unit of measure. 

9. Press Esc to save the data and exit the screen. 
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Transferring Price Update Data to Product Notes 
You can transfer updated product information to user-defined notes in the product record. Notes help keep 
product records up to date on pricing information. 

Define as many as 20 product note categories in the User Defined Product Notes control maintenance 
record. Notes are listed in numeric order in the control maintenance record, as shown below. 

 
Using the same numeric order in auto price updating, you determine which notes receive update 
information. 

Important: When creating notes in this way, existing notes in the product record could be 
overwritten. 

To transfer update data to a product note: 

1. Display the character based system. 

Note: The Auto Price Update functionality has not been incorporated into Solar Eclipse 
as of this release. 

2. From the System > Printers menu, select Your Hold Entries, to display the Spooler Control 
screen. 

3. Position the cursor on the name of the update file, and use the Process hot key to display the User 
Defined Upload Processing screen. 

4. In the Processing Type field, enter Auto Product Price Updating, and use the Begin hot key to 
display the User Defined Auto Price Updating screen. 

5. In the Work ID field, enter the appropriate work ID for the update file. 

6. Use the Add'l Data hot key to display the Additional Data screen. 

Either Start or Elmt# display as headings in the first active field, depending on the update file's 
format. 

7. Scroll to the note number listed in the Data Format field. The system will transfer the data to this 
location. Enter the following, depending on the format: 
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• For blocked records, in the Start field, enter the number provided by the vendor for the data 
format you want to match. 

• For variable records, in the Elmt# field, enter the column number from the update file for the 
data format you want to match. 

8. In the Dec# column, enter one of the following for numeric data: 

• If the decimal point is not embedded, but the numeric data contains a defined number of 
decimal places, enter the appropriate number of decimal places. 

• If the decimal point is embedded, enter a zero. 

9. Press Esc to save the data and exit the screen. 

The notes display when accessing the specified screens after the next price update. 
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Scanning Price Update Files 
To ensure that the system will update pricing information properly before running the update, view a 
summary of your update criteria from the Price Update Scan screen. You can verify the price sheet setup 
and make any changes necessary for an accurate update. 

To scan a price update file: 

1. Display the character based system. 

Note: The Auto Price Update functionality has not been incorporated into Solar Eclipse 
as of this release. 

2. From the System > Printers menu, select Your Hold Entries to display the Spooler Control 
screen. 

3. Position the cursor on the name of the update file, and use the Process hot key to display the User 
Defined Upload Processing screen. 

4. In the Processing Type field, enter Auto Product Price Updating and use the Begin hot key to 
display the User Defined Auto Price Updating screen. 

5. In the Work ID field, enter the appropriate work ID for the update file. 

6. Use the Scan hot key to display the Price Update Scan screen. 

Use the following hot keys, as needed, to perform each task: 

To... Use this hot 
key... 

To... 

verify that each price sheet is set up 
correctly. 

Edit Formulas display the Price Sheet Entry (Auto 
Updates) screen. 

Change the effective date for listed 
price sheets to the same date. 

Set All New Eff 
Dts 

enter the new date in the New Eff Dt 
field. 

Create a price sheet. Edit Last Eff Dt display the Eff Date screen. 

Assign formulas to a price sheet. Edit Formulas display the Effective Dates screen. 

7. Press Enter at any time to stop the process. 

8. Press Esc to return to the User Defined Auto Price Updating screen. 

See Also: 

Auto Price Updating Overview 

Defining Auto Price Update Parameters 
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Verifying Data on Price Sheets 
Verify the information on the price sheet before running the update to ensure all information is in place to 
accurately update your product pricing information. 

To verify data on a price sheet: 

1. Display the character based system. 

Note: The Auto Price Update functionality has not been incorporated into Solar Eclipse 
as of this release. 

2. From the System > Printers menu, select Your Hold Entries to display the Spooler Control 
screen. 

3. Position the cursor on the name of the update file, and use the Process hot key to display the User 
Defined Upload Processing screen. 

4. In the Processing Type field, enter Auto Product Price Updating and use the Begin hot key to 
display the User Defined Auto Price Updating screen. 

5. In the Work ID field, enter the appropriate work ID for the update file. 

6. Use the Scan hot key to display the Price Update Scan screen. 

7. Use the Edit Formulas hot key to display the Price Sheet Entry (Auto Update) screen. 

Verify the values defined for the last effective date that display in the CalcBase* and Formula 
fields: 

• If the formulas are correct, they carry over to the new effective date. 

• If new formulas are necessary, use the Edit Eff Dates hot key on the Price Update Scan screen 
to create a new price sheet. 

For basis names you are updating from the file, verify that the CalcBase* field displays AUTO 
and the Formula field displays *1. If not, change the values. 

8. In the Prc Bas field verify that the number (1-5) corresponds to the correct number of the Price 
Basis # field in the Data Format column on the User Defined Auto Price Updating screen. 

For example, if you are updating LIST and you used Price Basis #1 on the User Defined Auto 
Price Updating screen to point to a new list price in the update file, enter 1 in the PrcBas field for 
LIST price on the Price Sheet Entry (Auto Update) screen. 

For basis names with a value calculated using another basis name, enter the basis name and the 
formula. For example, if REP-COST is LIST less 40 percent, enter LIST in the CalcBase* field 
and *.40 in the Formula field. If LIST equals $40.00, this creates the formula $40.00 x .40 = 
$16.00, therefore the price for REP-COST is $40.00 - $16.00 = $24.00. 

If the basis name used to calculate another value is updated from the file, enter that number (1-5) 
in the Prc Bas field. 

9. Repeat the verification process for each price sheet being updated. 

10. Press Esc to return to the Price Update Scan screen. 
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Matching Products During Price Updates 
The system prompts to match products during an update when the New Items Mode in Auto Price 
Updating is set to Prompt, and the system encounters a product in the update file that is not in the Eclipse 
product file. You can create a new record, edit the existing record, or skip the record as needed. 

To match products during a price update: 

1. The Auto Price Updating Product Matching screen displays when the system detects a product on 
the update file that is not in the system during the price update or during setup when accessing the 
Scan screen (User Defined Auto Price Updating > Scan hot key). 

Note: The New Items Mode in Auto Price Updating is set to Prompt for this window to 
display. 

The Upd Desc field displays the product description from the vendor update file. 

The Xref field displays the cross-reference value assigned to the vendor product to match against 
the corresponding value in the product file. 

The Prd Desc field is blank, but is updated after you match the product. 

2. Use the following hot keys as needed to match products in the update file: 

Hot Keys Description 
Create Create a product record for the new product in Product Maintenance. 

Edit Prd Edit a product record. This hot key is active only when the Prd Desc field is populated, 
then is inactive again after you edit the product record. 

Update 
Desc 

Update the product description as follows: 
If you use the Find Prd hot key to select a product, the product description displays in 
the Prd Desc field. Then, use the Update Desc hot key to change the product 
description to match the product description in the Upd Desc field. 

Skip Determines whether to skip the product during the update. Enter one of the following at 
the prompt: 
• A number of steps - Skips this number of products before prompting. 
• Continue - Continues the update without stopping. 
• Edit - Displays the Product Maintenance window, so you can edit the product record. 

Find Prd Search for a product using the system search routines. The product displays in the Prd 
Desc field, when found. 
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Auto Updating Product Pricing Information 
Use User Defined Auto Price Updating to update pricing information for products already in your 
inventory. Before you run the update you must complete the following: 

• Import the vendor's update file. 

• Set up auto price update parameters. 

To ensure that the products update correctly, we recommend that you run the update program only for 
products already in your inventory. 

During the first run of an update file, view each product record to ensure that the information is updating 
correctly. After you verify the accuracy of the data, you can include the new products and run the update 
a second time without interruption. 

To update product information: 

1. Display the character-based system. 

Note: The Auto Price Update functionality has not been incorporated into Solar Eclipse 
as of this release. 

2. From the System > Printers menu, select Your Hold Entries to display the Spooler Control 
screen. 

3. Position the cursor on the update file, and use the Process hot key to display the User Defined 
Upload Processing screen. 

4. In the Processing Type field, enter Auto Product Price Updating and use the Begin hot key to 
display the User Defined Auto Price Updating screen. 

5. In the Work ID field, enter the appropriate work ID for the update file. 

6. In the New Items Mode field, enter Ignore. 

Products processed in the Ignore mode are listed in the background, tagged as follows: 

• Skipped - New items and products that were not updated because the price sheet was 
incomplete. 

• Updated - Items that have successfully updated. When the system encounters a product with a 
new price line or price sheet discount class, it displays the Price Sheet Entry screen so you can 
make corrections, if needed. 

7. Use the Begin hot key and select an effective date. 

8. At the Ignored Items prompt, enter one of the following: 

• Y - Creates and sends the Ignored Items report to your Hold file. This report lists new products 
and existing products that were not updated. 

• N - Runs the update without creating a report. 

9. At the ##of Steps/Continue/Edit update prompt, enter E (edit product) to display the Product 
Maintenance screen for the last product displayed in the list in the background. 

10. View the first updated product record to verify that information was entered correctly. 
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11. Use the Prices hot key and the PriceSheet hot key to verify that the price you are updating for 
the new effective date is correct. 

12. Press Esc when finished to exit the product record screens and redisplay the ##of 
Steps/Continue/Edit update prompt. 

13. Enter one of the following to determine how the update should proceed: 

Value Description 
[A number] 
## of Steps 

Enter the number of products from this file that you want to update before prompting. 
For example, if you enter 1, the prompt returns after each product is updated; if you 
enter 25 the prompt returns after 25 products have been updated. If you enter a large 
number and the update is incorrect, you must manually correct that many records. 
We recommend entering 1  in this field, so that you can verify the accuracy of each 
product record and make any corrections before continuing. 

Continue Enter C to process the items without prompting. Exception: the system prompts you if 
it encounters a new product and the New Items Mode is set to Prompt, or if it 
encounters an incomplete price sheet. 
If the system encounters a new price sheet for which a formula has not been entered, 
it displays the Price Sheet Entry screen.  Once you enter a formula, the system 
continues updating products. 

Note: Use this value only if you have verified products are updating correctly. 

14. When you finish updating records, press Esc until you return to Spooler Control. 

If items that are part of your product file appear in the Ignored Items report, the UPC number or 
the user-defined product number may be missing from the product record for those items. If so, 
use the Edit Detail hot key on the Hold Entry Preview screen to display the product record. 
Correct those product records and re-run the Ignore mode. If the product number still appears on 
the report, contact Eclipse Support. 
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Adding New Products While Updating Prices 
Use User Defined Auto Price Updating to add new products to inventory while running a price update. 
Before running the price update for new products, complete the following: 

• Import the vendor's price update file. 

• Define default information for new products. This default product information allows the system to 
create a product record for each product on the update file not found in your inventory. 

• Run the update on any products already in your inventory. 

After the update, you can access the new product records and add more detailed information if necessary. 

To add new products while updating prices: 

1. Display the character based system. 

Note: The Auto Price Update functionality has not been incorporated into Solar Eclipse 
as of this release. 

2. From the System > Printers menu, select Your Hold Entries to display the Spooler Control 
screen. 

3. Position the cursor on the name of the update file, and use the Process hot key to display the User 
Defined Upload Processing screen. 

4. In the Processing Type field, enter Auto Product Price Updating and use the Begin hot key to 
display the User Defined Auto Price Updating screen. 

5. In the Work ID field, enter the appropriate work ID for the update file. 

6. Set the New Items Mode field to one of the following to create new product records during a 
price update: 

• Prompt - Selectively adds new products to the file. The Auto Price Updating Product 
Matching screen displays every time the system encounters a new product. This update may 
take several minutes if the update file contains many new products. 

• Add - Updates the products and adds any new products in the update file. Run the update in 
Add mode only after you have updated the products. If the file contains a new line of products 
only, you can use Add the first time you run the update. 

7. Use the New Profile hot key to create a default profile for new products. 

8. Press Esc to save the new product data and return to the User Defined Auto Price Updating 
screen. 

9. Verify all necessary information for the price update is included on the User Defined Auto Price 
Updating screen before running the update. 

After running the update, the User Defined Auto Price Updating screen displays, and an update 
report is sent to your Hold file showing the products that were added. The updated value on the 
report is the new product's price, the Prev List column shows 0.00, and the gross profit percent 
change column shows 100.0% since the product is new. 

10. Review the new product records to ensure they have been assigned necessary information before 
changing the product status from Review to Stock or Nonstock. 
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Preparing Vendor Update Files for the Matrix Upload Utility 
To run the Matrix Update Utility for customer-specific price and cost updates, you must first save the 
vendor update file in a format that the system understands. The system uses this file to create sell matrix 
cells at the time of the update, so that customers can receive discounts directly from the vendor. 

Take the data element from the vendor's file, and complete the following list of tasks in a spreadsheet. 

To prepare the vendor update file for matrix upload: 

1. Display the character based system. 

Note: The Matrix Upload Utility functionality has not been incorporated into Solar 
Eclipse as of this release. 

2. Rearrange each data element into its proper sequence by arranging it under a column name on a 
spread sheet. 

3. Rename all vendor discount codes or group codes into valid sell groups or buy groups. 

4. Rename all cost basis names into system-defined price or cost basis names 

• From the price lines if you are loading group price/costs. 

• From products if you are loading item price/costs. 

5. Modify formula fields to match system standards for pricing formulas, including units of 
measure. 

The first row of your spread sheet must contain headings, not data. Use the column names listed 
in the table below, as an example of how to build your spreadsheet columns. 

Spreadsheet 
Column Name 

Description 

UPC Enter only for items not using group pricing. 

Price Group Code Is a UPC number provided? 
• Yes - The system validates it against the price line or local basis name. 
• No - The system validates it against the global basis name. 

Cost Basis for Sell 
Price 

Is a UPC number provided? 
• Yes - The system validates it against the price line or local basis name. 
• No - The system validates it against the global basis name. 

Sell Formula Map formulas to system format, based on matrix rules. Net price must be 
preceded by a dollar sign ($). See Pricing Formulas Overview for more 
information. 

Cost (COGS) 
Basis for Cost 

Is a UPC number provided? 
• Yes - The system validates it against the price line basis name. 
• No - The system validates it against the global basis name. 

Cost Formula Map formulas to system format, based on matrix rules. Net cost must be 
preceded by a dollar sign ($). See Pricing Formulas Overview for more 
information. 
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Spreadsheet 
Column Name 

Description 

Cost Eff Date 
Override 

Populates the price sheet override date on individual matrix cells. 
For rebates and contracts, this date is loaded into the price sheet effective date 
for the rebate. 

Quote# Use this column for rebate or contract numbers. 
All matrix cells have the expiration date of the matrix cell loaded into the 
Expiration Date field on the Matrix Cell Rebate Maintenance screen. 

Price Per Qty Has the vendor provided unit of measure information that affects the pricing or 
costing formulas? 
• Yes - Enter the quantity for each unit of measure listed in the Price Per Qty 

column on the spreadsheet. For example, the vendor's units of measure are: 
• e = 1 
• c = 100 
• m = 1000 
Use the spreadsheet's find and replace feature to search for e in the Price Per 
Qty column, and replace it with 1. Then search for c and m and replace them 
with 100 and 1000 respectively. 
This entry affects only items, not groups, that have a dollar amount in the sell 
or cost formula. 

• No - The system default lists all quantities as 1 if no vendor information is 
provided in this column. The system then uses the product pricing 
information to calculate the correct price or cost. For example, a quantity of 1 
is entered on the spreadsheet for an item you sell in packs of 6. The system 
uses its product pricing information, and multiplies 6 times 1 to calculate the 
price. 

Customer Number 
(CN) 

Enter the customer number for which you want to create matrix cells. A period 
in front of the number is not necessary. 

Vendor Number 
(VN) 

The rebate vendor that will be the rebate vendor on the rebate information 
 screen. A period in front of the number is not necessary. 

The following examples show spreadsheets with vendor information saved in .csv format. Example 1 
shows a vendor update file in an Excel spreadsheet. Example 2 shows the .csv in text format. 

Example 1 - .txt File Opened in Microsoft Excel 

The following spreadsheet contains vendor information that has been imported into an Excel spreadsheet, 
and is ready to be saved in .csv format and imported into the system. 
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Example 2 - .csv File opened in a Text Editor 

The following text was saved in .csv format and is ready to import into the system. 
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Defining the File Format for Price Updates 
Vendors send price updates in a variety of formats. Determine the file format for the user-defined matrix 
upload before importing the file, and prepare the system to receive the correct format. 

To define the file format for price updates: 

1. Display the character based system. 

Note: The Matrix Upload Utility functionality has not been incorporated into Solar 
Eclipse as of this release. 

2. From the System > Printers menu, select Your Hold Entries to display the Spooler Control 
screen. 

3. Scroll to the name of the update file, and use the Process hot key to display the User Defined 
Upload Processing screen. 

4. In the Processing Type field, enter Matrix Upload User Defined. 

5. Use the Begin hot key to display the User Defined Matrix Entry screen. 

6. In the Work ID field, enter the work ID for this update. 

A work ID can determine a format-specific template for processing a spreadsheet, and does not 
need to be vendor-specific. You can use the same work ID for different vendors if several 
vendors send their data in an identical format. 

7. Complete the remainder of the fields. 

8. Use the File Format hot key to display the Upload File Format screen. 

9. In the Record Type field, enter one of the following formats for the update file: 

• Blocked - fixed-length. 

• Variable - comma-delimited. 

Note: You can also separate data elements in a blocked record by a delimiter. 

10. In the Record Length field, do one of the following: The Record Length field is accessible only 
for blocked-type records. 

• Enter the number of characters necessary if the vendor specifies a record length. 

• Leave the field blank if no length is specified. 

11. In the Delimiter Char field, enter the character used between each field as a delimiter. This field 
is accessible only for variable-type files. 

12. In the Delete Chars field, enter any characters that you do not want read as data, such as 
quotation marks or the dollar sign. 

The system does not recognize the dollar sign as a numeric value, so if the vendor puts a dollar 
sign in front of the prices enter $ in this field. 

13. Press Esc to save the information and return to the User Defined Matrix Entry screen. 
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Creating User-Defined Matrix Cells During Price Updates 
Use the User-Defined Matrix Upload Utility to create buy or sell matrix cells directly from a vendor's 
price update file. You can set up the matrix cells to be branch-specific and for a variety of data, depending 
on the data included in the update file. You can also define your own layout for uploading data to the 
matrix cells. 

You must have the UD.MATRIX.UPLOAD authorization key to access the User Defined Matrix Upload 
screen. 

Important: Uploading user-defined matrix cells does not check to see if identical matrices exist. 
Running this function multiple times creates a duplicate matrix. 

Complete the following tasks before running the update: 

• Download the customer-specific price update file from the vendor. 

• Identify the columns on the vendor's update file. You can create a spreadsheet or use the 
information sheet included with your update file. 

• Ensure the file is in an understandable format for the system: comma delimited (.csv), text (.txt ), or 
Excel (.xls). 

• Import the file into your Hold file in the system. 

• Define the file format for the system, blocked or variable. 

After running the update, verify that the matrix cells were created correctly by viewing them in Quick Sell 
or Quick Buy Matrix Maintenance. 

Note: If there is only a cost in the upload, and no price, the created matrices are O types. 
If a price is included in the upload, the matrices are N types. 

To create buy or sell matrix cells during price updates: 

1. Display the character based system. 

Note: The Matrix Upload Utility functionality has not been incorporated into Solar 
Eclipse as of this release. 

2. Complete the required tasks described above. 

3. From the System > Printers menu, select Your Hold Entries to display the Spooler Control 
screen. 

4. Select the update file, and use the Process hot key to display the User Defined Upload Processing 
screen. 

5. In the Processing Type field, enter User Defined Matrix Upload and use the Begin hot key to 
display the User Defined Matrix Entry screen. 

6. In the Work ID field, enter a selection. 

• Leave the field blank - Does not save the template after this update. 

• A name that identifies to the vendor who sent the file - Creates a new template. 

• The name of the price line being updated - Creates a new template. 
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• Press F10 and select an ID - Uses an existing template. 

7. In the Desc field, enter a complete description for the update. 

8. In the Br/TR/ALL field, enter a branch or territory selection. 

• Enter a branch ID - Creates branch-specific matrix cells for a single branch or territory. 

• Leave the field blank - Creates matrix cells that are not branch-specific, using the DFLT 
branch. This is the default. 

• Enter ALL - The DFLT branch option is used for the matrix cells created. 

9. In the Matrix Type field, select which matrix type you want to create: Sell or Buy. 

The Data Format column below displays different items depending on which matrix type you 
select. 

10. In the Effective Date field, enter the date the matrix cell becomes effective. 

11. In the Expiration Date field, enter the date the matrix cell is no longer effective. 

12. In the Comment Type field, enter a comment type to attach a comment to the matrix cells. Press 
F10 to select from the same comment type selection screen displayed when you use the 
Comment hot key on the Matrix Maintenance screens. This field is required if you enter a 
Comment data point, below. 

13. In the Write Info to Customer Rebate Screen field, enter one of the following: 

• Y - Copies rebate information to the Customer Rebate Maintenance screen. Display this screen 
from Customer maintenance by pressing the Rebate hot key. 

• N - Does not copy information to the Customer Rebate Maintenance screen. This is the default. 

14. In the Start or Elmt# field of the Data Format section of the screen, scroll the data format list to 
find the format you want to update, enter the column number of that data from the update file. 

For blocked records: 

• Start - Enter the starting position character number that begins the section of data. 

• Lngth - Enter the corresponding length of the field. 

For variable records: 

• Elmt# - Enter the element number sequence as it appears in the record. 

Data Formats for matrix cells. 

Data 
Format for 
Sell Matrix 
Cells 

Sell 
Matrix 
Cells 

Buy 
Matrix 
Cells 

Description 

 Class 
 

  Price class for the matrix cell. Class or customer data are 
required. 

Customer 
 

  Customer specified on the matrix cells. If you entered Sell in the 
Matrix Type field, above, Customer displays here. Class or 
customer is required. If left blank, class is used. 
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Data 
Format for 
Sell Matrix 
Cells 

Sell 
Matrix 
Cells 

Buy 
Matrix 
Cells 

Description 

Vendor   
 

Vendor specified on the matrix cells. If you entered Buy in the 
Matrix Type field, Vendor displays here. Vendor data are 
required. 

Product 
Group 

  

Product group specified on the sell matrix cells. Either a product 
group or a product is required. If both are entered, the system 
uses the product first. 

Product 
  

Product specified on the matrix cells. Either product group or 
product are required. If both are entered, the system uses the 
product first. The product information can be either the Eclipse 
ID or the primary UPC. 

Basis 
  

Price basis specified on the matrix cells. The basis used in the 
update file must be represented in Price Line Maintenance. 
You can also use one of the following the following basis names 
not represented in Price Line Maintenance: 
• Lnd Cost 
• Avg Land 
• Ord COGS 
• Ord Comm 
If you use one of these basis names, the format must be exactly 
as stated here. 

Formula 
  

Formula to apply to the basis. 

Matrix 
Effective Date 

  

Effective date specified for the matrix cells. This setting 
overrides the setting in the Effective Date field, above. 

Matrix 
Expiration 
Date 

  

Expiration date specified for the matrix cells. This setting 
overrides the setting in the Expiration Date field, above. 

COGS 
Override 
Basis 

 

  Basis applied to COGS override. The basis used in the update 
file must be represented in Price Line Maintenance. 

COGS 
Override 
Formula 

 

  Formula to apply to the COGS override basis. 

COGS 
Override 
Code 

 

  Cost override code for COGS override. 

COGS 
Override 
Effective Date 

 

  COGS price effective date override. 

Comm-Cost 
Override 
Basis 

 

  Basis for Comm-Cost override basis. The basis used in the 
update file must be represented in Price Line Maintenance. 
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Data 
Format for 
Sell Matrix 
Cells 

Sell 
Matrix 
Cells 

Buy 
Matrix 
Cells 

Description 

Comm-Cost 
Override 
Formula 

 

  Formula to apply to the Comm-Cost override basis. 

Comm-Cost 
Override 
Code 

 

  Cost override code for Comm-Cost overrides. 

Comm-Cost 
Override 
Effective Date 

 

  Comm-Cost price effective date override. 

Rebate 
Contract 

 

  Contract number to use for rebate. 

Rebate 
Vendor 

 

  Vendor to which the rebate applies. 

Prc Eff 
Overide Date 

 

  Price effective date to use for rebates. 

Rebate 
Expire Date 

 

  Date the rebate expires. 

Comment 
 

  Adds a matrix comment to the matrix cells. You must populate 
the Comment Type field, above. 

Price Per Qty 
 

  Price per for net pricing. If this quantity is assigned, the system 
converts the price using the current pricing unit of measure in 
the system. This setting affects products, not groups, which use 
net pricing. The default value is 1. 

Price UOM 
 

  Pricing unit of measure for net pricing. 

Price Sheet 
Date 

 

  Overrides the Prc Date field on the matrix cells. 

Direct COGS 
Override 
Basis 

 

  Basis applied to direct COGS override. The basis used in the 
update file must be represented in Price Line Maintenance. The 
basis used in the update file must be represented in Price Line 
Maintenance. 

Direct COGS 
Override 
Formula 

 

  Formula to apply to the direct COGS override basis. 

Direct COGS 
Override 
Code 

 

  Cost override code for direct COGS override. 

Direct COGS 
Override 
Effective Date 

 

  Direct COGS price effective date override. 
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Data 
Format for 
Sell Matrix 
Cells 

Sell 
Matrix 
Cells 

Buy 
Matrix 
Cells 

Description 

Direct 
Comm-Cost 
Override 
Basis 

 

  Basis for direct Comm-Cost override basis. The basis used in 
the update file must be represented in Price Line Maintenance. 

Direct 
Comm-Cost 
Override 
Formula 

 

  Formula to apply to the direct Comm-Cost override basis. 

Direct 
Comm-Cost 
Override 
Code 

 

  Direct cost override code for Comm-Cost overrides. 

Direct 
Comm-Cost 
Override Eff 
Date 

 

  Direct Comm-Cost price effective date override. 

Direct Rebate 
Contract 

 

  Contract number to use for direct rebate. 

Direct Rebate 
Vendor 

 

  Vendor to which the direct rebate applies. 

Direct Rebate 
Effective Date 

 

  Price effective date to use for direct rebates. 

Direct Rebate 
Expire Date 

 

  Date the direct rebate expires. 

Rebate 
Multiplier 

 

  Populates the Rebate Multiplier column on the Rebate tab in 
Sell Matrix Maintenance on the Default mode line. 
For example, a sell price is increased by $1.00, the factor is 
applied to the increase, ($1.00 x .90), = .90.  Costs will increase 
by ninety cents (.90). The imported value must have a decimal 
point defined on the import file, for example the rebate 
multiplier would be (.50) ;    

Direct Rebate 
Multiplier 

 

  Populates the Rebate Multiplier column on the Rebate tab in 
Sell Matrix Maintenance on the Direct mode line. 

Minimum 
COGS 
Threshold 

 

  Populates the Minimum COGS Threshold column on the 
Rebate tab in Sell Matrix Maintenance on the Default mode 
line. 
The imported value must have a decimal point defined on the 
import file, for example, 548.00. Even though there are no 
partial dollars, the zero cents must be defined. 

Direct 
Minimum 
COGS 
Threshold 

 

  Populates the Minimum COGS Threshold column on the 
Rebate tab in Sell Matrix Maintenance on the Direct mode line. 
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Data 
Format for 
Sell Matrix 
Cells 

Sell 
Matrix 
Cells 

Buy 
Matrix 
Cells 

Description 

Best Price 
Check 

 

  Selects or deselects the Best Price Check check box in Sell 
Matrix Maintenance when using Quick Sell Matrix. Enter Yes 
to select and No to deselect. 

Best Cost 
Check 

 

  Selects how to handle best cost checks. Valid entries: Yes, No, 
All. 

Split 
Quantity 
Pricing 

 

  Selects how to handle pricing for split quantities. Valid entries: 
Yes, No, Extendable 

Enable 
Rounding 
Rules 

 

  Selects or deselects the Enable Rounding Rules check box on 
the Additional tab in Sell Matrix Maintenance when using 
Quick Sell Matrix. Enter Yes to select and No to deselect. 

Restrict Price 
Changes in 
Order Entry 

 

  Selects or deselects the Restrict Price Changes in Order 
Entry check box on the Additional tab in Sell Matrix 
Maintenance when using Quick Sell Matrix. Enter Yes to select 
and No to deselect. 

Exclude 
Items Using 
This Matrix 

 

  Selects or deselects the Exclude Items Using This Matrix 
check box on the Additional tab in Sell Matrix Maintenance 
when using Quick Sell Matrix. Enter Yes to select and No to 
deselect. 

Note: If you set this option to Y, and the control maintenance 
record is not activated, a prompt asks if you want to activate it. 

Expiration 
Quantity 
Type 

 

  Populates the Type field in the Expire Quantities area in Sell 
Matrix Maintenance. Select one of the following: U - Unit, W - 
Weight, L - Load Factor, D - Default List. 

Expiration 
Quantity 

 

  Populates the Original field in the Expire Quantities area 
Enter a value to expire this matrix cell after a quantity of 
product is sold 

15. Use the File Format hot key to define the file format of the import file. 

16. Use the Begin hot key to run the update. 

17. Use the Delete hot key to delete the template, if necessary. The system prompts to confirm the 
deletion. 

18. Press Esc to return to a blank User Defined Matrix Upload screen. 
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Updating Trade Service Prices 
Trade Service is an industry name that includes companies who manage your vendor's prices. These 
companies provide price lists and product information on diskette or CD-ROM that you upload, then run 
the update utility, which applies the changes to your product and pricing records. 

A special file is sent to your weekly FTP directory that allows you to automate the process of 
retrieving, downloading, and processing your weekly update from Trade Service. You may need 
to contact your Eclipse PDW support team so that the feature can be configured for your use. 
This topic includes the following procedures: 

• Processing a CD, diskette, or FTP 

• Importing Trade Service data. 

• Loading Trade Service prices. 

To process a CD-ROM, diskette, or FTP: 

1. Display the character based system. 

Note: The Trade Service Upload functionality has not been incorporated into Solar 
Eclipse as of this release. 

2. From the System > Printers menu, select Your Hold Entries to display the Spooler Control 
screen. 

Note: FTP files must be saved to your hard drive before uploading to the Spooler Control 
screen. 

3. Use the Upload hot key, and select the TRADE.DAT file to upload. For example, for a CD-
ROM, the path is CD drive/TRADE.DAT. 

4. In the Enter Spooler Title field, enter a title for the file, such as TradeService_042004. 

The system displays how many bytes were transferred to the destination. 

5. Press Esc to return to the Spooler Control screen. 

6. Continue with the following instructions. 

To import Trade Service data: 

1. Display the character based system. 

2. From the System > Printers menu, select Your Hold Entries to display the Spooler Control 
screen. 

Note: FTP files must be saved to your hard drive before uploading to the Spooler Control 
screen. 

3. Enter Trade Service Diskette Import, and use the Begin hot key. One of the following occurs: 

If a Trade Service file has been used on the system, the Clear Previous Data and Load Type 
(Y/N) prompt displays. Do one of the following: 
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• If you uploaded a data from a CD-ROM, FTP, or diskette, enter Y. This action clears the 
previous pricing information and imports the new data. The system displays the number of 
records updated. The Downloading screen displays. Select The data only on one line - No 
Conversion when the Downloading screen displays. 

• If your data originated from a 4mm data tape, enter N. This action does not clear the old 
pricing information or import new data. Select The data on multiple lines - Remove CR/LF 
when the Downloading screen displays. 

If a Trade Service file has not been used on the system, the system imports the Trade Service file 
and displays how many records were imported. 

4. Press Enter to return to the Spooler Control screen. 

5. Continue with the following instructions. 

To load Trade Service prices: 

1. Display the character based system. 

2. From the Other > Prc Upd menu, select Trade Service Automatic Price Updates to display the 
Clear Previous Data and Load Tape prompt. 

3. Enter one of the following: 

• Y - Displays the Automated Price Update Preview screen containing details about each item on 
the Trade Service update file. 

• N - Clears the current update information and displays a blank Automated Price Update 
Preview screen. 

4. In the Price Line field, enter a price line ID to change the price line or to add a price line. 

5. If the Automated Price Update Preview screen displays, press Tab to select a product to update, 
and do one of the following: 

• In the Eff Date column, enter the new effective date. 

• Use the Eff Dates hot key, scroll to the first available space, and enter a new effective date. 

6. Use the following hot keys, as needed. 

Hot key Description 
Formulas Displays the Price Sheet Entry (Auto Updates) screen where you can assign formulas 

to change product prices on the update. 

Eff Dates Displays the Price Sheet Days screen. 

Buy Line Displays the Enter Buy Line for Vendor # prompt. Press F10 and select a buy line 
for each product. 

Edit Data Displays the Price Update Data Edit screen with each product's data displayed. 
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Hot key Description 
UPC Displays the UPC Selection screen, where you select the following for matching data 

on the update file: 
• Primary UPC - Uses only the primary UPC for matching. Primary and secondary 

are the default. 
• Secondary UPC - Uses only the secondary UPC for matching. Primary and 

secondary are the default. 
• Up to 10 user-defined UPCs - Uses user-defined UPCs numbered 1 through 10 

for matching. 
• Multiple UPCs - Uses only the first match for updating. 

Updates Displays a view-only screen showing detailed update information on this product. 

Update Detail Field Descriptions 
The Update Details screen displays the following view-only information: 

Field Description 

Vendor The vendor number for the products. 

Price Line The price line ID for the products. 

Price Sheet The price sheet for the products. 

Discount Class The discount class for the products. 

Effective Date The effective date for the prices of the products. 

Price Updates The number of items that contain pricing updates. 

Revisions The number of revisions or changes. 

New Items The number of new items on the update file. 

Deletes The number of items set to a status of delete. 

UPC Changes The number of UPC changes. 

No Updates Number of items that are not being updated. 
 

Replace Displays the Replace Existing Products screen. 

7. Press Esc. 

8. At the Ready to load Automatic Price Updates prompt, enter one of the following: 

• Y - Loads the update file with the information you have defined. 

• N - Exits without loading the update file. 

9. Press Enter to return to the Prc Upd menu. 
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Defining Product Details for Trade Service Updates 
You can select which details you want to replace during a Trade Service update. For example, if product 
names have changed, but you want to maintain the current pricing information, specify that you want to 
replace only product descriptions. 

To define product details to replace: 

1. Display the character based system. 

Note: The Trade Service Upload functionality has not been incorporated into Solar 
Eclipse as of this release. 

2. From the Other > Prc Upd menu, select Trade Service Automatic Price Updates, and enter N 
at the prompt to display the Automated Price Update Preview screen. 

3. In the Replace existing Commodity Code? field, indicate if you want to replace the commodity 
codes in the product records. 

4. In the Replace existing Description? field, indicate if you want to replace the product 
descriptions in the product files. 

5. In the Replace existing Pricing? field, indicate if you want to replace product pricing 
information. 

6. Press Esc to save the changes and return to the Automated Price Update Preview screen. 
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Price Sheet Entry Overview 
Vendors and pricing agencies, such as Trade Service, provide product price information through price 
sheets. These price sheets correspond to your price lines, and if authorized, you can manually enter prices 
on the price sheets. Set up the price line and Price Sheet Entry screen to find the products that need 
updating. Then, manually enter new vendor prices. 

In Price Sheet Entry you can change the following: 

• All pricing within a price line. 

• Pricing for a subset of the items. 

• Pricing for a single product. 

• Maintain different price sheets for the same product. For example, two different branches may use 
different price sheets. If you use different vendors for the same product, create a price sheet for 
each in Product Maintenance. In addition, when a promotional price sheet is set up for a branch, the 
branch maintains a price sheet for the original price and for promotional prices. 

Complete the following to manually update prices in a price line: 

1. Organize the products in the price line you are updating. 

2. Create a new effective date for the price sheet you are updating. 

3. Select criteria to limit the list of items on the price sheet to those you want to update. 

4. Print a worksheet. 

5. Transfer the vendor's price sheet information to the worksheet by hand. 

6. Determine the basis names you want to update. 

7. Enter the updated prices. 
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How Eclipse Handles Price Sheet Hierarchies 
Price sheets are lists of products and their prices. Depending on your vendor's pricing and other pricing 
strategies, you can use price sheets to make sure that your products are priced to benefit both you and 
your customer. Price sheets correspond with price lines which in turn correspond to your products. 

Two kinds of price sheets help you maintain the pricing structure at the price sheet level: default price 
sheets and local price sheets. 

Note: You must be assigned the PRICE.SHEET.MAINT, Level 4 to edit price sheets. 

Default Price Sheets 
The default price sheet (~tilde sheet) holds the most common settings used throughout your company. 
Price sheet changes usually occur because of price changes by the manufacturer. Each branch can 
maintain its own price sheets, but can inherit the values from the default price sheet. 

For example, your company may use the same settings across branches and territories for all values. 
However, your branches in California have different standard cost and replacement cost. You set up a 
default price with all standard settings. Then your Pricing Manager for the California branches can edit 
the standard and replacement costs for the California price sheet only. 

Traditionally, default price sheets contain a tilde (~) in the price sheet name. 

Local Price Sheets 
Local price sheets house the settings specific to how that branch or territory maintain their pricing 
structure. They have specified values for a product's Price Sheet Discount Class at the branch or territory 
level. They may retrieve settings from the default price sheet, but maintain several values that are specific 
to the territory. The local sheet settings take priority. This arrangement ensures that if you can use a 
default price sheet to keep most settings for price sheets throughout your company the same, but adjust a 
setting for a local branch that make handle costs differently. 

Note: Price sheets loaded into the ALL territory are considered local. 

Local price sheets inherit settings from the default price sheets under the following circumstances: 

• For a basis, you have selected Inherit From Default Price Sheet in Product Maintenance. 

• The local price sheet is blank even though a price sheet is in effect for the item as of the date of the 
order. 

About Product Price Sheet Dates 
Local price sheet dates do not have to exactly match the default price sheets for the inherit functionality to 
work. Similar to basis field value validation, if a local sheet is blank and the Use Default is enabled, then 
the system looks for the effective basis field value in the default price sheet. For example, on June 1, 2013 
an item has a local sheet dated 1/1/2013 with a blank value. When looking up the value on the default 
sheet, the last effective price sheet is found on 5/15/2013. This is the value used and displayed. 

In Price Sheet Maintenance for the local price sheets, values inherited from the default price sheet display 
in gray, italicized text with a carrot preceding it. In Price Sheet Maintenance for default price sheets, 
values inherited by "looking backward" to the most recent effective price sheet display in gray, italicized 
text: 
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Consider the following control maintenance records for price sheets: 

Use Future Price Sheet If No Current Price Sheet Is Found 

Copy Default Price Sheet To Blank Sheets In Product Maint 
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Selecting Price Sheets 
You can enter or maintain a product's costing information at the line item level on a price sheet. Price 
sheet changes usually occur because of price changes at the manufacturer. Each branch can maintain its 
own price sheets. 

Different products within the same price line can have different discount classes. A price sheet set up with 
a discount class contains only the products categorized by that discount class. 

Classify products by discount class on the product record and assign each discount class its own formula 
on the price sheet. This way you apply pricing rules to that category of products only. 

Select price sheets by discount class to navigate quickly from one price sheet to the next when updating 
prices. 

To select a price sheet: 

1. Access the Price Sheet Entry window in one of the following ways: 

• From the Maintenance > Price Maintenance menu, select Price Sheet Entry. 

• From the Price Update menu, select Price Sheet Entry. 

2. In the Price Line field, enter the price line ID of the price sheet you want to view. 

A dialog box displays, listing the price lines and the number of items in each price line. The 
default price sheet is always the first in the list. 

3. Select the price sheet. 

A dialog box displays, listing this price sheet's effective dates. 

4. Select the effective date of the price sheet you want to view. The price sheet displays unless the 
price sheet includes a discount class. 

Note: To create a new price sheet, select NEW/CHANGE. 

5. If this price sheet has discount classes, select the discount class from the Discount Class field. 

If the price sheet has multiple discount classes, a prompt asks if you want to display only the 
selected discount class. Enter one of the following to define what discount classes are displayed 
in the Price Sheet Entry/Update window when you manually enter prices: 

• Y - The system limits the discount class to the one displayed in the top right of the screen. 

• N -  The system uses all discount classes associated with the price line. 

6. Make the necessary changes to this price sheet. 

7. Save your changes and exit the dialog box.. 
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Changing Price Sheet Effective Dates 
Create a different price sheet for a price line by changing the effective date on the price sheet. This way 
you maintain the pricing rules set up for the price line, while changing only the necessary details. 

Maintain different price sheets for the same product for the following reasons: 

• Different branches use different price sheets to arrive at their pricing. 

• Different vendors provide the same product at different branches. 

• Promotional price sheets are set up for branches. 

You can use a default price sheet (tilde (~) price sheet) to keep most settings for price sheets throughout 
your company the same, but adjust a setting for a local branch that make handle costs differently. For 
more information, see How Eclipse Handles Price Sheet Hierarchies. 

To change a price sheet effective date: 

1. Display the Price Sheet Entry window in one of the following ways: 

• From the Maintenance > Price Maintenance menu, select Price Sheet Entry. 

• From the Price Update menu, select Price Sheet Entry. 

2. In the Price Line field, enter the price line ID. 

If this price line has more than one price sheet, a list of the price sheets and the number of items 
in each displays. The default price sheet is the first in the list. 

3. If the price sheet list displays, select the price sheet containing pricing rules closest to those you 
want to create in a new price sheet. 

An effective date list displays with all of the effective dates for that price sheet and the 
NEW/CHANGE option. 

4. Select NEW/CHANGE to display the Price Sheet Days window. 

5. In the Purge Age (days) field, enter the number of days to keep this price sheet active. The 
default is 365. 

6. In the Effective column, scroll to the first empty row, enter the new effective date, and click OK. 

The effective date list re-displays including the effective date you just created. The price sheet 
only inherits its value if the most recent date is blank. The local sheet settings take priority. 

7. Select the new effective date from the list. 

8. If discount classes exist for this price line, select the sheet you want to view from the Discount 
Classes field. The price sheet displayed contains the new effective date, and the other window 
information is identical to the existing price sheet. 

9. Enter any new pricing criteria for this price sheet. 

10. Save your changes and exit the dialog box. 
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Limiting the Product List in Price Sheet Entry 
Limit the product list that displays on the update window in Price Sheet Entry. By default, The Price 
Sheet Entry/Update dialog box displays all products in a price line. We recommend limiting the list for 
easy processing. 

Use the following criteria to limit the product list: 

• Select Discount Class 

• Null Basis Only 

• Sheet Sort By 

• Product Index Type 

• Maximum Lines of Description 

• Entity 

To limit the product list in Price Sheet Entry: 

1. Display a Price Sheet. 

2. Select Selection > Include Deleted Items to include products on the Price Sheet Entry/Update 
dialog box that have a status of Delete. This status is assigned to products on the product record. 

3. Select Selection > Selection Criteria to display the Item Select dialog box. 

4. Enter selection criteria in the fields to determine which products to list on the Price Sheet 
Entry/Update dialog box. 

Selection 
Criteria 

Description 

Select Discount 
Class 

Enter one or multiple discount classes separated by commas. Leaving the field 
blank selects all discount classes. Assign discount classes to products in Product 
Maintenance. 

Sheet Sort By Select one of the following to determine the default status of the product list on 
the Price Sheet Entry/Update dialog box: 
• Sort Code - Lists products by sort code, determined in the product record. This 

is the default entry. 
• Product ID - Lists products by product ID, determined in the product record. 
• Status - Lists products by status, determined in the product record. 
• Description - Lists products according to the first line of the description in the 

product record. 
• Prod Sequence - Lists products as they are listed in the price line record used 

for this price sheet. 

Product Index 
Type 

Select one of the following: 
• Primary - Includes stock items only. 
• Catalog - Includes nonstock items only. 
• Both - Includes stock and nonstock items. This is the default. 
Product index types are assigned in the product record as Catalog or Primary. 



Limiting the Product List in Price Sheet Entry 

70 

Selection 
Criteria 

Description 

Maximum Lines 
of Desc 

Determine how many lines of description are necessary to distinguish between 
products on the Price Sheet Entry/Update dialog box. Enter the maximum number 
of lines needed. 

Entity Select either customer or vendor for this price update: 
The part number displays on the Price Sheet Entry/Update dialog box for any 
products that have customer or vendor specific part numbers under the product's 
description. In addition, the customer or vendor name displays at the bottom of 
the window next to the Entity indicator. 

Null Basis Only Select this check box to lists the null basis products - products in the price line 
that have a blank Basis field in Price Sheet Entry. These products did not get 
updated. 
If left unselected, the system lists all products in the price line. 
Run this selection after running an update to get a list of products in the price line 
that did not get updated. 

5. Click OK to activate the selection. 

6. Select File > Enter Prices on the Price Sheet Entry window to view the list of products on the 
Price Sheet Entry/Update dialog box. 
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Printing Price Worksheets for Manual Updates 
Use a printed price worksheet to aid entering prices manually. The worksheet prints the current price for 
products with spaces for writing in the new prices. Write the new vender prices on your worksheet and 
then enter the new prices into the system. 

To print price worksheets for manual updates: 

1. From the Maintenance > Price Maintenance menu, select Price Sheet Entry to display the 
Price Sheet Entry window. 

2. Complete the information on the Price Sheet Entry window for all bases that affect pricing for the 
price line. 

If you type ENTER in the Calculation Basis column for any of the bases, the worksheet displays 
a column of old prices followed by a column of blank lines where you enter the new prices. If the 
Calculation Basis column does not contain ENTER, no worksheet prints. 

3. Do the following to organize the product list before printing the worksheet: 

• Rearrange the product list in the price line for easy product location. 

• Sort the products on the price sheet to organize products or limit the list on the worksheet. 

• To determine if you should include or exclude products in the worksheet that have been 
assigned a Delete status on the Product Maintenance window, select Include Deleted items. 

4. Select File > Print Worksheet to generate the worksheet. 

The worksheet prints to your Hold file and the Phantom messages you when the worksheet is 
available. 

5. Transfer the data from the vendor's price sheet onto your worksheet by hand. 

6. Select File > Enter Prices to display the Price Sheet Entry/Update dialog box. The items listed 
should match the items on the worksheet. 

Note: You must have the PRICE.SHEET.UPDATE authorization key to use the Enter 
Prices hot key. 

See Also: 

Manually Updating Prices 

Price Sheet Entry Overview 
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Manually Updating Prices 
Each time you receive new pricing data for a price line, assign a new effective date to the price sheet to 
create a new price sheet to store with previous price sheets for the price line. 

Use a calculation basis and a formula to calculate the prices or costs for a basis on a price sheet. Then 
manually enter prices into the system. 

To verify that calculation bases, formulas, and prices are calculating the end prices correctly, view the 
new price sheet in the product file. 

This topic contains the following procedures: 

• Entering bases and formulas to determine the calculation for final costs and prices. 

• Entering prices manually on the update window. 

• Viewing price sheets for products. 

Important: Pressing Enter in the Price Sheet Entry/Update window causes dependent costs to 
update. That is, when the cursor moves right after pressing Enter, the cost on 
the newly highlighted cell updates. If you move the cursor down, the entire row 
is updated. 
 
Use the Tab key and the arrow keys to move your cursor through the table 
without updating. 

To set up a price sheet for update: 

1. From the Maintenance > Price Maintenance menu, select Price Sheet Entry to display the 
Price Sheet Entry window. 

2. In the Price Line field, enter the price line ID and select the price sheet and discount class. 

3. Select one of the following: 

• New/Change - To enter the new effective date. 

• An existing effective date - To display a price sheet. 

4. In the Price Change Variance Checking area, enter the percentage limits for the high and low 
end for this price sheet in the fields provided. Example: 

For example, a vendor's prices are increasing 5 percent. To help avoid making errors, set the 
Variance % low end to 0% and the high end to 6%. When entering prices with these settings in 
the Price Sheet Entry/Update dialog box, you accidentally enter a price that is 7 percent higher 
than the previous price. The system warns that you have exceeded the variance allowed. At that 
point you can double check the price you entered, or you can press any key to accept the price 
and continue. 
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5. In the Calculation Basis field, enter the action for each basis name listed: 

Options Descriptions 
ENTER Displays this basis name as a column heading on the Price Sheet Entry/Update 

window, where you manually assign a new value to that basis name, for example: 
1. In the Calculation Basis field for LIST, type enter. 
2. Select File > Enter Prices to display the Price Sheet Entry/Update dialog box. 
3. In the LIST column, update the prices as listed on the vendor's price sheet. 

Note: You are not required to enter a formula for basis names with a calculation 
basis of ENTER, because you manually enter prices for these basis names. 

PREVIOUS The system checks each of the price sheet's effective dates beginning with the most 
recent, and applies the formula and the basis name for the most recent price sheet 
that contains a value. 

NO UPDATE The formula and the basis name for the new effective date remain the same as on 
the previous effective date. 
If the previous price sheet contains a null entry, when a price search is in process 
for a product, the system checks the price sheets beginning with the most recent 
effective date, and applies the price from the most recent effective date that contains 
a value. 

Basis name Enter one of the following: 
• A basis name that is different from that entered in the Basis Names column, but 

is associated with this price line. This entry includes the added basis name's 
formula in the value. 
 
For example, a price sheet from a vendor shows that all REP-COSTS are 
increasing, and lists the individual price changes. You want to calculate your 
LIST price from the vendor's REP-COST for the products in this price line. 

• The same basis name as the basis name in the Basis Names column. This entry 
takes the basis name times 1 (*1). 

6. In the Formula field, enter the formula you want the system to use with the entry in the 
Calculation Basis field to calculate the selling price. 

7. In the Round-To field, enter the number of decimal places for rounding cents. Valid entries are 0 
to 3; 0 does not round cents, 1 rounds to a hundredth, 2 rounds to whole cents, 3 rounds to the 
tenth of a cent. 

8. Select the Display check box to display this basis name in the Price Sheet Entry/Update dialog 
box. otherwise leave it unchecked. 

This field is active only for lines with PREVIOUS, NO UPDATE and basis name entries in the 
Calculation Basis column. If you leave the box unchecked for PREVIOUS, or NO UPDATE, 
 entries in the Calculation Basis column are calculated but do not display in the update dialog 
box. 

9. Save your changes and exit the dialog box. 

To enter prices on the update window: 

1. Set up the price sheet for update. 
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Note: You must be assigned the PRICE.SHEET.UPDATE authorization key to edit 
prices. 

2. Select File > Enter Prices on the Price Sheet Entry window to display the Price Sheet 
Entry/Update dialog box. The following information displays: 

• The view-only Status and UM columns display the product's status and unit of measure. 

• The basis name column headings on the right side of the dialog box are defined by the entries 
in the Calculation Basis and Display fields on the Price Sheet Entry window, described above. 

• Select Views > Expanded to add the following columns to the table. 

• Sort Code - Assigned to the product in Product Maintenance. 

• Product ID - Assigned to the product in Product Maintenance. 

• Product Sequence - Determined by the product ID sequence. 

3. To sort the items by any of the column headings, right-click on the table heading and select the 
intended sort method. For example, to sort the list to display the items with the smallest LIST 
price first, right-click on the LIST table heading, and select Sort By Descending. 

4. In each basis name column (for example, LIST and REP-COST), enter the vendor's price for each 
product. 

5. Save and exit the dialog box when finished entering prices to update the prices. 

To view price sheets for products: 

1. From the Maintenance menu, select Product to display the Product Maintenance window. 

2. Select Pricing > Product Price Maintenance to display the Product Price Maintenance dialog 
box. 

Price sheets display in the columns in consecutive order starting with the most recent. 

3. Save your changes and exit the dialog box. 
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Copying Price Sheets 
This topic shows you how to copy the information from one price sheet to another. You can segment 
price sheets by discount class, and copy a discount class to another discount class. Copying allows you to 
maintain most information on a price sheet while changing only the information necessary. 

Copy price sheet information for the following reasons: 

• You want to maintain the same pricing information from one price sheet to another, but change the 
effective date. 

• You want to offer promotional prices for a time, then return to charging the previous prices. 

• You want to copy pricing information from one discount classes to another. 

This topic includes the following procedures: 

• Copying all the information from one price sheet to another. 

• Copying a discount class to another price sheet. 

To copy all price sheet information from one price sheet to another: 

1. From the Maintenance > Price Maintenance menu, select Price Sheet Entry to display the 
Price Sheet Entry window. 

2. In the Price Line field, enter the price line that contains the price sheet you want to copy. 

3. Select File > Copy Pricesheet, and select the price sheet to which you want to apply the copied 
information, then select one of the following: 

• The effective date to which to copy the information. The system prompts you to enter the 
number of price or cost bases to copy. 

• NEW/CHANGE - To copy the information to a new effective date. Enter the Purge Age 
(days) in the field provided, then enter the new effective date in the first blank row. 

4. Click OK to copy the information and return to the Price Sheet Entry window. 

To copy the discount class from one price sheet to another: 

1. From the Maintenance > Price Maintenance menu select Price Sheet Entry to display the 
Price Sheet Entry window. 

2. In the Price Line field, enter the price line that contains the price sheet from which you want to 
copy the discount class. 

3. Select File > Copy to Discount Class to display a list of discount classes applied to the price 
sheet. 

4. Select the discount class to copy. 

The system copies the discount class you entered in step 3 to the price sheet containing the 
discount class you select. 

5. Make changes as necessary to any of the Price Sheet Entry fields. 

6. Save your changes and exit the window. 
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Maintaining Price Sheets for Different Branches 
This topic describes how to maintain price sheets for products in different branches. 

Maintain multiple price sheets for the following reasons: 

• Your branches obtain the same products from different vendors. 

• Products cost more to ship or store at one branch than at another branch. 

• The promotions you run at one branch differ from those at your other branches. 

A price line can have any number of price sheets associated with it. Carefully check the following if a 
product has multiple price sheets in use at the same branch: 

• The costing and pricing are correct. 

• You are using the correct price sheet for the vendor's product. 

This topic includes the following procedures: 

• Creating branch-specific product price sheets. 

• Entering prices on branch-specific product price sheets. 

To create a branch-specific product price sheet: 

1. From the Maintenance menu, select Product to display the Product Maintenance window, and 
enter a product in the Product field. 

2. Select Pricing > Product Price Maintenance to display the Product Price Maintenance dialog 
box. 

3. Select File > Toggle Hierarchy, enter a branch, and click OK to view the settings for a specific 
branch and where those settings came from. All territories that contain that branch display in the 
Branch /Territory column below the branch, in the order of the territory priority. For more 
information, see Branch Hierarchy Details. 

4. In the Price Sheet column, do the following: 

If... Then... 
for the same price sheet, all 
branches use the same costs 
and/or prices for the products 
in the price line 

leave the field blank. 
The system uses the price line name as the price sheet name, followed 
by a tilde (~). This sheet is called the null price sheet. For example, the 
null price sheet for the SYL price line is named SYL~. 

any branch uses costs or 
prices that are different from 
those at the other branches 

enter a name for the price sheet, such as Branch1, to create a separate 
price sheet for that branch. 
The system attaches the price line name and tilde (~) as a suffix. For 
this example, the new price sheet name for the SYL price line is 
SYL~Branch1. 
Repeat step 3 above, and this part of step 4 to create price sheets for as 
many branches as necessary. 

5. Exit the dialog box to return to the Product Maintenance window. 

6. If the Price Sheet Days dialog box displays, do one of the following in the Purge Age (days) 
field: 
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• Click OK to accept the entry of 365 and click OK. 

• Enter the number of days you want this price sheet to remain on record after the expiration 
date, and click OK. 

7. In the Effective field, select an existing effective date, or enter a new effective date for this price 
sheet. 

Note: The Price Sheet Days dialog box displays for each branch-specific price sheet you 
entered in the Price Sheet field on the Product Price Maintenance dialog box. 

8. Click OK to save your changes and exit the dialog box. 

To enter prices for a branch-specific product price sheet: 

1. From the Maintenance menu, select Product to display the Product Maintenance window, and 
enter a product in the Product field. 

2. Select Pricing > Product Price Maintenance to display the Product Price Maintenance dialog 
box. 

3. Select Pricing > Price Sheet to display the Price Sheet Maintenance dialog box. 

4. Scroll to an effective date, or create an effective date by selecting Edit> Effective Dates. 

5. In the price sheet effective date row, enter the prices for each basis name, as needed. 

6. Do one of the following: 

• Select another price sheet for editing. 

• Save your changes and exit the dialog box. 
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Generating Price Sheets 
Price sheets are lists of products and their prices. Generate price sheets for all or part of your product file: 
customers, vendors, sales representatives at the counter or in the field, and branches. Use data source 
selections to limit the information displayed on our price sheets. 

Note: You must be assigned the COGS.VIEW or COST.VIEW authorization key to print 
cost on a price sheet. 

To set general options: 

1. From the Price Update menu, select Print Price Sheets to display the Print Price Sheets 
window. 

2. In the Price Sheet field, enter a price sheet ID or click New Price Sheet to create a new price 
sheet from which to work. 

3. On the Parameters tab: 

• Review and complete the fields in the General area, as needed. 

Field Description 
As of Date Enter the date for the pricing data on the price sheet. The field defaults 

to the current date. This field accepts variable dates. 
Use the Future Date field to print future-dated pricing data in addition 
to the as of date pricing data. For example, to compare today's pricing 
data with next month's pricing data, enter the date one month from the 
current date. 

Branch Enter the branch, branches, or territories to use for pricing the items on 
the price sheet. 

Selection The entry in this field determines the next field's name and selections: 
If you select Customer/Vendor, the system prints price sheets for 
selected customers or vendors. The next field becomes 
Customer/Vendor, where you enter the customer or vendor's names to 
include in the price sheet. 
• Customer name - Prints price sheets specific to that customer. 
• Vendor name - Prints price sheets that show what you pay this 

vendor for the products in the price lines. 
If you select Out Salesperson, the system prints price sheets for 
selected salespeople. The next field becomes Out Salesperson. 
• Enter a salesperson's ID - Prints a list of all of this salesperson's 

customers. 
• Leave this field blank, and enter price classes using the CLASS# 

selection in the Data Source field to create a generic price book. 
If you select the Only Customers with Assigned Lines option, you 
cannot make a selection in this field. 

Last Activity Date Enter a date to include only the products purchased from a vendor or 
sold to a customer on or after that date. 
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Field Description 
Future Date Enter a date in the future to print future-dated pricing data in addition to 

the as of date pricing data. For example, to compare today's pricing data 
with next month's pricing data, enter the date one month from the 
current date. 

Saved List Leave this field blank unless you want to enter a saved list, if so enter 
the name of a saved list in this field. 
If you are using a saved list, deselect the following options. The system 
ignores, or does not allow entry in these fields when using a saved list: 
• Only Custs with Assigned Lines 
• Only Customer Specific PNs 
• Select from Reorder Pad 
• Sort by (Format tab) 

Note: If no saved list exists, and if you understand how to use TCL 
(Terminal Control Language), you can build your own editable saved 
list. Alternately, you can contract with Eclipse to create a saved list that 
gives you the information you want. 

Only Customer 
 Specific 
Overrides 

Select the check box to include only those products whose prices come 
from a customer-specific sell matrix for each customer's price sheet. If 
this item remains unchecked, all products are included on the report 
regardless of which sell matrix it comes from. 

Only Customers 
with Assigned 
Lines 

Select the check box to print the price sheet for only those customers 
who have price lines assigned in Customer Maintenance, and include 
only the products in those price lines. This entry overrides the Price 
Lines field on the Product Selection tab. If you select this option, you 
cannot populate the Selection field. 

• Review and complete the field in the Product Selection area, as needed. 

Field Description 
Price Lines Enter price lines to include on the price sheets. The lists can be saved for 

future use. If you leave this blank, the system includes all price lines 
assigned to the customer. 
The system ignores settings on this window if Only Customers with 
Assigned Lines is selected, price lines specified in this field are ignored. 

Product Status Limit the list of products on the price sheets to only those assigned a 
certain status, for example, stock, nonstock, or miscellaneous charges on 
the product record. 

Sell Group Limit the products in the price sheets to those assigned to certain sell 
groups. 
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Field Description 
Print Quantity 
Breaks 

Select one of the following for products subject to quantity break pricing: 
• None - Does not display the product's quantity breaks on the price sheet. 

If this option is activated, the Extend Quantity Breaks option is not 
available. 

• Row - Prints the product's quantity breaks in rows below the product. 
• Column - Prints the product's quantity breaks in columns to the right of 

the price column. 
If the Print Quantity Breaks option is set to Row or Column, check 
Extend Quantity Breaks to display the dollar amount that the customer 
has to spend to reach each break point on the price sheet. If this option is 
not checked, the break point dollar amount on the price sheet does not 
display. Use the CUST SPEC data source to display quantity breaks on the 
report. 

Inventory 
"Stock" Status 

This option works with the Stock column on the Primary Inventory 
Maintenance window for all products in the branch. Select one of the 
following: 
• Stock - Includes the product if the Stock field on the Primary Inventory 

Maintenance window contains Yes or Auto and meets the minimum 
number of hits to consider the product a stock product. 

• Nonstock - Includes the product if the Stock field on the Primary 
Inventory Maintenance window contains No or a Auto and does not 
meet the minimum number of hits to consider the product a stock 
product.. 

• All - Includes both stock and nonstock items. 

• Select the remaining check boxes in the Product Selection area, as needed: 

Select this 
check box... 

To... 

Select Active 
Products Only 

limit the products on the price sheet to only those that are active at the selected 
branches. 
Use the Branch/Terr field to select the branches in which you want to limit the 
active product selection. 

Select from 
Reorder Pad 

print a price sheet for only those products on the customer's Reorder Pad. If 
deselected, the system selects all products for the price lines specified. 

Respect Print 
Flag 

honor the Respect Print flag in Additional Product Pricing. 
The Respect Print Flag check box is dependent upon the entry in the Print Price 
Sheet column in the Product Price Additional Data window (Maintenance > 
Product Maintenance > Pricing > Additional) being deselected. The Print Price 
Sheet option flags a product on a branch-by-branch basis to include or exclude from a 
price sheet. 
If this Respect Print Flag option left deselected, the Print Price Sheet flag is 
ignored, and all selected products are included on the price sheet print. 
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Select this 
check box... 

To... 

Only Customer 
Specific PNs 

create a price sheet that includes only products that have a customer-specific part 
number. If deselected, the system includes all products in the selected price lines. 
This option is active only when you enter a customer in the Customer/Vendor field. 

Note: If a save list is used for this report, it displays in the Use Save List field, and 
the Only Customer Specific PNs option is inactive. 

Extend 
Quantity Breaks 

display the extended dollar amount needed to hit the defined break, set to Yes. This 
works in conjunction with the Print Quantity Breaks field in the Product Selection 
area. 

Select Both 
Reorder Pad 
and Customer 
Overrides 

have the system check to see if an item is in the Reorder Pad or has a customer 
specific override. If either is true, the system includes the item in the price sheet. 
Select this field only if both the Select from Reorder Pad and Only Customer 
Specific Overrides fields are selected. If this field is not selected and the Select from 
Reorder Pad field and Only Customer Specific Overrides field is selected, the 
system first checks the Reorder Pad and then checks the customer part number. If the 
item exists in the Reorder Pad and the Only Customer Specific Overrides field is 
selected, the system includes it in the list. 

Only Price 
Changes 

include products whose dollar amounts change between the As of Date and the 
Future Date. Price changes can be further filtered by using combinations of the 
following fields: 
• Respect Print Flag 
• Select from Reorder Pad 
• Only Customer Specific PNs 
• Select Reorder Pad and Override 
This field is dependant upon the inclusion of at least one of the following data 
sources: 
CUS SPEC 
BASIS# 
COGS 
CUST COMM 
DLFT COST 
DFLT LIST 
LIST GP% 
CUST GP% 
COST OVRD 
For more information about data sources, see Defining Data Sources and Columns for 
Price Sheets. 

Only Fixed 
Pricing 

limit the price sheet to select only customers that have fixed pricing (price formulas 
that start with $) 

GP Range From 
and GP Range 
To 

include only customers with a gross profit that falls into that range. Using these fields 
allows you to print the price sheet for only customers with margins less than or more 
than what you specify. 

4. On the Format tab: 
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• Select your price sheet display options. 

Field Description 
Sort By Select whether to sort the price sheet by price line or customer part number. 

Date Format / Date 
Separator 

Select how you want your dates to display on your price sheets. Indicate the 
date format, such as MMDDYYY and the separator such a /. Your dates 
display as 10/26/1998. 

Page Break On Select one of the following page break preferences: 
• Price Line - Breaks at each price line. 
• Customer - Breaks at each customer. 
• Nothing - Breaks where the page margin dictates. 
• Customer/Price Line - Breaks at each customer and each price line. 
• Salesperson - Breaks at each outside salesperson. 

Report Break Select this check box to start a new report on each new item in the Page 
Break field. For example, if you set the Page Break field to Customer, a 
new report begins for each customer. 
Leave this check box deselected to create one report. A blank row is 
inserted between each item, and the report breaks as you specified in the 
Page Break field. 

Data Source Select a data source for each column heading to include on this price sheet. 
You must be assigned the COGS.VIEW or COST.VIEW authorization key 
to print cost on a price sheet. 

Note: To delete old price sheet formulas in the Eclipse Product File use the 
Rebuild Price Sheet/Discount Class Cache Utility. For example, if a vendor 
gives you disks with new price sheets and discount classes, run this utility 
to delete the old price sheets and discount classes in your Eclipse Product 
File. 

• Format the column structure using the table to adjust your price sheet format. 

Column Description 
Column The column on the price sheet you are formatting. 

Data Source Select the type of data you want for the column, such as Avg Cost. 

Heading Enter the heading name you want to use. 

Justify Indicate which side of the column to justify the text to, such as R for prices 
and L for text. 

Width Define the maximum width for the columns depending on the data. For 
example, the column for branches may only need to be 3 characters wide, 
while a part number may need 15 characters. 

Pad Select the separator between columns: periods, zeroes, or blank spaces. 

Decimals Enter the number of decimal places you want to use in the column. Leave 
blank to eliminate decimals. 

Comma Indicate if you want to use commas in when there are more than four place 
values, such as $4,623. 
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Column Description 
Support Zero Indicate if you want to support zeroes in the column. 

5. Set options and generate the price sheets. You can schedule price sheets to print regularly, if 
needed using the Phantom Scheduling. 

Note: If you make changes to the price sheets through the phantom scheduler, the system 
pushes the changes back to the original report. You do not need to delete and 
reschedule the price sheets to run to make changes. 
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Defining Data Sources and Columns for Price Sheets 
The system uses data sources, such as AVG COST, to help you analyze your price sheets. For example, 
you can review price lines, units of measure, matrix group and sell groups across products. Use the 
Format function on your price sheet to determine the data sources that display on a printed price sheet. 
The system predefines data sources, and you must be assigned the COGS.VIEW or COST.VIEW 
authorization key to print cost on a price sheet. 

To define data sources and columns for a price sheet: 

1. Display the Print Price Sheets window. 

2. Enter the necessary criteria for the price sheet as described in Generating Price Sheets. 

3. Click the Format tab. 

You must be assigned the COGS.VIEW or COST.VIEW authorization key to print cost on a price 
sheet. 

4. In the Sort By field, select how to sort the data: Line (sorts by price line) or Part Number. 

5. In the Page Break on field, indicate where to add page breaks. 

• Price Line - Breaks at each price line. 

• Customer - Breaks at each customer. 

• Nothing - Breaks where page margin dictates. 

• Customer/Price Line - Breaks at each customer and each price line. 

6. Check Report Break to start a new report on each new item in the Page Break On field. For 
example, if you set the Page Break On field to Customer, a new report begins on each customer. 
If this is unchecked, the list continues without page breaks. A blank row is inserted between each 
item in the list. 

7. In the Data Source column, enter a data source for each column to display on this report. 

Data Source Description 
*LINEBREAK* Inserts a line break and starts printing the following columns of 

information on a new line. The columns after the *LINEBREAK* print 
on the next line down. 

3M SQTY Prints the quantity sold in the last three months to the customer entered 
on the price sheet. 

ATTB# Prints the value in the product file assigned to the attribute number that 
you enter. You must know the dictionary layout of the product file to 
know what value you are pulling. Enter the attribute number next to the 
number sign (#), before moving to the next column. For more 
information, see Eclipse Dictionary Overview. 

AVG COST Prints the current system-calculated average cost for the product in 
inventory at the branch. 

BASIS# Prints the price that corresponds to the local basis name in the line 
provided, counting down from the top. Enter the basis number next to 
the number sign (#), before moving to the next column. 
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Data Source Description 
CLS# Enter the class price for the products to include on the price sheets. This 

class prices the items as if the customer were assigned to that price 
class. Enter the class number next to the number sign (#) before moving 
to the next column. 

COGS COST Prints the price assigned on the Product Price Sheet Maintenance 
window to the local basis name that is assigned to the COGS COST 
global basis name for the product's price line. 

COMM CODE Prints the commodity code assigned to the product on the Product 
Maintenance window. 

COST OVRD Prints any cost override associated with the product. The column is 
blank if there is no override cost. 

CUST COGS Prints overridden cost of goods sold cost from the matrix cell for the 
customer. If an override does not exist on the matrix cell for this 
customer, the report displays the value found in the basis that is 
pointing to the global basis COGS-COST in Price Line Maintenance. 
Use this option only for internal reporting. 

CUST COMM Prints overridden commission cost from the matrix cell for the 
customer. If an override does not exist on the matrix cell for this 
customer, the report displays the value found in the basis that is 
pointing to the global basis COMM-COST in Price Line Maintenance. 
Use this option only for internal reporting. 

CUST GP% Prints gross profit percent that is found based upon the matrix for the 
customer. The system uses the cost of goods sold cost when calculating 
the GP%. Use this option only for internal reporting. 

CUST ID Prints the customer's internal ID number, which identifies the customer 
to the system. 

CUST PN Prints the customer-specific part number if one has been assigned to an 
item that is included on the price sheet. 

CUST SPEC Prints the customer-specific price, which is the customer's normal price 
for the as-of date of the report. 

DESC2-6 Prints lines two through six of the product description. 

DESC LINE 1 Prints the first line of the product description, unless DESC.WORD.1 
comes before DESC1. Then DESC1 prints everything after the first 
word in the first line of the product description. 

DESC LINE 2 Prints the second line of the product description. If that line is blank, 
the column contains a blank line. 

DESC LINE 3 Prints the third line of the product description. If that line is blank, the 
column contains a blank line. 

DESC MULTI Prints all lines of the product description. 

DESC WORD 1 Prints the first word in the first line of the product description. If DESC 
WORD 1 comes before DESC LINE 1, DESC LINE 1 prints 
everything after the first word in the first line of the product 
description. 
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Data Source Description 
DFLT COST Prints the price assigned on the Product Price Sheet Maintenance 

window to the local basis name that is assigned to the DFLT COST 
global basis for the product's price line. 

DFLT LIST Prints the price assigned on the Product Price Sheet Maintenance 
window to the local basis name that is assigned to the DFLT LIST 
global basis for the product's price line. 

DISC CLASS Prints the discount class assigned to the product on the Product Price 
Maintenance window. 

EXPIRE DATE Prints the expiration date of the corresponding pricing matrix cell that is 
currently in effect for the product. 

HEADING Prints the heading as a column value in the report. For example, if the 
heading were 10 underlines, it prints the underlined area to be used as a 
place to write something, such as, DATE. 

ID Prints the system's internal product number. 

KEYWORD 1 Prints the first word, delimited by a space, that is in the Additional Key 
Words field in the product record. If that line is blank, the column 
contains a blank line. 

KEYWORD 2 Prints the second word, delimited by spaces, that is in the Additional 
Key Words field in the product record. If that line is blank, the column 
contains a blank line. 

LAST COST Prints the last amount, purchase price, or COGS COST, paid for the 
product at the branch. 

AVG COST Prints the current system-calculated average cost for the product in 
inventory at the branch. 

LAST SALE DT Print the date the product was last sold to the customer entered on the 
price sheet. 

LAS SALE PRC Prints the price the product was last sold to the customer entered on the 
price sheet. 

LIST DISC Prints the difference between the price the customer is being charged 
and the LIST PRICE. 

LIST GP% Prints the gross profit percent found using the LIST price of the product 
to the cost of goods sold cost for the product. Use this option only for 
internal reporting. 

MATRIX GRP The sell group or product ID on the matrix cell. 

PRC LINE Prints the name of the product's price line. 

QTY SOLD Reports the quantity sold for a specified date range. You can include 
the QTY SOLD data source only if 
you set the Select from Reorder Pad field to Yes. 

RANK # Prints the products for the rank you select. 

SELL GROUP # Prints only the sell group position selected, regardless if the product 
lives in multiple sell groups. 

SELL GROUP Prints all the sell groups assigned to the product, from the Price Group 
Maintenance window, in the product's branch. 
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Data Source Description 
SORT CODE Prints the sort code assigned to the product on the Product Maintenance 

window. 

SPACE Inserts a blank column of the defined width. 

U/M DESC Prints the descriptive unit of measure defined in the Per UM field on 
the Product Price Sheet Maintenance window, which describes the unit 
of measure. For example, box or each. 

Note: When you move to another data source line, the system prompts 
you to select how to display the unit of measure: Make Upper Case 
(BX), Make Lower Case (bx), or Keep As Is (default from the system). 
For each U/M data source, you select how to handle the display. 

U/M QTY Prints the quantity defined in the Per Qty field on the Product Price 
Sheet Maintenance window that is assigned to the unit of measure 
entered in the Per UM field on the same window. For example, if the 
Per UM were box, the Per Qty might be 12 per box. 

Note: When you move to another data source line, the system prompts 
you to select how to display the unit of measure: Make Upper Case 
(BX), Make Lower Case (bx), or Keep As Is (default from the system). 
For each U/M data source, you select how to handle the display. 

UPC Prints the number in the Primary UPC field on the UPC Codes 
Maintenance window, accessed by using selecting Additional Data 
>UPC Code Maintenances on the Product Maintenance window. 

WEIGHT Prints the weight assigned to the product on the Product Maintenance 
window. 

YTD QTY Prints the total quantity, in the lowest unit of measure, of the item that 
has been sold out of the branch from the beginning of the fiscal year 
through the as of date. 

8. In the Heading column, enter the name of the heading to display for each data source. 

The heading is user-defined up to the width of the column. If you enter a heading that exceeds the 
width of the column, the system truncates it to fit the column width. 

9. In the Jus column, enter the justification you want for the column: 

• L (left) - Starts printing the entry at the left side of the column. Use this setting if the data is 
alphabetic. 

• R (right) - Starts printing the entry at the right side of the column. Use this setting if the data is 
numeric. 

Note: If you enter L in this column and move the cursor to the Pad column, an entry is 
required in the Pad column before exiting that column to ensure blank spaces 
display appropriately. 

10. In the Width column, enter the number of characters for displaying data in each column. The 
width of the column depends on the remaining number of character spaces available. The total 
number of characters available in portrait mode is 80. The total number of characters available in 
landscape mode is 100. 
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11. In the Pad column, enter one of the following: 

• Y (periods) - Fills the blank spaces in a column with periods before or after the data, depending 
on the justification selected. 

• Z (zeros) - Fills the blank spaces in a numeric column with zeroes. 

• N (blank spaces) - Leaves the blank spaces in a column blank. 

12. In the Decm (decimal) column, enter the number of decimal places for a numeric entry. You 
cannot access this column if the Jus column is set to L. 

13. Select the Comma check box for each data source that you want to insert a comma in numeric 
entries greater than 999. 

You cannot access this column if the Jus column is set to L. 

14. Select the Support Zero check box for each data source if you want to leave a numeric field 
blank for entries of zero. If left deselected, entries of zero print as numeric. 

You cannot access this column if the Jus column is set to L. 
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Customizing Price Sheet Headers 
You can change the header on your price sheets, if needed, so they reflect the information you need to see 
regularly. For example, you can add a comment to display on each header sheet, such as "All prices 
associated with miscellaneous charge items are under review." 

To customize a price sheet header: 

1. Display the price sheet that you want to add a new header to. 

2. From the Edit menu, select Header Edit.  

3. Select Column Headers if you want to include default column headers when creating price 
sheets. 

4. Use the following fields to define how you want to use or replace the header information for 
different areas: 

 
• Standard Branch Header - Indicate if you want to include the standard branch header on the 

price sheet you are managing. 

• Standard Main Header - Indicate if you want to include the standard main header when 
customizing your price sheets. 

• Standard Break Header - Indicate if you want to include the standard break header when 
customizing your price sheets 

• User-Defined Download - Indicate if you want to use the standard extract for price sheets or if 
you want to use the user-defined download utility to pull pricing information for your price 
sheets. 

Note: You can also choose to replace the any of these selections with something more 
specific using the table at the bottom of the page. 

5. If you selected to replace any of the headers, use the Header Item table to define what to use as a 
replacement: 

• Header Type - Select which kind of field you want to use for the header. 

• Heading Value - To correspond with the Column Header Type, enter the information you 
want to use on the header, such as the date format. 

For example: 
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6. Click OK to save your changes and return to the price sheet details. 
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Defining Price Sheet Download Parameters 
The Price Sheet Download function allows the user to select a file name and format which auto populates 
the e-mail, FTP and windows direct option. You can run price sheets and have it e-mail a file, such as MS 
Excel, of the pricing automatically using the parameters you define. 

To define the download parameters for a price sheet file: 

1. From the Price Update menu, select Print Price Sheets to display Price Sheet Entry. 

2. Display the price sheet for which you want to define download parameters. 

3. From the File menu, select Download to display the Download Options. 

4. Complete the download parameters for the price sheet: 

Field Description 
File Name Enter the name you want the file to have each time it is extracted, such as Branch 3 

NStock. 

File 
Extension* 

Select the type of file you want the extract to be in: .csv, .pdf, .txt, .xlsx, or Other. 
This field is five characters long. 

Column 
Delimiter* 

Select how to separate the values in the file for each column: pipe (|), comma, 
semicolon (;), tilde (~), none, space, tab, or other. The delimiter is two characters 
long. In addition: 
• If you select .csv in the File Extension column, the system auto-populates this 

field with a comma and you cannot edit it. 
• If you select .pdf, .xls, or .xlsx in the File Extension column, the system grays out 

this field and you cannot edit it because these formats typically are not delimited. 

Line 
Delimiter* 

Select how to separate the values in the file on each line: pipe (|), comma, semicolon 
(;), tilde (~), CR, CRLF, LF, space, Tab, or Other. The delimiter is two characters 
long. 

Trim Blanks Type Yes to have the system eliminate any blanks that are not delimiters. 

No Decimals Type Yes to remove decimals from the extract. 

Footer 
Comment 

Enter any footer comment you want to add, such as "Prices are subject to change 
without notice." 

* If you select Other, the system prompts you for a user-defined entry. 

5. Save your changes and exit the window. 
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Buy and Sell Group Overview 
Although you can price products individually, most products are more easily priced when arranged in 
groups. Define buy and sell groups, then assign products to the groups. These groups are used when 
creating buy and sell matrix cells. 

You assign buy groups and sell groups to products by branch. When a branch level transaction occurs, the 
branch-specific group is used to determine the correct price. 

Use sell groups to identify groups of products that share the same pricing rules. This grouping can reflect 
vendor classifications of products for costing purposes, and in such cases sell groups can be the same as 
discount classes. You can also group products according to the sales velocity or ranking of the item, 
which means you would group your A items together, your B items together, and your C items together. 
Use this approach when the selling price is associated with its relative velocity. Assign a different 
multiplier to slow-moving items to ensure a greater profit from those items. 

Use buy groups to identify a group of products that share the same costing rules. Group products into buy 
groups when you have multiple primary vendors for a group of products, or when complex pricing 
relationships exist between your primary vendors and the product groups that you purchase from them, 
such as quantity breaks. 
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Pricing Group Guidelines for Matrix Cells 
The system provides ways of grouping customers and products for your organization. Use these groups to 
determine costs and prices when buying and selling products. Anyone in your organization who buys, 
sells, or does accounting needs an understanding of the following group concepts for pricing: 

• Customer Price Classes 

• Product Groups 

• Buy Groups and the Matrix Cell 

• Sell Groups and the Matrix Cell 

Customer Price Classes 

Customers are categorized by price class and customer type. These categories are set up in the Valid 
Customer Price Classes and Default Customer Price Class control maintenance records. Grouping 
customers by price class lets you give your best customers your best prices. 

The customer type is used for promotional pricing. Define the customer type and default price class from 
the customer record. For example, your customer types may be: large contractor, small contractor, 
electrical, industrial, and retail. You can give all electrical customers a discount this month on certain 
products. 

Product Groups 

Categorize products by product buy and sell groups. Organizing products by groups allows you to apply 
similar pricing to similar products. These product groups can include all or part of the products in a price 
line. For example, In the Sylvania price line, miniature lamps could be in one sell group, and fluorescent 
lamps another. Product groups are defined in Price Group Maintenance. 

You can also group products according to the sales velocity, or ranking, of an item. For example, group 
your A items, your B items, and your C items. Use this approach when the selling price of the item is 
based on its relative velocity. Slower moving items have a different multiplier than the multiplier for 
faster-moving items. 

Buy Groups and the Buy Matrix 

Create matrix cells in Quick Buy Matrix and Buy Matrix Maintenance using buy groups and a formula to 
determine the costs of products from your vendors. 

For example, you can purchase lamps from more than one vendor. The following table shows matrix set 
up for four vendors, listed across the top, and three buy groups, listed on the left. Each table cell 
represents one buy matrix cell. When you purchase lamps from the FLU-LMP group from Phillips 
Manufacturing, the system selects the matrix cell assigned to that vendor and group. In this example, the 
formula for the florescent lamps is TRADE -23%. 

Manufacturers: Sylvania Mfg. Phillips Mfg. General Electric Seagull Lighting 

Buy Groups: 

MIN-LMP 
(Miniature 
Lamps) 

TRADE -20 TRADE -21 TRADE -20/2 TRADE -20 
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Manufacturers: Sylvania Mfg. Phillips Mfg. General Electric Seagull Lighting 

Buy Groups: 

FLU-LMP 
(Fluorescent 
Lamps) 

TRADE -25 TRADE -23 COL3 -20 LIST-50/10 

MISC-LMP 
(All Other 
Lamps) 

TRADE - 25 TRADE -26 TRADE -26/5 TRADE -25.6 

The system requires buy groups for the following reasons: 

• To maintain multiple pricing arrangements from multiple vendors on the same group of products. 

• To have multiple pricing arrangements from a single vendor on the same group of products, such as 
quantity breaks. 

When you have a single primary vendor you can maintain costing through the price sheet and price sheet 
discount classes instead of a buy matrix cells. 

Sell Groups and the Sell Matrix 

Create matrix cells in Quick Sell Matrix and Sell Matrix Maintenance using sell groups and formulas to 
help determine the prices of products for your customers. 

For example, lamp prices vary for different customer price classes. The following table shows matrix cell 
set up for four customer price classes, listed across the top, and three sell groups, listed on the left. A row 
intersects with a column at a matrix cell, which contains the formula the system uses to price the product. 
When you sell lamps from the SYL-FLR group to a customer assigned price class 2, the system selects 
the matrix cell assigned to that customer price class and group. In this example, the formula for the 
florescent lamps is REP-COST *1.8 (replacement cost plus 8%). 

Sell Group Customer 
Price Class 1 

Customer 
Price Class 2 

Customer 
Price Class 3 

Customer 
Price Class 4 

SYL-MIN 
Miniature 
Lamps 

REP-COST x 1.8 REP-COST x 1.7 REP-COST x 1.6 REP-COST x 1.5 

SYL-FLR 
Fluorescent 
Lamps 

REP-COST x 1.9 REP-COST x 1.8 REP-COST x 1.7 REP-COST x 1.6 

SYL-COOL 
Cool White 
Lamps 

REP-COST x 2 REP-COST x 1.9 REP-COST x 1.8 REP-COST x 1.7 
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Creating Buy and Sell Groups 
A product group is a set of products that share a common pricing scheme. 

Create price lines and buy lines before defining buy groups and sell groups. If you try to define a buy 
group or sell group before defining your price lines, the system prompts you to create a price line on the 
fly. After creating price line and buy lines, create paper lists of the buy and sell groups that will be part of 
each buy line and price line. Refer to the list when creating buy and sell group IDs in Buy/Sell Group 
Maintenance. 

To create a buy or a sell group: 

1. From the Maintenance > Price Maintenance menu, select Buy/Sell Group to display the 
Buy/Sell Group Maintenance window. 

2. In the Group ID field, click the New Group button, enter an ID for the buy or sell group, and 
click OK. 

Note: To display an existing buy or sell group press F10 to display a list from which to 
select. For more information, see Assigning a Group ID to a Buy or Sell Group. 

3. In the Description field, enter a description of the buy or sell group. 

4. In the Price Line field, enter the price line to use with this group. 

5. In the Representative Product field, enter the representative product for each sell group. 

6. In the Group Price Unit of Measure field, enter the unit of measure to use when setting up a 
matrix cell with quantity breaks for the sell group, and when assigning the G (Group Quantity 
Break) matrix type in Sell Matrix Maintenance. 

7. In the Group Type field, assign a group type to this buy or sell group. Group types are used for 
reporting purposes and are defined in the Valid Buy/Sell Group Types control maintenance 
record. 

8. In the Combo Group field, enter the name of the combination group if this group will be part of 
a combination group. 

9. In the Combo Contributor field, select how to handle the quantities, if items in this group are 
part of a combination group: 

• No, do NOT add group's qtys into total Combo break but use Combo pricing - Does not 
add the group's quantities to the total Combo break, but uses Combination (type C matrix cell) 
pricing. 

• Yes, add group's qtys into total Combo break and use Combo pricing - Adds the group's 
quantities to the total Combo break, and uses Combination (type C matrix cell) pricing. 

• Qtys are to be added to total Combo break but do not use Combo pricing - Adds quantities 
to the total Combo break, and does not use Combination (type C matrix cell) pricing. 

• No, do NOT add group's qtys into total Combo break but use Combo pricing - Does not 
add the group's quantities to the total Combo break, but uses Combination (type C matrix cell) 
pricing. 

• Yes, add group's qtys into total Combo break and use Combo pricing - Adds the group's 
quantities to the total Combo break, and uses Combination (type C matrix cell) pricing. 
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• Qtys are to be added to total Combo break but do not use Combo pricing - Adds quantities 
to the total Combo break, and does not use Combination (type C matrix cell) pricing. 

For example, you have a customer who gets quantity break pricing for all copper products, except 
on small copper pipe hangers, which cost very little. The quantity break level is 600, and the 
customer orders 500 elbows and 1000 copper hangers. Enter No, do NOT... in this field to keep 
those 1000 hangers from contributing to the quantity that determines the break level. This ensures 
that the customer would not earn a quantity break for a lot of inexpensive items. 

10. In the Minimum Price Basis field, enter the global basis to be used to determine the minimum 
sell price for a product. 

The Minimum Sell Basis represents the minimum price a user can use when overriding the sell 
price to the customer. This check occurs before any GP% check that could be set up in the 
system. 

The system checks the product's sell group first for a Minimum Price Basis. If a basis field is not 
selected, the system checks the Price Line for a Minimum Price Basis. 

The Minimum Sell Basis represents the minimum price a user can use when overriding the sell 
price to the customer. This check occurs before any GP% check that could be set up in the 
system. 

Note: You must have the SOE.MIN.SELL.PRICE authorization key assigned in order to 
manually override the minimum selling price for the item in Sales Order Entry. 

11. Save your changes and exit the window. 
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Assigning Group IDs to Buy or Sell Groups 
Buy group can be a subset of a price line used with the buy or sell matrix, or can exist independently from 
a price line. Define buy and sell group IDs in Buy / Sell Group Maintenance and assign the groups to 
products in Product Maintenance. 

A sell group is a set of products that share a common pricing scheme. Use a sell group ID to group items 
together when you want to use the same pricing formula to calculate the selling price assigned in the sell 
matrix. 

A buy group is a set of products that share a common costing scheme. Use a buy group ID to group items 
together when you want to use the same pricing formula to calculate the buying price assigned in the buy 
matrix. 

Naming Groups 
When you assign a buy or sell group to products or to matrix cells, the group ID indicates what the group 
contains. Give meaning to a group ID by starting the name with the price line or buy line ID followed by 
characters that define the subset. 

For example, if you have multiple sell or buy groups associated with a price line, avoid a pattern of group 
names that starts with the price line ID by itself, then is followed by groups that use that price line ID as a 
prefix, as shown in the following table: 

Use this naming 
method 

Do not use this 
method 

SYL-GEN SYL 

SYL-LMP SYL-LMP 

SYL-WHT SYL-WHT 

SYL-MISC SYL-MISC 

With the second naming pattern, if you enter SYL as a group ID, SYL displays in the field, instead of 
giving you a choice of all the SYL groups. With the first pattern, if you enter SYL, all the SYL groups 
display, so you can choose from the complete SYL group. 
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Changing Buy and Sell Group IDs 
Use the Change Buy/Sell Group ID utility to replace an existing buy or sell group name with a new group 
name everywhere that group is used throughout the system. This change affects all effective matrix cells 
using the old group name, the product file of items associated with that group name, and any items on 
open orders that are priced using the old group name. 

By running this utility, you create a new buy and/or sell group. The system creates a maintenance log 
record in the product file documenting the change. Any group matrix cell currently being used with the 
old sell and/or buy group name expires and the system creates a new matrix cell with the new sell and/or 
buy group name.                                                    

In addition, the system changes the effective date of the new matrix cell to the current day. The expire 
date of the old matrix cells are the day before the existing expire date. The expire date of the new matrix 
cell remains the same as the old matrix cell. The old matrix cell's expiration date becomes the date before 
the day the utility was run last. For example, if you run the utility today, the old matrix cell's expiration 
date becomes yesterday's date. The system creates a maintenance log record for the old matrix cell. Any 
line item on existing open orders using the old matrix cell are updated with the new matrix cell. 

Important: The system does not remove the old buy or sell group from the price group file in 
the system. The old group remains along with any matrix cell that was using the 
sell group, but the sell matrix is expired. If you want to remove a group, you must 
delete it off each product. 

To change a buy or sell group ID: 

1. From the Maintenance > Price Maintenance menu, select Change Buy/Sell Group ID to 
display the Change Buy/Sell Group ID window. 

2. In the Current Group ID field, enter the group ID you want to change. 

3. In the New Group ID field, enter the new group ID. 

4. Select File > Begin to change the group ID throughout the system. 
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Combination Group Pricing Details 
Combination groups offer quantity break discounts on the combined total of items bought from all sell 
groups included in the combination group. 

For example, when a customer places an order, the system determines if any of the items are in sell 
groups that belong to a combination group. Combination group items are added together and the system 
determines if the total quantity qualifies for quantity break pricing. If the quantity meets a break point, on 
the matrix cell, the system looks at the matrix type to determine which items qualify for quantity breaks. 

The following examples explain how the system determines quantity breaks for: 

• Combination group matrix cells that all have the matrix type C - combination quantity break. 

• Combination group matrix cells that do not all have the matrix type C - combination quantity 
break. 

When combination group matrix cells are all matrix type C 

The table below shows the combination group DELTA, which contains sell groups DELTA1, DELTA2, 
and DELTA3. All of the sell groups are combined with customer price class 1 in sell matrix cells. These 
are all C-type (combination quantity break) matrix cells. The combination group has quantity breaks 
defined at 10 ea (each), 20 ea, and 30 ea, with pricing formulas for the matrix cells defined. 

Customer Price Class 1 
Sell Group DELTA1 - Type 
C 

Customer Price Class 1 
Sell Group DELTA2 - 
Type C 

Customer Price Class 1 
Sell Group DELTA3 - Type C 

Qty Brk Formula Qty Brk Formula Qty Brk Formula 

<10 LIST x 1.0 <10 LIST x 1.0 <10 LIST x 1.0 

10 LIST x .90 10 LIST x .85 10 LIST x .75 

20 LIST x .80 20 LIST x .75 20 LIST x .65 

30 LIST x .70 30 LIST x .65 30 LIST x .55 

A class 1 customer places an order for: 

• Four items from DELTA1. 

• Five items from DELTA2. 

• Two items from DELTA3. 

Though the customer does not reach the first quantity break (10), the  total number of items (11) exceeds 
the quantity break for the combination group. 

The system calculates the formula in the class/group matrix cells at the quantity break level (10), shown 
shaded in the table above, and determines the price for the items in each group, itemized as follows: 

• Sell group DELTA1 - Price = 4 at LIST x .90 

• Sell group DELTA2 - Price = 5 at LIST x .85 

• Sell Group DELTA3 - Price = 2 at LIST x .75 
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When combination group matrix cells are not all matrix type C 

The table below shows the combination group DELTA, which contains sell groups DELTA1, DELTA2, 
and DELTA3. All of the sell groups are combined with customer price class 1 in sell matrix cells: 

• Class 1/sell group DELTA1 and class 1/sell group DELTA2 are C-type (combination quantity 
break) matrix cells. 

• Class 1/sell group DELTA3 is an N-type (no quantity break) matrix cell. 

The combination group has quantity breaks defined at 10 ea (each), 20 ea, and 30 ea, with pricing 
formulas for the matrix cells defined. 

Customer Price Class 1 
Group DELTA1 - Type 
C 

Customer Price Class 1 
Group DELTA2 - Type 
C 

Customer Price Class 1 
Group DELTA3 - Type N 

Qty Brk Formula Qty Brk Formula Qty Brk Formula 

<10 LIST x 1.0 <10 LIST x 1.0 <10 LIST x 1.0 

10 LIST x .90 10 LIST x .85 10   

20 LIST x .80 20 LIST x .75 20   

30 LIST x .70 30 LIST x .65 30   

A class 1 customer places an order for the following: 

• Four items from DELTA1. 

• Five items from DELTA2. 

• Two items from DELTA3. 

The total number of  items ordered (11) in this combination group exceeds the first quantity break, but 
eligibility of items receiving quantity break pricing works as follows: 

• For the 9 items in sell groups DELTA1 and DELTA2 the matrix cell is a type C, so these products 
receive quantity break pricing. 

• For the 2 items ordered in sell group DELTA3 the matrix cell is type N, so these items do not 
receive quantity break pricing. 

The system then calculates the formula in the class/group matrix cells at the quantity break level (10), 
shown shaded in the table above, and determines the price for the items in each group, itemized as 
follows: 

• Group DELTA1 - Price = 4 at LIST x .90 

• Group DELTA2 - Price = 5 at LIST x .85 

• Group DELTA3 - Price = 2 at LIST x 1.0 
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Combining Sell Groups for Quantity Break Pricing 
Sell groups in a combination group must reference the same price line in Buy/Sell Group Maintenance. 
This ensures that the price basis assigned to a price line is the same for all of the combination group's sell 
groups. 

For example, when you create a C-type (combination quantity break) matrix cell for each sell group in the 
combination group, the system references the price basis and pricing formulas assigned to the matrix cell 
and calculates the price for items in the group. 

Create combination groups and assign sell groups to the combination groups in one of the following 
ways: 

• While creating buy groups and sell groups in Buy/Sell Group Maintenance, access Combination 
Group Maintenance by entering a name for a new combination group. 

• Create all of your buy and sell groups in Buy/Sell Group Maintenance, then go to Combination 
Group Maintenance and create the combination groups. Return to Buy/Sell Group Maintenance to 
assign the sell groups to the combination group. 

To combine sell groups for quantity break pricing: 

1. Create your buy and sell groups. 

2. From the Maintenance > Price Maintenance menu, select Buy/Sell Group. On the Buy/Sell 
Group Maintenance window, enter the necessary information to create the buy or sell group. Then 
enter a combination group ID in the Combo Group field. 

3. In the Combination Group field, enter the name of the combination group, or click the New 
Group button to display the New Combination Group dialog box, where you complete the 
following fields: 

• Price Line - Select the price line ID that contains the sell groups for the combination group. 

• New Combination Group -Enter the name of the new combination group. 

Click the Create button to display the Combination Group Maintenance window. 

4. In the Description field, enter a description for the contents of the combination group, up to 23 
characters. 

5. In the Unit of Measure field, enter a common unit of measure for defining quantity breaks for the 
items sold as part of the combination group. 

Sell groups in a combination group can have different units of measure for pricing, but they must 
have a common combination group unit of measure. Use one of the units of measure defined for 
the price line, # (weight), or $ (dollars). 

Note: The combination group unit of measure overrides the sell groups unit of measure. 

6. Check the Split Qty Pricing check box to activate split quantity pricing for the combination 
group. 

7. In the Quantity column for Quantity Break 1 through Quantity Break 5, set up your definitions 
for quantity breaks. When you enter a number, the system appends the combination group unit of 
measure to the number. 
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When you create a C-type matrix cell for each sell group in the combination group, the system 
displays the quantity breaks and unit of measure defined on the Sell Matrix Maintenance window. 

More Options for Combining Sell Groups for Quantity Pricing 

Menu item Description 
File > Recall Preserves the entries in the Line and Combo fields and changes the 

remaining fields back to their original settings. 

File > Delete Deletes the combination group. You are prompted for confirmation. 
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Quote Pricing Overview 
Use Quote Maintenance to define a quote for price groups or products. The quote is selectable during 
order entry on the Pricing Override screen, and overrides other pricing rules. 

Quotes are: 

• Assigned to any customer. Notify customers of a special price quote and instruct them to relay the 
quote name or number to the order taker. 

• Assigned an effective date and an expiration date. Once the expiration date is reached, the quote is 
not offered during order entry. 

• Assigned an original quantity and a remaining quantity for each product assigned to the quote. The 
amount can be in units, pounds, load factor, or dollars worth of product. When the remaining 
quantity reaches zero, the quote pricing expires. If a customer orders more than the remaining 
quantity of a product on a quote, normal pricing goes into effect for the number of items over the 
remaining quantity. 

The Quote Process 

1. Create a quote. 

2. Assign price groups and products to the quote. 

3. Activate the quote pricing for the customer during order entry. 

The system checks the quote for pricing for every item entered on the order. The quoted price for 
a price group or product overrides all other matrix cells in the pricing matrix hierarchy as long as 
the best price check is not active. 

4. Verify that quote pricing was used on the order. 

See Also: 

Creating Quote Pricing 

Assigning Price Groups and Products to Quotes 

Setting Expiration Quantities for Matrix Cells 

Applying Pricing Quotes in Sales Order Entry 
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Quote Pricing Workflow 
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Creating Quote Pricing 
Use Quote Maintenance to offer limited time, special pricing to customers. 

When you create a quote, inform customers of the special pricing. The customer relays the quote name or 
number to the order writer, who selects the quote during order entry. 

The quoted price for a price group or product overrides all other matrix cells in the pricing matrix 
hierarchy as long as the best price check option is inactive. Normal pricing goes into effect if a quote 
matrix cell for the product is not found. 

To create a quote: 

1. From the Maintenance > Price Maintenance menu, select Quote Maintenance to display the 
Quote Maintenance window. 

2. In the Quote Number field, click the New Quote button and enter the name of the quote at the 
prompt. 

Note: To display an existing quote, enter the quote ID. 

3. In the Expire Date field, enter the date the quote expires. You cannot select this quote from order 
entry after the expiration date. This expire date for a quote can be different from the expiration 
date in the matrix cells for the products or groups. 

Note: A quote might expire earlier than this date if you have activated expire quantity on 
the matrix cell, and the quantity reaches zero. 

4. In the Description field, enter a description of the quote, such as "Sanyo Air Conditioner Special," 
or customers who benefit from the quote, such as "Plumber Special." 

You can use as many as 99 lines of 30 characters each to describe the quote. This description 
displays with the quote ID in the selection list in the Quote Number field. 

5. Do one of the following: 

• To make the quote pricing available to all customers save and exit the dialog box. 

• To restrict the quote pricing to the customers or vendors listed, enter the name of each entity to 
benefit from the quote in the Customer/Vendor column, and then save your changes and exit 
the window. 

6. To delete a quote select File > Delete. The system prompts for confirmation. 
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Assigning Price Groups and Products to Quotes 
Use Sell Matrix Maintenance to assign price groups or products to a quote. By setting up a quote matrix 
cell for products or groups, with best price check inactive, the system selects the quote pricing without 
checking further in the pricing matrix hierarchy. This setup ensures that the price offered in the quote is 
used on the order. 

To assign quotes to multiple matrix cells see Creating Matrix Cells in Quick Sell Matrix Maintenance. 

To assign price groups or products to a quote: 

1. From the Maintenance > Price Maintenance menu, select Sell Matrix to display the Initial 
Matrix Information dialog box. 

2. In the Type/Quote field, enter the quote ID. 

3. Enter a value in one of the following fields: 

• Group - Enter a sell group ID for matrix cells that are not product specific. Enter All to include 
all sell groups in the matrix cell. 

Note: If you select a Type/Quote, you cannot use ALL in the Group field. 

Note: If you use All, you can use only global basis names in the Basis field because All is not 
a sell group in a price line to which local basis names have been assigned. 

• Prod - Enter a product ID to create a product-specific sell matrix cell. 

4. In the Branch/Territory field, enter one of the following: 

• A branch ID - Includes that branch in the matrix cell. 

• DFLT (default) - Includes all branches in the matrix cell. 

5. Select NEW at the prompt. 

6. In the Effective field, enter the date the matrix cell becomes effective. 

Note: To display an existing matrix cell, enter the effective date for that cell. 

7. In the Expires field, enter the date the matrix cell will expire. 

• If the matrix cell is in effect for a quantity, the cell will expire if the quantity of the item 
reaches zero before the expire date arrives. 

• If a matrix cell expires and there is not a new one to take its place, the system searches the 
pricing hierarchy until it finds the cell to use when pricing a product. 

8. In the Expire Quantities area, enter the following: 

• Original field - Enter the product quantity available at the quote price. 

The system populates the Exp Qty: Remaining field with the same quantity. As this item is 
purchased at the quoted price, the amount displayed in the Remaining field reduces. The quote 
pricing for the product expires either when the remaining amount reaches zero, or on the quote 
matrix expire date. 

• Type - Enter the quantity type. Quantity can be a dollar amount, the product's unit of measure, 
weight, or load factor. 
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9. In the Matrix Type field, enter a matrix type: 

• C - Combo Qty Break 

• D - Different Matrix 

• G - Group Qty Break 

• M - Matrix Qty Break 

• N - No Qty Break 

• O - Override Cost Only 

• P - Product Level Quantity Break 

10. In the Best Price Chk field, enter N. When the system checks a price, it looks only at normal 
pricing, where quote pricing is at the top of the pricing matrix hierarchy. 

11. In the Basis field, enter the basis name for this quote. 

12. In the Formula field, enter the quote pricing formula. 

13. Use the Comment hot key to add a comment to the quote for easy identification. 

14. Save your changes and exit the window. 
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Price Tags Overview 
Use price tags to provide product and pricing information for regular and sale-priced items in your 
showroom. Use the Price Tag Print Queue to print one or a range of price tags for products with a location 
type of Display in Product Location Maintenance. 

Note: An L in the T column in Product Location Maintenance indicates a display 
location for a product. 

As you print tags for products in the queue, the system moves the products to the Price Tag Reprint 
Queue where they remain until you manually delete them. Access the Price Tag Reprint Queue through 
the Price Tag Print Queue by changing the queue type to Reprint. The selection and printing functions in 
both queues work the same. 

Regular Price Tags 
Regular price tags have two print areas, one that a customer sees in the showroom, and a tear-off portion 
that provides information to locate the product on display in the showroom. You remove the bottom 
portion of the price tag after locating the product and placing the price tag on an item in the showroom. 

The top portion of the price tag includes the following information: 

• Eclipse product ID and bar code. 

• Product description.. 

• The date the tag was printed. 

• The current sell price. 

• User-defined product details. 

The system determines the regular price by searching all sell matrix cells that do not have promotional 
codes set. 

Special Price Tags 
Special price tags are for products that are on sale or promotional priced products and contain the same 
information on the regular price tag plus the regular price of the item and an additional user-defined field 
at the bottom. Changes in promotional codes and pricing drive the printing of special price tags for 
products. 

Price Tag Print Queue 
The Price Tag Print Queue displays all items in your showroom, that is, those items with a product 
location type of Display, that require new price tags. Check for price updates using the Phantom 
Scheduler or by running the update manually. The system adds products to this queue if any of the 
following information changes: 

• Product description 

• Selling price 

• Promotional code 



Assigning and Updating Prices 

109 

If you run price tag prints frequently, you can add a widget on your Solar Main window and run them, 
when needed. You can set all the details available in Price Tag Print Queue and run the price tags with a 
single action. For more about adding widgets, see Adding Widgets to the Widget Toolbar in the 
Navigation documentation. 

 
For more information, see Printing Price Tags. 

Price Tag Reprint Queue 
After you print tags from the Price Tag Print Queue, the system removes the item from that queue and 
places it in the Price Tag Reprint Queue. Use this queue to reprint any necessary tags that you may have 
misplaced or damaged. Items remain in this queue until you manually delete them. 
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Setup Requirements for Price Tags 
Before printing price tags using the Price Tag Print Queue, some setup tasks are required for them to 
work. Review and complete the following: 

• Create a customer in Customer Maintenance to use for all price tags, such as Price Tag Customer. 
You use this customer to create pricing matrix cells the system uses to determine price changes that 
require new price tags. 

• Create matrix cells for your price tag customer and the products or product groups that require 
price tags. 

• Check for price tag updates. 

• Check that you have defined promotional codes for price tags, if needed.. 
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Creating Sell Matrix Cells for Printing Price Tags 
Use the print price tag feature to generate price tags on demand for sale items and regularly priced items 
that you have in your showroom. 

Before creating matrix cells, complete the setup instructions in the system to handle price tags. Then, 
create a matrix cell for your price tag customer and the products or product groups that require price tags. 
Customers in the same price class as the Price Tag Customer receive the same pricing as displayed on the 
tag. Any other customer receives their normal pricing based on how they are set up in the matrix. 

Schedule a price tag update phantom to run regularly to check for price changes. This phantom evaluates 
the matrix file for each product and determines if a price has changed for items with a display location, 
defined in Product Maintenance. If the price has changed, or if items go on sale, these items are sent to 
the Price Tag Print Queue where you can print the required tags. 

To create a matrix cell for printing price tags: 

1. From the Maintenance > Price Maintenance menu, select Sell Matrix to display the Sell Matrix 
Maintenance window. 

2. Complete the sell matrix information on the Initial Matrix Maintenance window. 

3. In the Effective Date field, enter the date from which you want to begin using the price tag 
matrix cell. 

4. Click the Additional tab. 

5. In the Promotional Code field, select the promotional code you want to use for price tags. 

Note: Use the Valid Promotional Codes control maintenance record to setup a code for 
price tags. 

6. Save your changes and exit the window. 
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Defining Promotional Codes for Price Tags 
Use promotional codes to identify products in your showroom that are on sale. Any product associated 
with a promotional code requires a special price tag. If the promotional code for a sell matrix cell 
changes, the system places all products using that sell matrix cell in the Price Tag Print Queue the next 
time the Phantom Scheduler checks for price tag updates or you manually run the routine. Promotional 
codes result in special price tags that contain the sale price along with the regular price. Define the valid 
promotional codes before setting them in a sell matrix cell. 

To define a promotional code for a price tag: 

1. From the Maintenance > Price Maintenance > Price Tags menu, select Valid Promotional 
codes to display the Valid Promotional Codes window. 

2. In the Code field, enter the code as it should display in the selection lists in the Sell Matrix or 
Print Price Tag Queue. You can use up to nine (9) characters. 

3. In the Description field, enter a more complete description for the code. 

4. In the Label Text field, enter the text you want to include on the special tag for the items that use 
the promotional code. 

For example, you enter Fall in the Code field to indicate a discount you offer in the autumn 
months of the year. In the Description field, expand on that code by entering additional 
information about the promotion, such as Fall Discount of 10 Percent. In the Label Text field, 
enter the text that you want to your customers to see for the special, sale-priced items, such as 
Fall Blowout or Fall Clearance. 

5. Repeat steps 2-4 to define additional promotional codes. 

6. Save your changes and exit the window. 

To set promotional codes in a sell matrix sell: 

1. From the Maintenance > Price Maintenance menu, select Sell Matrix to display the Sell Matrix 
Maintenance window. 

2. Display a sell matrix cell. 

3. Click the Additional tab. 

4. In the Promotional Code field, enter or select the promotional code for the pricing matrix. The 
system associates each product that uses the matrix cell with the promotional code you assign. 

5. Save your changes and exit the window. 
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Adding Product Details on Price Tags 
You can add product classification information, if needed, on price tags. For example, if a product 
contains wattage information, create a dictionary in the PROD.CLASS file for MAX_WATTAGE and 
then set the Product Classification in the Product Maintenance window to MAX_WATTAGE indicating 
maximum wattage as listed in Product Maintenance. Then enter Watts the Classification Description to 
list what to display on the price tag. If you use the MAX_WATTAGE dictionary for wattage information 
changes, the system places the product in the Price Tag Print Queue the next time the check for price tag 
updates routine runs. 

Note: Dictionary files are setup in Dictionary Maintenance and these product 
classifications are normally defined during installation and setup. 

To add product details, you must create a price tag customer, create a matrix cell for your price tags, and 
define promotional codes. 

Adding Product Classifications to Product Files 
Before adding product details to your price tags, you must identify for each product you expect to have a 
price tag for. You can use Mass Load to upload classify data all at once. 

To add product classifications to Product Files: 

1. From the Maintenance menu, select Product to display the Product Maintenance window and 
display a product record. 

2. From the File menu, select Classify to display the User-Defined Data for the product. 

The system displays the current File Name and Desc ID fields for the product. 

3. In the Input column, add the details for the price tag for each corresponding Input column entry. 

Setting Classification Types in Price Maintenance 
After adding product classifications, use Price Maintenance to select classification types for price tag 
codes and descriptions. 

To add classification types in Price Maintenance: 

1. From the Maintenance > Price Maintenance > Price Tags menu, select Price Tag 
Maintenance to display the Price Tag Maintenance window. 

2. In the Price Tag Customer field, enter the customer you set up for managing price tag 
parameters. 

The system may auto-populate this field with the customer you have set up in Customer 
Maintenance. 

3. In the Product Classification for Label field, use the drop-down menu to select the product 
classification you want to use, such as MAX_WATTAGE. These selections are setup in the 
Product Maintenance during system setup. 

4. In the Description Title for Label field, enter the text you want to display on the tag with the 
information, such as WATTS or COLOR. This text is used only in this field in the system. 
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6. Save your changes and exit the window. 
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Checking for Price Tag Updates 
Check for price updates using the Phantom Scheduler or by manually running an update. The system 
searches for products, with a location type of Display in Product Location Maintenance, that contain 
changes to the following information since the last time the price tag check ran: product details, product 
description, selling price, and promotional code. 

Note: The system first determines if a product has a Display location type, then 
determines if the product is part of the matrix cell defined for the customer in the 
Price Tag Customer control maintenance record. 

To check for price tag updates: 

1. From the Maintenance > Price Maintenance > Price Tags menu, select Check for Price Tag 
Updates to display the Price Tag Updates window. 

2. In the Price As of Date field, enter the date after which you want to search for changes. 

For example, if you want to check for price changes that occurred or are scheduled to occur after 
October 1, 2010, enter 10/01/10 in the Price As of Date field. The system searches for products 
that have sell matrix cells effective as of the date, and also searches for products that have 
changes as listed above. 

Note: You cannot check for price updates for dates in the past. 

3. From the File menu, select Begin or schedule the phantom to run when convenient. 
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Printing Price Tags 
The Price Tag Print Queue lists all the products that have Display locations defined in Product Location 
Maintenance that have a price or product change. The system determines a product requires a new price 
tag based on any of the following information changing for the product: product details, product 
description, selling price, and promotional code. You can also create a widget for the price tag queue to 
keep track of changes, as needed. 

Check for price tag updates regularly using the Phantom Scheduler or run the check manually prior to 
printing tags. You can also manually add products to the Price Tag Print Queue. You can insert tags 
manually, if you need to print a tag that is not displayed in the queue. By default, price tags print as 4 
inches wide and 3 inches tall. 

Note: Products with display locations that have zero on-hand that have had a price or 
product change also appear in the Price Tag Print Queue. 

As you print tags for products in the queue, the system moves the products to the Price Tag Reprint 
Queue where they remain until you manually delete them. Access the Price Tag Reprint Queue through 
the Price Tag Print Queue by changing the queue type to Reprint. The selection and printing functions in 
both queues work the same. 

This topic discusses the following tasks for printing price tags: 

• Populating the Price Tag Print Queue. 

• Selecting Products and Printing Price Tags. 

• Removing Products From the Price Tag Queues. 

• Purging the Price Tag Print Queue. 

Populating the Price Tag Print Queue 
Populate the Price Tag Print Queue to display the products for which you want to print price tags. 

To display the Price Tag Print Queue: 

1. From the Maintenance > Price Maintenance > Price Tags menu, select Price Tag Print Queue 
to display the Price Tag Print Queue. 

2. Use the Header fields to limit the price tags you want to display in the queue. 

Field Description 
Branch/Terr/All Enter the branch or territory for which you want to display products in the queue. 

Promotional 
Code 

The promotional code assigned to the product in the sell matrix. 

Note: Promotional code information is applicable only to special tag types. If you 
selected Regular in the Tag Type field, the cursor moves directly to the Mode 
field. 

Price Line Limit the queue to a single price line. 

Product ID Limit the queue to tags for a single product ID. 

Buy Line Limit the queue to a single buy line. 
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Field Description 
Display On-
Hand 

The on-hand quantity of the product in the display location. 

Tag Type Select one of the following: 
• Regular - Only products that have regular pricing information defined and that 

require new price tags display in the queue. 
• Special - Only tags with promotional codes that require new price tags display in 

the queue. 
• Both - All regular-priced and promotional prices products that require new price 

tags display in the queue. 

Mode Select one of the following: 
• System – Displays products that the system found during the last price tag update 

check. 
• Manual – Allows you to enter products in the print queue manually and displays 

the products you have added to the queue manually, but have not yet printed 
price tags for. For example, you may find a price tag missing in your showroom 
and need to replace it. Use the manual mode to add it to the queue. For more 
information, see Manually Adding Tags to the Price Tag Print Queue. 

• Both – Displays products that the system found during the last price tag update 
check and those that you manually added to the queue, but have not yet printed 
price tags for. 

Queue Type Indicate if you want to display the queue for regular print tags or reprint tags. 

2. Click Update. 

The system displays the queue with the defined parameters. 

Column Description (View Only) 
Branch The branch where the product is located. 

Description The product description, as defined in the product record. 

Tag Type • Regular - Only products that have regular pricing information defined and that 
require new price tags display in the queue. 

• Special - Only tags with promotional codes that require new price tags display 
in the queue. 

• Both - All regular-priced and promotional prices products that require new price 
tags display in the queue. 

Promotional 
Code 

The promotional code assigned to the product in the sell matrix. 

Effective Date The effective date of the pricing as defined in the sell matrix cell. 

Queue Date The date the item was added to the queue. As you print items, the system moves 
them to the Price Tag Reprint Queue. 

Display On-
Hand 

The on-hand quantity of the product in the display location. 

Stock On-Hand The total on-hand quantity of the product that you have in stock that is available to 
sell. 
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Printing Price Tags 
To print price tags from the Price Tag Print Queue: 

1. Display the Price Tag Print Queue. 

2. Verify the tags are the ones you want to print. 

3. Do one of the following: 

• Use the check boxes to select a specific range of tags to print and from the File menu, select 
Print. 

• Press Ctrl-A to select all the check boxes. 

• Press Shift and select the first and last in a range of tags to print. 

Manually Adding Tags 
After populating the queue, if you need to add a tag to print, you can insert it. You must have the Mode 
set to Manual or Both in the Header of the queue. 

1. Display the Price Tag Print Queue. 

2. Select a record after which you want to insert a tag to print. 

3. From the File menu, select Create Manual Tag. 

1. Enter the Product ID and the Branch number for the product tag you are entering. 

Note: The product you enter must have a valid display location. 

5. Click OK to return to the queue. 

6. Print the tags. 

Purging the Price Tag Queue 
To clean up the price tag queue, you can purge the items that have already printed or ones that no longer 
have promotional codes. 

To purge the price tag queue: 

1. From the File > Price Maintenance > Price Tags menu, select Price Tag Maintenance to 
display Price Tag Maintenance. 

2. From the File menu, select Price Tag Print Queue Purge to display the following selections: 

 
3. Click Begin purge immediately or Schedule to run the phantom and purge the queue at a later 

time. 
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