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Disclaimer 
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Entity Maintenance Overview 
Each customer, vendor, and branch must have its own record for pricing, reporting, and product 
information. 

You can set up a variety of information in your customer and vendor records, including: 

• Cross-references between the customer or vendor's product numbers and the system-generated part 
numbers. 

• A list of contact numbers within the customer or vendor's company, such as those of purchasing 
agents, sales representatives, and accountants. 

• Activity triggers that tell the system to send automatic email confirmations to customers when 
orders are shipped, or fax notifications to vendors when ship dates are missed. 

• A way to determine which customers can order from which of your branches, and which of your 
branches can order from which vendors. 

• The ability to receive or ship consigned inventory. 

Each branch record contains information, such as: 

• The customers and vendors that order from or sell to the branch. 

• An assigned remit-to branch if a branch does not maintain its own finances. 

• The credit card types that can be used. 

• The method used to transport goods to and from the branch. 

• The process used to verify checks. 
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Setup Requirements for Customer and Vendor Maintenance 
Following are the control maintenance records and authorization keys used for Customer and Vendor 
Maintenance. 

Only a system administrator is authorized to set control maintenance records and authorization keys. 

This topic contains the following sections: 

• Customer and vendor control maintenance records. 

• Customer and vendor authorization keys. 

Customer Control Maintenance Records 
The following control maintenance records relate to Customer Maintenance: 

ACCT (Accounting) 
Set the following control maintenance records: 

• A/P Over/Short Maximum Parameters 

• Auto C/R Default Customer If Not Found 

• Cash Over/Short Maximum Parameters 

• Credit Card Default Reference Number 

• Credit Card Level III Summary Line Item 

• Default Auth Method for New Credit Cards 

• Include Service Charges In Service Charge Calculation 

• Maximum Collection Days Date 

• Minimum Check Distribution Amount 

• Restrict Access to Customer Maint Based On User Authorized Branches 

• Valid ACH Formats 

• Valid Cash Sources 

• Valid Customer Statement Cycles 

• Valid Invoice Select Codes 

DLOT (Detail Lot Tracking) 
• Valid Detail Lot Product Quality Ranks 

• Valid Detail Lot QC Inspection Levels 

EMAIL (E-mail) 
• Corporate Customer 

• Default E-mail Print Styles 

• Valid E-mail Preference 
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• Valid E-mail Types 

GENRL (General) 
Set the following control maintenance records: 

• Activity Trigger Subroutine Overrides 

• Customer Classification Sort List 

• Valid Customer Price Classes 

• Vendor Classification Sort List 

INVM (Inventory Management) 
• Assign Demand Forecast To Price/Ship Branch Or By Zip Code 

MAINT CUST (Customer Maintenance) 
• Customer Maintenance Authorization Levels 

• Customer Maintenance Authorization Levels For New Customers BT/ST 

• Default Customer Price Class 

• Default Customer Salesperson 

• Job Lien Days By State 

• New Customer Maintenance Template 

• Prompt To Copy Tax Information From Bill-Tos to All Ship-Tos 

• User Defined Customer Notes 

• Valid Customer Invoice Status Codes 

• Valid Customer Points Programs 

• Valid Customer Select Codes 

• Valid Customer Types 

• Valid Job Types 

• Valid Job Nature Types 

• Valid Sale Categories 

MAINT PROD (Product Maintenance) 
• Valid Product Certification Codes 

• Valid Product Zones 

MAINT (Vendor Maintenance) 
Set the following control maintenance records: 

• Disable Home Branch Check In Vendor Maintenance 

• User Defined Vendor Notes 



Setup Requirements for Customer and Vendor Maintenance 

4 

• Valid Vendor Types 

POE (Purchase Order Entry) 
Set the following control maintenance records: 

• Capitalize Tax On Purchase Orders 

• Default B/O Days For Purchase Orders 

• Include Directs In Vendor Target Check When Printing a P/O 

• Vendor Freight Terms 

• Valid Vendor ASL Types 

SFA (Sales Force Automation) 
• SFA Administrator 

SOE (Sales Order Entry) 
Set the following control maintenance records: 

• Allow Multiple Products To Be Associated With One Customer Part # 

• Allow Sending Credit Card Level 3 Data 

• Apply Extra Handling For Shipping To First Gen Only 

• Display Customers/Vendors Who Are Inactive At A Branch 

• Display Products Within A Customer's Product Zones 

• Duplicate Customer P/O Number Check 

• Duplicate Order Check 

• Enable Auto Routing On Creation Of Sales Order 

• Exclude From Ship-To/Ship-From Selection If Excluded From Index 

• Invoice Print Copies = 0, Q Status Invoices To Invoice Preview Queue 

• Minimum Variance Before Last Price Reduction 

• New SOE Customer Template 

• Number Of Digits Of Accuracy For Product Weight 

• Order Status Print Status Defaults 

• Pass-Along Discount Holdback Percent 

• Percent Of Order To Fill Before Automatically Shipping 

• Prompt For Required Date In Sales Order Entry 

• Use Last Price/Cost Logic 

• Validate Name In 'Ordered By' Field Against Customer Contact 

• Valid Product Matrix Types 
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TOE (Transfer Order Entry) 
Set the following control maintenance record: 

• Default Vendor Consignment on Transfers 

WIP (Work Order Processing) 
Set the following control maintenance record: 

• Valid Vendor Work Order Process Codes 

Customer and Vendor Authorization Keys 
Set the following authorization keys: 

• COGS.VIEW 

• CONVERT.PROSPECT 

• CREDIT.CARD.ACCT 

• CREDIT.CARD.REQD.OVR 

• CUST.CREDIT.EDIT 

• CUST.BR.AUTH.ONETIME 

• CUST.BR.AUTH.OVRD 

• CUST.CERTIFY.EDIT 

• CUST.DEMAND.BR.OVRD 

• CUST.POINTS 

• CUST.PRICING.EDIT 

• CUST.TAX.VIEW 

• CUSTOMER.MAINT 

• CUSTOMER.MAINT.LEVEL 

• ENTITY.PN.EDIT 

• ENTITY.TRIGGER 

• FREIGHT.TARGET.OVERRIDE 

• INVALID.VEN.TYPES 

• POE.ASL.RELEASE 

• PRD.ZONE 

• SLSMN.CUSTOMER.MAINT 

• SOE.CREDIT.RELEASE 

• VALID.VEN.TYPES 

• VEN.BR.AUTH.ONETIME 
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• VEN.BR.AUTH.OVRD 

• VENDOR.MAINT 

• VENDOR.MAINT.LEVEL 
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Setup Requirements for Contact Maintenance 
Following are the control maintenance records and authorization keys used for Contact Maintenance. 

Only a system administrator is authorized to set control maintenance records and authorization keys. 

Control Maintenance Records 
Set the following control maintenance records: 

• Contact Classification Sort List 

• Validate Name In 'Ordered By' Field Against Customer Contact 

• Valid Phone Codes 

• Valid Salutations 

• Valid SFA Contact Classifications 

Authorization Key 
Set the following authorization key: 

• CONTACT.MAINT 
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Setup Requirements for Branch and Territory Maintenance 
Following are the control maintenance records and authorization keys used for Branch and Territory 
Maintenance. 

Only a system administrator is authorized to set control maintenance records and authorization keys. 

Control Maintenance Records 
• Check Verification: Required Information 

• Display Active Primary Index Products First In Product Search 

• Restrict Access to Customer Maint Based On User Authorized Branches 

• RF Pick Selection Sort 

• Valid Cost Center Types 

• Valid Phone Codes 

Authorization Keys 
• BRANCH.MAINT 

• CREDIT.CARD.SETUP 

• RF.LOAD.OVRD 

• TERRITORY.MAINT 
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Setup Requirements for Company Branches 
Creating a branch in the system involves several system program settings. You must set up branches as 
entities to track sales and expenses, and to use the branch in transfer orders. Generally, you create 
branches representing different physical locations, but you can also create a fictitious branch, such as 
Corporate, to maintain and track expenses that are not applied to inventory or pricing branches. 

Complete the following to set up a branch: 

• Set up control maintenance records and authorization keys for Branch and Territory Maintenance. 

• Create a branch record and associate it with a customer record, so the branch activities can be 
tracked and you can use the branch for transfer orders. If this is a non-stocking branch and you will 
never order from this branch, activate No Order Entry in customer credit control parameters. 

Alternatively, you can specify a class for your transfer entities to accomplish the same purpose. For 
example, assign all branches a class of BRCH, and create a Class/All matrix cell. 

• For each branch customer record for which you anticipate creating transfer orders, set up 
Customer/Group/All sell matrix cells so there is no gross profit percent calculated on transfer 
orders. 

• Define territory authorization levels for users in User Maintenance. Determine a user's authority 
based on their assigned branches and how they need to use the system's territories. 

• Set up customer and vendor access to branches with which your customers and vendors will do 
business. 

• Create territories. 

• Organize your branches into territories. 

See Also: 

Branch and Territory Maintenance Overview 

Creating Branch Records 

Creating Territories 

Adding Branches to Territories 
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Branch and Territory Maintenance Overview 
A branch is an entity that is part of your company. Branch designations in the system provide the 
structure used to maintain accuracy and detail throughout the system. 

The system uses branch designations in the following ways: 

• Control maintenance records set up by branch. For example, RF may be enabled at one warehouse 
but not at any other warehouse. 

• Each customer, vendor, and user is assigned a home branch for pricing, accounting, reporting, and 
tracking purposes. 

• Accounting branch designations provide accuracy for A/P, A/R, and reports. General ledger 
postings are identified by branch. For example, in your general ledger, you may want to 
differentiate between A/R collected from your different branches. 

• Pricing is assigned according to branch or location. For example, items purchased from Branch 10, 
located on an island community, may be priced higher than items purchased from Branch 1 on the 
mainland. 

• Tax jurisdictions are assigned according to the geographic location of a branch. 

A territory is a name given to a group of branches. It is much easier to maintain branches within territories 
because you can set branch-specific pricing, product, or entity parameters for multiple branches at a time, 
rather than spending hours changing parameters for each branch. 

Your branches can reside in more than one territory, depending on how you organize your company. For 
example, you can organize branches in territories according to geographic location, what products you 
sell at each branch, or branch functionality, such as pricing or shipping. Territories are prioritized so that 
the system knows what branch-specific setting to use for reports and transactions. Territory priorities 
create the branch hierarchy, which allows you to define branch-specific settings at the territory level 
throughout the system. 
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Territory Priority Basics 
A territory is a name given to a group of branches. Eclipse's branch hierarchy allows you to define 
branch-specific settings at the territory level, rather than entering the same setting, for example sell 
package quantity, branch by branch. The branch hierarchy eliminates the need for complicated mass load 
operations when setting branch parameters. 

Territory priorities create the organization for branches that are in multiple territories. Plan your territory 
and branch structure before creating territories and assigning branches to them. Create categories for your 
branches when the branches have similar settings, or reporting needs. Branch categories can reflect 
regions, states, and products, for example. This process helps you create a branch hierarchy that the 
system can use to efficiently maintain branch-specific options in many areas of the system. 

Throughout the system you can add and view only branches and territories to which you have access. 
Branch and territory access is defined in User Maintenance. To view or edit the Territory Maintenance 
screen, where you define territory priorities, you must be assigned the TERRITORY.MAINT 
authorization key. 

When you change territory priorities, the system requires that you rebuild the territory list. We 
recommend that you schedule the rebuild for after normal business hours to ensure that the process does 
not interfere with daily transactions. 

Defining Territories 
Use the Territory Maintenance screen to create as many territories as you need to maintain the system's 
branch-specific settings. Create territories to organize branches into geographic locations, or types of 
products sold. For example, you might run reports on regions, such as South and East, or you might run a 
report focused on two states, for example Alabama and Georgia. If your branches sell different types of 
products, you might categorize territories as plumbing and HVAC to accurately report sales at those 
branches. 

If your company has only one branch or multiple branches, use the ALL territory to maintain branch 
settings throughout the system. That way, if you ever add a branch, the new branch can inherit all of the 
properties of other branches through the ALL territory. You can also set different parameters for the new 
branch, if necessary, because individual branch settings always override territory settings. 

Note: You do not have to create the ALL territory, it was created as part of the Eclipse 
system. 

If a Control territory displays, you cannot change these settings. Control indicates the default system 
settings. This display helps you compare your territory settings with the settings automatically assigned 
by the system. 

Assigning Territory Priorities 
A branch can belong to more than one territory. The branches in these territories may need different 
settings for reporting purposes, tax purposes, pricing setup, inventory, and products. How does the system 
know what settings to use for branches maintained in multiple territories? You give each territory a 
priority for product and entity settings that the system uses to determine which parameter to use, such as 
package quantity for products and branch-specific overrides for entities. You can always override territory 
settings at the branch level. 
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Set territory priorities, from 1-99, according to the specificity of each territory, giving more specific 
territories a higher priority than less specific territories. You cannot maintain data on a territory that does 
not have a priority number; such territories can be used only for reporting purposes. 

In this example, a higher priority is assigned to a territory focusing on automation products than to a 
territory containing all of the Southeastern branches, as shown in the following table. You will determine 
the correct priority for doing business at our own company. 

Territory Product Priority 
AUTO 90 
ELECGRP 80 
GEORGIA 75 
SOEAST 50 

For example, you have ten branches in the Southeast, five in Georgia, and five in Alabama, and sell 
electrical products at all of your branches, and automation products at 6 of those ten branches. Your state 
branches have equal priority, and are more specific than the regional, SOEAST territory, and less specific 
than the ELECGRP territory. Product and entity priority settings do not need to be the same for a 
territory, but should remain equal between like territories. The following table shows the priority 
distribution for state, regional, and product-specific territories: 

Territory 
Name 

Number of 
Branches 

Product 
Priority 

Entity 
Priority 

AUTO 6 90 95 
ELECGRP 10 80 85 
ALABAMA 5 75 70 
GEORGIA 5 75 70 
SOEAST 10 50 40 

You purchase a Midwestern company that has five branches, two in MICHIGAN, and three in OHIO. All 
five branches sell electrical products, but none sell automation products. Now you have two regional 
territories and four state territories. Give both regions equal priority, and give all of the states equal 
priority. The number of branches in the ELECGRP territory jumped to 15 because all of your branches 
fall into that category. The following table shows how the addition of branches and territories can change 
the branch hierarchy: 

Territory 
Name 

Number of 
Branches 

Product 
Priority 

Entity 
Priority 

AUTO 6 90 95 
ELECGRP 15 80 85 
ALABAMA 5 75 70 
GEORGIA 5 75 70 
OHIO 3 75 70 
MICHIGAN 2 75 70 
MIDWEST 5 50 40 
SOEAST 10 50 40 
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To determine which territories have priority within the branch hierarchy, set territory priorities in 
Territory Maintenance. 

If you change the priority settings, you must rebuild the authorized territory list, exit the Eclipse program 
you are in and then re-enter a branch-specific screen to see the change in priority. We recommend 
scheduling these rebuilds for after work hours to avoid interfering with normal business transactions. 
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Branch Hierarchy Details 
Eclipse's branch hierarchy lets you define branch-specific settings at the territory level, rather than having 
to define multiple settings for each branch. Branches are categorized in territories and each territory is 
given a priority. The level of priority establishes the order of the territory list within the branch hierarchy. 
The system uses the branch hierarchy to apply the correct branch setting to a given system parameter, 
such as sell package quantity for a product, or the minimum order cycle for a buy line. Maintaining 
settings at the territory level, rather than at the branch level, eliminates the need for complicated mass 
load operations when making company wide changes to branch settings. 

Each Eclipse screen where you can set branch-specific parameters, such as Product Price Maintenance or 
Buy Line Maintenance, lets you do one of the following: 

• View overrides for the branches and territories for which you have access. 

• Add an override to a branch or territory setting. 

• View settings for a specific branch, and where those settings came from. 

Viewing Territory Override Settings 
When you enter a screen that displays branch-specific parameters, such as Product Price Maintenance, the 
branches and territories that currently have settings display in the Branch/Territory column. The column 
lists branch overrides first, followed by territory settings that are currently in effect. 

Note: You can identify a screen with branch-specific parameters by its File > Hierarchy 
option. 

To add an override to another branch or territory, press Alt + Insert and enter the branch or territory 
name at the prompt. Scroll to the column that needs an override, and enter the value. You can add 
branches and territories only if you have access to them, and only if they have a priority assigned to them 
in Territory Maintenance. 

Viewing a Branch with its Associated Territories 
To view the territory list for a selected branch, in a screen that has branch-specific parameters, select the 
File > Hierarchy option and enter the branch. The system populates the Branch/Territory column with 
the selected branch at the top as the highest priority, and lists all of the territories containing that branch 
that you have authorization to view in the order of their priorities. The highest priority territory is directly 
under the branch, and the lowest priority territory is at the bottom of the list. If you have added the ALL 
territory to your authorized territories in User Maintenance, the ALL territory displays at the bottom of 
the list. Territories that contain the selected branch, but do not have a priority setting do not display in this 
list, and you can use them only for reporting purposes. 

In screens with branch-specific settings, you can set the parameters by territory, rather than having to set 
individual branch priorities. You can still set overrides at the branch level because the branch is always 
the highest priority level. 
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Creating Branch Records 
Create a record in Branch Maintenance for each branch at your company, and assign parameters that 
associate the branch with system events and procedures. Associate branches with a customer record, so 
you can track branch activities and you can use the branch for transfer orders. Also, assign a home branch 
to users, customers, and vendors for pricing, accounting, reporting, and tracking purpose. For more 
information about setting up a branch for company use, see Setup Requirements for Company Branches. 

Branch Maintenance is not the only place in the system where you enter branch-related parameters. The 
system has at least 15 screens where you set branch-related parameters, such as Product Price 
Maintenance, Buy Line Maintenance, and Procurement Group Maintenance. You can identify screens 
throughout the system that have branch-specific parameters by the File > Hierarchy option that when 
selected, prompts you to enter a branch. 

To create a branch record: 

1. From the Maintenance > Branch menu, select Branch to display the Branch Maintenance 
window. 

2. Complete the following fields, as needed: 

Field Description 
Branch Enter the name or number used to identify the branch or click the New Branch button 

to create a new branch ID. 
We recommend checking the naming convention your company uses. There are no 
numbering restrictions. For example, creating a branch 5000 does not have a negative 
impact on the system. 

Short 
Description 

Enter the name of the branch, using up to 12 alphanumeric characters. 
This description displays on selection lists when a user is prompted to select a branch, 
such as on reports. 

Long 
Description 

Enter a detailed description of the branch, up to 33 alphanumeric characters. 
This description displays on certain reports that display that branch. 

Branch Entity Enter one of the following to map the branch name to the branch's customer record: 
• All or part of the branch name, as it displays in customer maintenance. 
• The last four digits of the branch phone number. 
• The branch record name preceded by a period (.). 
The Entity ID field displays the branch's customer ID. 

Note: If you have not created a customer record for this branch, select Maintenance > 
Edit Entity to create a record in Customer Maintenance. See the table, below. 

Remit To Enter one of the following to indicate the branch that receives payments for this 
branch's transactions: 
• Part of the branch's name. 
• The last four digits of the branch phone number. 
• The record name preceded by a period. 
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Field Description 
P/O Bill-To Enter an alternate bill-to entity to display on purchase orders. 

The P/O Bill-To ID field displays the bill-to entity ID entered in the P/O Bill-To field. 

Note: The P/O Bill-To and P/O Bill-To ID fields display only if the Allow Alternate 
Branch Bill-To Address control maintenance record is set to Yes. 

Default Price 
Class 

Enter the branch's default price class. 
If you assign a default price class in Customer Maintenance, the customer's setting 
overrides this setting. 

Branch 
Manager 

Enter the name of the manager of this branch. To display a list of users that match your 
entry enter part of the manager's name and press Enter. 

Cost Center Enter this branch's primary function, such as Distribution, or Showroom. Cost center 
types are defined in the Valid Cost Center Types control maintenance record. 

3. Select the Stocking Branch check box if this branch handles product. 

In addition to performing money related tasks, users at a stocking branch can perform tasks such 
as, entering orders, adjustments, pricing, and edit product parameters. 

To limit the products displayed to those with on-hand quantities or on transactions at the 
stocking/shipping branch, activate the  Display Active Primary Index Products First In 
Product Search control maintenance record. This record can limit the products displayed to 
those with on-hand quantities or on transactions at the stocking/shipping branch. 

Note: If you change the stocking branch status, you must run the Delete Branch Cache 
Files utility. Run the utility after hours to avoid slowing the system during 
business hours. 

More Options for Creating Branch Records 

The following are some common options you might use while creating branch records: 

To... Select... 
do one of the following: 
• Edit a customer record that is 

also a branch. 
• Edit an existing branch's 

customer record. 
• Create a branch that will also be 

a customer. 

Maintenance > Edit Entity and select one of the following: 
• Branch Entity - Displays the customer record associated with the branch. 
• Remit-To - Displays the branch's remit-to branch, if one exists, otherwise 

the current branch's customer record displays. 

set up credit card processors to be 
used by the branch. 

Maintenance > Credit Card Branch Set Up 

display the Inventory Inquiry 
Branches dialog box. 

Maintenance > Inventory Inquiry Branches 
enter all of the branches to associate with this branch. When the displayed 
branch is your home branch, you can view information for these branches in 
Inventory Inquiry. For example, your home branch is Denver, but you need to 
view all Colorado branches in Inventory Inquiry. When the Denver branch is 
displayed on the Branch Maintenance screen, use this option to list all of the 
Colorado branches. Then when you display inventory in Inventory Inquiry, the 
system looks to your home branch, and displays only information for that 
branch and its associated branches. 
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To... Select... 
assign the branch's default method 
of transporting product. 

Maintenance > Ship Via Branch Overrides 

set up a check processor for the 
branch. 

Maintenance > Check Verification 

set up a pricing hierarchy for your 
branches. 

Maintenance > Matrix Hierarchy 
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Assigning Ship Vias to Branches 
Ship vias are the methods used to move product from the warehouse to the customer. Before you can 
assign a ship via to any order, you must create a file containing the ship vias that your company uses. 
Your system is installed with a set of ship vias defined. 

Use the Ship Via Maintenance program to define the additional ship vias required for each branch of your 
company. Once defined, ship vias have many interrelated uses in Eclipse. By assigning a ship via to a 
branch you can do the following: 

• Determine if a ship via requires a routing ticket for deliveries. 

• Search for a ship via. 

• Assign all ship vias to a branch at once. 

• Set up auto scheduling overrides. 

• Change the branch tax jurisdiction method. 

• Set up a pick ticket printer location. 

To assign a ship via to a branch: 

1. From the Maintenance > Branch menu, select Branch to display the Branch Maintenance 
window. 

2. In the Branch field, enter the branch name to display the branch record. 

3. Select Maintenance > Ship Via Branch Overrides to display the Ship Via Branch Overrides 
dialog box. 

4. In the Ship Via column, enter the ship vias to assign to this branch. 

5. In the Tax Jurisdiction Method column, enter the tax jurisdiction method for the system to use 
when determining the tax jurisdiction associated with this ship via. 

6. In the Pick Ticket Print Location column, select the printer location for each branch where the 
Automatic Shipping Ticket Printing program or the Batch Transfer program prints pick tickets. 
This setting overrides the setting in the Default Printer Location For Branch control 
maintenance record. 

7. In the Auto Scheduling column, select one of the following to set the automatic scheduling of 
tickets that are manually added to the manifest: 

• On - Enables the auto scheduler, so when you add a ticket to the manifest, the system 
calculates the delivery time and stop number for the ticket. 

• Off - Disables auto scheduler, so all delivery scheduling must be done manually. When you 
add a ticket to the manifest, the system adds the ticket where the cursor is positioned on the 
manifest and creates a new stop if the ship-to address does not match that of the prior order on 
the manifest. 

This setting overrides the Auto Schedule setting on the Shipping Manifest Queue (Warehouse 
Management > Warehouse Queues). 

• Default - The auto scheduler uses the setting on the Shipping Manifest Queue (Warehouse 
Management > Warehouse Queues). 
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8. In the Routing Ticket column, if the ship ticket requires a routing ticket for deliveries, check the 
box. 

9. In the Pick Priority column, enter a number from 0 to 99 to assign a priority to each ship via. 
Zero is the highest priority, and 99 is the lowest priority. If you leave any ship via unselected, this 
ship via is considered the highest priority. 

If two or more ship vias have the same pick priority, blank or otherwise, the system determines 
the ship via priority by the setting on the RF Pick Selection Sort control maintenance record. 

The Ship Via Pick Priority Maintenance dialog box in Warehouse Maintenance and this field 
work together. If you enter a value for a ship via on one dialog box, it overrides the value for the 
same ship via on the other dialog box. 

10. The Override Freight and Ship Via Override columns work together: 

• If this branch's ship via can have a freight override, then the Override Freight column is 
checked. 

• If this branch's ship via can have a freight override, the Override Value field displays Yes. 

Enter the override status of the ship via for this customer at this branch if you set the Override 
Customer Freight Out Exempt field on the Ship Via Maintenance window (Maintenance > 
Ship Via) to B, and you activate the Override Freight field here. See Overriding Customer 
Freight Exempt for a Branch for more information. 

11. Select Additional > Branch Ship Via Additional Data to display the Branch Ship Via 
Additional Data window. Use this window to do the following: 

• Assign RF criteria to specific ship vias and assign statuses to ship vias at a branch. 

To... Do the following... 
specify a staging location Enter the default location where the ship via is staged in the 

Staging Location field. 
combine all full orders across 
multiple zones into one pick. 

check the Combine All Zones in RF Pick Select check box. 

hold all manifests from the 
picking queue until they are 
manually released. 

Select the Hold RF Picking Until Released check box. 
If left unselected, the system sends all picks to the picking 
queue as soon as they are released from sales or transfer order 
entry. 

enable fleet routing for this ship 
via and branch. 

Select the Use in Fleet Routing check box. 

assign statuses to ship vias at a 
branch. 

In the Order Inprocess Status Selection area, enter the ship 
via status for the ship via. 
Ship via statuses defined here override the ship via set up in 
Ship Via Maintenance. List the statuses in order of progression, 
for example, PRINTED, PICKING, STAGING, and 
MANIFEST. Each branch can have its own ship via priority. 
For example, branches 1 through 6 use statuses PRINTED, 
PICKING, STAGING, and MANIFEST, but branch 5 requires 
a PACKING step between STAGING and MANIFEST. For 
branch 5, enter PACKING in the appropriate order. 
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To... Do the following... 
prevent users from closing 
orders after they are staged in 
RF. 

Select the Prevent Close During Staging check box. 
If a user is assigned the RF.LOAD.OVRD authorization key, 
they can override this setting and close orders after staging. 

print a document when you 
close an RF order from the 
Warehouse In Process Queues: 

Select one of the following types of documents in the 
Document to Print on RF Order Close field: 
• N - None 
• T - Pick Ticket 
• O - Ship Ticket 
• F - Routing Ticket 

use carton packing at your 
branch 

Select Use Order Packing/Verification check box. Then use 
the remaining fields to indicate how to handle cartons: 
• Carton Staging Location - Enter the location you want to 

use for staging cartons at this branch. 
• Carton Loading Print Option - Select when to print the 

ship ticket for the carton. You can choose not to print a ship 
ticket, print it when the carton is loaded, or for a manifest. 

• Validate Carton Loading Manifest Sequence - Select if 
you want the system to validate carton loading for cartons at 
this branch. 

override customer freight 
exempt for a branch 

See Overriding Customer Freight Exempt for a Branch. 

set a default status after 
packing in the review queue 

Enter the status you want to use in the Review Queue Status 
After Pack Complete field. 

• Setup delivery schedules for sales order entry. 

12. Save your changes and exit the dialog box. 



Creating and Maintaining Branches and Territories 

21 

Verifying Check Processors for Branches 
Set up an electronic check verification system for a branch to automatically verify the authenticity of a 
check when it is accepted at that branch. Information required for authorization is drawn from the Check 
Verification:Required Information control maintenance record. 

Before you begin auto-verifying checks, define the default check processor information on the Check 
Verification Processor Setup window. 

To verify a check processor for a branch: 

1. From the Maintenance > Branch menu, select Branch to display the Branch Maintenance 
window. 

2. In the Branch field, enter the branch name to display the branch record. 

3. Select Maintenance > Check Verification to display the Check Verification Branch Setup 
dialog box. 

The current branch ID displays in the lower-left of the dialog box. 

4. In the Processor field, select a processor for this branch. 

5. In the Subscriber ID field, do one of the following: 

• If a default subscriber ID is defined on the Check Verification Processor Setup dialog box for 
the processor, this field displays that ID. 

• If no default subscriber is defined, enter the subscriber ID. 

• If a default entry is displayed, but the branch has a unique subscriber ID, change the default ID 
to the branch's ID. 

6. Ignore the Host ID and Service ID fields. Their functions are not active at this time. 

7. To copy the branch setup information, select one of the following: 

• Copy > Copy From Branch to copy the information from another branch to the displayed 
branch. 

• Copy > Copy to Branch(es) to copy information from the displayed branch to one or more 
other branches. When entering multiple branches, separate the branches with a comma. 

8. Save your changes and exit the dialog box. 
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Overriding Customer Freight Exemptions for Branches 
You may want to restrict certain types of shipping from customers who place orders through one of your 
branches. For example, if Branch 3 is in a remote location, and UPS Gold is an expensive shipping 
method from that branch, you can restrict customers from the freight exempt status at Branch 3 for UPS 
Gold. 

This procedure overrides the setting in the Freight Out Exempt field on the Customer Maintenance 
window. 

Perform the following procedures in the following order: 

• Setting up the customer freight out exemption. 

• Overriding the customer freight out exemption. 

To set the customer freight out exemption: 

1. From the Maintenance menu, select Ship Via to display the Ship Via Maintenance window. 

2. In the ShipVia field, enter the ship via to which to apply a branch override. 

3. On the Primary/Freight tab, in the Override Customer Freight Out Exempt field, enter B for 
branch. For more information, see Assigning Automatic Freight and Handling Charges to a Ship 
Via. 

Override Freight column on the Ship Via Branch Overrides dialog box, described below, now 
accepts the override. 

To override the customer freight out exemption for a branch: 

1. From the Maintenance > Branch menu, select Branch to display the Branch Maintenance 
window. 

2. In the Branch field, enter a branch ID to display the branch record. 

3. Select Maintenance > Ship Via Branch Overrides to display the Ship Via Branch Overrides 
dialog box. 

4. Any ship via to which you applied the "B" setting in the Override Customer Freight Out 
Exempt field in Ship Via Maintenance displays a check mark in the Override Freight column. 

5. If you want this setting to override the entry in the Override Customer Freight Out Exempt 
With field in the Freight Data, set the Ship Via Override? column to Yes. 

6. Save your changes and exit the dialog box. 
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Assigning a Pricing Hierarchy to Branches 
Define a pricing matrix hierarchy of territories for a branch to determine the pricing for products sold at 
that branch. 

To assign pricing hierarchy to a branch: 

1. From the Maintenance > Branch menu, select Branch to display the Branch Maintenance 
window. 

2. In the Branch field, enter a branch ID to display the branch record. 

3. Select Maintenance > Matrix Hierarchy to display the Matrix Hierarchy dialog box. 

4. Enter as many branches as you want to add to the hierarchy. 

5. Save your changes and exit the dialog box. 
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Assigning Remit-to Addresses to Branches 
Each branch in your company has a remit-to entity associated with it that receives payment for products 
sold at that branch. The remit-to entity's name, address, and phone number display on the customer's bill. 
You may have several sales branches and one accounting branch where you expect to receive payment. 
You can designate the accounting branch as the remit-to entity for a branch, to assure that the customer 
always sends payment to the correct branch. 

You can create one or more remit-to override entities in Remit-To Maintenance to override the remit-to 
entity set up at the branch level for customers and for zip codes. For example, apply an override if you 
want a billing service to handle a customer's large construction project instead of handling the billing 
yourself. 

To create customer remit-tos: 

1. From the Maintenance > Branch menu, select Remit-To Maintenance to display the Remit-To 
Maintenance window. 

2. In the Remit-To ID/New field, do one of the following to display a remit-to ID: 

• Click the New Remit-To button to create a new remit-to ID, and when prompted, enter the 
name of the remit-to. 

• Select an existing remit-to ID, or enter part of an ID to display a partial list of remit-tos. 

3. In the Name field, enter the full name of the remit-to entity. 

4. In the Address field, enter the remit-to entity's address. 

5. In the City, St, and Zip fields, enter the name of the city where the remit-to entity is located. 

6. In the Phone field, enter the remit-to entity's phone numbers. The first phone number in the list 
prints on invoices and statement forms. 

7. In the Codes field, enter a phone code to a phone number. Phone codes are defined in the Valid 
Phone Codes control maintenance record. 

8. In the Description field, enter the description of the phone number, such as "Main Office," or 
"Warehouse." 

More Options for Assigning Remit-to Addresses to Branches 

To... Select... 
copy the information defined for this remit-to 
entity to a newly created remit-to entity record 

File > Copy 

delete a remit-to override record File > Delete 
If you delete the record for a remit-to entity that has been 
assigned to a zip code customer, the system uses the next remit-
to entity in the hierarchy. 

display the Maintenance Log Viewing 
window for this remit-to entity 

File > Maintenance Log 
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Configuring Branch Credit Card Processors 
Eclipse is certified with a credit card processor that enables your company to route credit card information 
to a credit card company, such as Visa, when you place credit card orders. Each branch that will take 
credit card orders must be set up with the credit card processor you are authorized to use. 

To edit information on the Credit Card Branch Setup screen, you must be assigned the 
CREDIT.CARD.SETUP authorization key. 

Note: If you are using the Element processing, see Configuring the Element Credit Card 
Processor at Your Branches in the Element documentation. 

To set up a branch credit card processor: 

1. From the Maintenance > Branch menu, select Branch to display the Branch Maintenance 
window. 

2. In the Branch field, enter the branch name to display the branch record. 

3. Select Maintenance > Credit Card Branch Set Up to display the Credit Card Branch Setup 
dialog box. 

The branch displays in the bottom left of the dialog box. 

4. In the Processor column, enter the name of a credit card processor used by this branch. 

5. In the Merchant column, enter the name or number that identifies this branch to the credit card 
processor. The ID is assigned by the processor. 

6. The Device ID column displays the name or number assigned to the branch by the credit card 
processor. 

7. The Terminal ID column displays the name or number assigned to the branch by the credit card 
processor. 

8. To copy another branch's credit card information into the current branch file, select Additional > 
Copy Credit Card Info From Branch and enter the branch whose information you want to copy 
when prompted. 

9. Select a processor, and then select Additional > Additional Credit Card Information to display 
detailed information provided by your processing bank. 

10. Save your changes and exit the dialog box. 
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Creating Territories 
A territory is a name given to a group of branches. Maintain territories that include one or multiple 
branches, and name territories by physical locations, such as state or city, by types of products sold at the 
branches, or by any other category that makes sense for your business. 

If you have one branch or multiple branches include your branches in the ALL territory, because if you 
ever add a branch, the new branch can inherit branch-specific settings from the other branches. This 
strategy makes setting up a new branch easier than manually entering system-wide branch parameters. 

If you have two or more branches that have similar settings, create a territory for those branches. For 
example, you have two branches in the Denver city tax district, and the rest of your branches are located 
outside of the Denver tax district. Create a territory named DENVER that includes the two Denver 
branches. Compare these branches by running reports on the DENVER territory. 

A branch can reside in more than one territory. For example, you have 10 branches in Colorado: 2 
branches in Denver, 5 branches along major highways on the eastern plains, and three branches in small 
mountain communities that require a higher rate of freight. In this case, your territories might be named 
COLORADO, DENVER, PLAINS, and MOUNTAIN. All 10 branches are in the COLORADO territory, 
and each of those branches also belongs to the territory named for its geographic location. 

In any branch-specific screen, such as Product Price Maintenance, you can set territory and branch 
parameters. Branch settings always override territory settings. You can identify a screen with branch-
specific parameters by its Hierarchy hot key. 

You can edit and view only branches and territories to which you have access. To view or edit the 
Territory Maintenance screen, you must be assigned the TERRITORY.MAINT authorization key. Branch 
and territory access is defined in User Maintenance. 

To create a territory: 

1. From the Maintenance > Branch menu, select Territory to display the Territory Maintenance 
window. 

2. In the Territory Name field, enter the territory's name. If this is an existing territory, any 
branches belonging to the territory display in the table. 

Note: The ALL territory was created as part of your Eclipse DMS, so you do not need to 
create it. 

3. In the Territory Description field, enter up to 32 alphanumeric characters to clearly describe the 
territory. For example, if you have three branches in Iowa for the territory you are creating, you 
might include each branch's geographic location in each description, as follows: 

• Iowa - Des Moines 

• Iowa - Ames 

• Iowa - Sioux City 

4. In the Entity Priority and Product Priority fields, enter the level of importance for the territory, 
from 1-99. 99 is the highest priority: 
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• In the Entity Priority field, rank the territory based on customer and vendor parameters, as 
you would find on the Branch-Specific Overrides dialog box. 

• In the Product Priority field, rank the territory based on product parameters, as you would 
find on the Forecast Parameters Maintenance window. 

Is the territory assigned a priority? 

• No - The territory is used only for reporting purposes. 

• Yes - Users with authorizations have access to the Branch-Specific Overrides dialog box from 
customer and vendor records. You can include the territory in the Authorized Territories screen 
in User Maintenance only if the territory is assigned an entity or product priority. 

If you do not assign a priority, you can use the territory for reporting purposes only. Include this 
territory in the Authorized Territories screen in User Maintenance only if you assigned it an entity 
or product priority. 

When you view any screen with branch-specific fields, such as the Product Price Maintenance 
screen, select File > Hierarchy, and enter a branch. The selected branch displays at the top of the 
Branch/Territory column, followed by the territories that contain the selected branch and that 
you have authority to view. The territories are listed in order of their priority, with the highest 
priority at the top. 

Note: If you add or remove branches, or if you change territory priorities, the system 
requires you to delete branch cache files and to rebuild the authorized territories 
list. Run these utilities only after business hours to avoid interfering with daily 
business transactions. 

Select the Aggregate to ADS check box if you want to include the branches in this territory in data 
uploads for Zoom 360, a part of the Activant Distribution Suite. If you do not select this option, 
you cannot see the territory in Zoom 360; however, the branches that comprise this territory remain 
available, as Zoom 360 uploads data for all branches. 

Note: For additional information about Zoom 360, contact your inside sales representative. 

5. In the Branch column, list the branches in this territory. The system sorts the branches 
alphanumerically the next time you display the screen. 

The Branch Name column displays the full branch name. 

6. Select the following options as needed: 

To... Select this menu item... 
delete a territory. File > Delete 

The system prompts for confirmation. 
If you enter delete at the prompt, the system prompts to rebuild 
authorized territories. If you have the Override Automatic Build field set 
to Yes in your user record, the territory is not deleted from the list. 
If the territory has an entity or product priority, the system prompts to 
delete cache records. Delete cache records when changes are made to 
territories, and only after business hours. 

return the entries to what 
they were before you 
started making changes. 

File > Recall 

find a branch in the list. File > Find 
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7. Save your changes and exit the dialog box. 
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Adding Branches to Territories 
You can add branches to your territories based on your business changes. For example, if a territory 
expands, and you need to add a branch location to a territory. Additionally, if your company expands or 
reorganizes, you can change a branch's assigned territory or create a new territory to include new or 
different branches. 

You can edit and view only branches and territories to which you have access. To view or edit the 
Territory Maintenance screen, you must be assigned the TERRITORY.MAINT authorization key. Branch 
and territory access is defined in User Maintenance. 

To add a branch to a territory: 

1. From the Maintenance > Branch menu, select Territory to display the Territory Maintenance 
window. 

2. In the Territory Name field, enter the territory ID. 

Note: The branches belonging to the territory, if any, display in the table. 

3. Complete the fields in top of the screen. 

4. In the Branch column, enter the number of the branch, or select from the list. 

The branch name displays in the Branch Name field. 

Note: To delete a branch from the list, select the branch from the table and right-click. 
Select Delete. 

5. Save the branch information and exit the window. 

6. The system prompts to delete branch cache records. Select Yes to continue with your changes and 
display the Delete Branch Cache Records dialog box. You can run the utility now or schedule it 
to run later. 

7. In the Customer field on the Customer Maintenance window, enter the branch you added to the 
territory 

8. Select Orders > Accessible Branches to display the Accessible Branches dialog box. 

9. Change the Home Branch field to the new branch number. 

10. Save your changes and exit the window. 

Note: If you add or remove branches, or if you change territory priorities, the system 
requires you to delete branch cache files and to rebuild the authorized territories 
list. Run these utilities only after business hours to avoid interfering with daily 
business transactions. 
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Deleting Branch Cache Files 
The system stores data for each branch in branch cache files. When you enter an order or make a branch 
inquiry, the system retrieves only the data it needs for that branch, rather than having to search a huge 
database of multiple branch settings. This logic enables the system to retrieve data quickly and efficiently. 

The Rebuild Authorized Territory Lists utility and the Delete Branch Cache Records utility were 
developed to clear old data from the system and to ensure that the system could quickly and effectively 
retrieve the most up-to-date branch and territory data possible. The utilities are triggered by the following 
system changes: 

• If you change a priority in Territory Maintenance, the system prompts to delete the branch cache 
files. The system retrieves data from the old branch cache files until you delete the old files. After 
running the Delete Branch Cache File utility the system can access the new data. 

• If you change the list of branches in Territory Maintenance, the system prompts to delete cache 
records and then to rebuild the Authorized Territory List. The system cannot find the new data until 
you delete the old cache files. Running the Rebuilt Authorized Territory List enables the changes 
you made to the territory priorities. 

Important:  Run the Delete Branch Cache Records utility and the Rebuilt Authorized Territory 
List utility only after business hours to avoid interfering with daily transactions. 

This topic contains the following instructions: 

• Change branches in a territory. 

• Delete cache records. 

To change to branches within a territory: 

1. From the Files > Branch menu, select Territory to display the Territory Maintenance window. 

2. In the ID field, enter the territory name to display the territory record, including the branches 
associated with the territory. 

3. In the Branch field, make the necessary changes to the branches. 

4. Click OK. 

The system clears the fields on the Territory Maintenance screen. The changes are saved, but they 
are not effective until you delete the cache records and rebuild the Authorized Territory List. 

5. To change more branch records, enter another branch name in the ID field. 

Continue steps 2-5 until you have completed making changes to all the branches you want to 
change. 

6. Press OK to display the Delete all Branch Cache Records prompt. 

7. Enter one of the following: 

• Yes - Deletes the old records. DO NOT enter Yes during business hours. 

• No - Displays the Rebuilt Authorized Territory prompt. 
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To delete cache records: 

1. At the prompt to delete all branch cache records, enter Yes to display the Delete Branch Cache 
Records dialog box. 

Note: You can also run the Delete Branch Cache Records utility from the Maintenance 
> Branch menu. 

2. In the Files field, enter the name of the file to delete, if applicable. For example, you can 
occasionally run the utility by line for the PROD.BR file to clear the cache during working hours, 
if necessary. 

Note: You most commonly manually run the utility for the PROD.DYNAM file. 

3. In the Branch field, enter a branch to delete, if applicable. 

4. Select one of the following options: 

• File > Begin - Starts deleting cache files now. DO NOT run this process during business hours. 

• File > Schedule - Displays the Phantom Scheduler where you schedule a time to run the utility. 
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Rebuilding the Authorized Territory List 
Run the Rebuild Authorized Territory Lists utility to update the list of branches within a territory. When 
you change a territory record, this utility updates the branch hierarchy lists in the Branch/Territory 
column on any screen that displays branch-specific data, such as the Product Price Maintenance screen. 

The Rebuild Authorized Territory Lists utility and the Delete Branch Cache Records utility have a similar 
purpose in that they were developed to clear old data from the system and to ensure that the system could 
quickly and effectively retrieve the most up-to-date branch and territory data possible. The utilities are 
triggered by the following system changes: 

• If you change a priority in Territory Maintenance, the system prompts to delete the branch cache 
files. The system retrieves data from the old branch cache files until you delete the old files. After 
running the Delete Branch Cache File utility the system can access the new data. 

• If you change the list of branches in Territory Maintenance, the system prompts to delete cache 
records and then to rebuild the Authorized Territory List. The system cannot find the new data until 
you delete the old cache files. Running the Rebuilt Authorized Territory List enables the changes 
you made to the territory priorities. 

Important: Run the Delete Branch Cache File utility and the Rebuilt Authorized Territory List 
utility only after business hours to avoid interfering with daily transactions. 

To rebuild an authorized territory list: 

1. From the Files > Branch > Territory menu, select Rebuild Authorized Terrs to display the 
Rebuild Authorized Territory Lists dialog box. 

2. Use one of the following options: 

• File > Begin - Runs the rebuild. Run this utility only during non-business hours to avoid 
interfering with daily transactions. A message scrolls at the bottom of the screen when the 
system completes the process. 

• File > Schedule - Displays the Phantom Scheduler where you schedule a time to run the 
rebuild. 

The system rebuilds the territory lists based on the changes made to the territories, and depending 
on your territory settings in User Maintenance, as follows: 

For the... The system updates... 
Reporting List all territories that include at least one branch accessible to the user. 

Viewable List any territory that has either an entity or product priority and that includes at least one 
branch accessible to the user. The entity or product priority setting means the user can 
set overrides at these levels for this territory. 

Editable List any territory that has either an entity or product priority and the user has all branches 
for a territory in their authorized branch list. The entity or product priority setting 
means the user can set overrides at these levels for this territory. 
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Setting Up New Branches Overview 
As you grow your business, you must add new branches to Eclipse. The way you use the new branch 
determines how to configure the branch. Depending on your business structure and the reasons for adding 
the branch, you must decide if you are adding the branch as a part of your existing Eclipse system or as a 
separate company within your system. For example, you can set up branch strictly for pricing purposes 
that lives in your existing system or you could split some of your processes into a new business structure. 

There are several questions you must address before adding a branch. The following checklists and 
questionnaires are provided to guide you through the setup process. 

• New Branch Questionnaire 

• New Branch Control Record Check List 

• New Branch Setup Workflow - Step by step check list in setting up the branch. 

After reviewing each of the above, you can create branch entities, assign users, and address territories, as 
needed. 
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New Branch Setup Workflow 
Use the following check list to make sure each step has an owner. We recommend completing these in the 
order listed, however depending on the type of branch you are setting up, some steps may not apply. 

The answers to the questionnaire help you decide how to handle steps that have multiple options. Read 
details carefully for each step to make sure all concerns are addressed. 

Step Description Assigned To 
1 Create the branch entity in Customer Maintenance. See Creating 

New Branch Entities. 
  

2 Create the branch in Branch Maintenance.   
3 Authorize your User ID for the new branch. Log off and back on 

to the system. 
  

4 Create and update territories and delete your cache records.   
5 Assigning customers for the new branch.   
6 Assigning vendors for the new branch.   
7 Assigning products and price lines for the new branch.   
8 Geographical price sheets and discount classes.   

Geographical sell groups (optional)   

Branch-specific and territory-specific settings.   

9 Update procurement groups for new branch.   
10 Update buy lines with targets and buyers for new branch.   
11 Update branch-specific control parameters.   
12 Add demand to new branch. (optional)   
13 Create transfer matrix cells to new branch.   
14 Copy or create matrix cells for new branch. (optional)   
15 Delete and recreate phantom processes.   
16 Create printer locations for new branch.   
17 Update terminal maintenance for terminals in new branch.   
18 Update fax settings for the new branch.   
19 Create new general ledger accounts for the new branch.   
20 Verify ship via records assigned to new branch.   
21 Authorize other users to access new branch / territories using mass 

load. 
  

22 Verify product families in new branch.   
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New Branch Questionnaire 
We recommend reviewing and answering each question to ensure a thorough and correct setup of your 
new branch. 

Note: All references to "branch" refer to the new branch you are setting up. 

1. Is the branch for pricing purposes only? Yes or No 

2. Is the branch part of the existing company already using the 
Eclipse system or are you setting up the branch as a separate 
company? 
See additional questions on Adding New Branches to the Current 
System and Branches as Separate CA 

Existing or 
Separate 

3. Is the new branch being created because a current branch is 
moving to a new location? 

Yes or No 

4. Do your employees know about the branch? Yes or No 

5. Do you have all the hardware and licenses required for the 
branch? 

Yes or No 

6. Before the branch is added, are you a single branch 
establishment? 

Yes or No 

Save these answers as you work through the check list. 
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New Branch Control Record Check List 
The following represent control files that may be affected by the new branch addition. Review each to 
make sure the new branch handles the settings the same as your other branches, or how you want it to be 
incorporated into the system. 

File Name Description Checked 
CONTROL The branch-specific control records need to be updated to the appropriate 

settings for the new branch. 
For information about branch hierarchies, see Branch Hierarchy Details. 

  

TERRITORY The territory file stores the branch and territory information that exist within 
the Eclipse system. 
For more information about how territories work, see Territory Priority Basics. 

  

ENTITY The system stores your customer and vendor records in the ENTITY file. 
When you create the new branch within the current Eclipse system setup you 
have, customer and vendors that do business with it need to be created and 
flagged to do business only with the new branch. Therefore, your customers 
will have separate statements from each company. 
If you are creating a separate company, and you have customers and vendors 
that will exist in both companies, you must duplicate and update these records 
so they only do business out of your current branches. 

  

PRODUCT Your product file can be authenticated. Authenticating a product file restricts 
products you sell in your current system branches so they cannot be sold in the 
new branch. 

  

PROD.PRICE Review geographical price sheets for the new branch. If your pricing for the 
new branch can be based on a current branch's demand, then you can skip 
reviewing price sheets. 

  

MATRIX If you cannot use another branch's matrix setup for the new branch, you must 
add a matrix cell that is territory-specific needs for the branch. 

  

BUY.LINE If you need new buy lines for the new branch you are creating, create them 
using vendor targets. You can also assign current buy lines to the branch. 

  

PRICE.LINE If you create new price lines for the new branch, mark them as branch-specific. 
If possible, leverage current products in the new branch. 

  

INITIALS New user profiles need to be added, if required, to work out of the new branch. 
Branch authorizations need to be updated for current employees who can 
operate in the new branch. These updates include printer locations, if current 
users can do business out of this branch. 

  

PROCURE.GROUP If material can be transferred from a current branch to the new branch (existing 
Eclipse system setup only), the procurement groups need to be updated to make 
the new branch part of a purchasing network. This file needs to be updated 
regardless of methods allowed for suggested purchase orders to run. 

  

SYSTEM.QUEUE Phantom processes need to be created or updated to reflect the new branch.   

TTY.DEFINE New terminal configurations need to be created for terminals operating in the 
new branch's location. Current terminals that can also do business in the new 
branch also need to be reviewed. 

  

PRINTER.LOCS Define new printer locations in the new branch and then assign users and 
terminal setup. 
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Adding New Branches to the Current System 
Questions to consider if you are adding the new branch to the current Eclipse system on your site: 

  Question Answer 
  Are the branches close enough together physically that product demand 

would move to the new one? 
  

  If you answered no to the previous question, can the product demand of a 
current branch be used to copy to the new branch? 

  

  Will material be transferred from an current branch to the branch for stock 
replenishment? 

  

  Can your existing pricing matrix be used in the branch?   
  Will the list price on products be the same as current branches?   
  Will your current employees be able to sell material out of the branch?   

  Is it an empty warehouse or did you buy inventory from the previous 
owners? 
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Adding New Branches as Separate Companies 
Questions to consider if you are adding the new branch as a separate company from the current Eclipse 
system on your site: 

  Question Answer 
  Is the branch a startup company or will data need to be converted for Eclipse?   

  Can your current customer purchase material from the branch?   
  Will you have the same vendors for this branch as the other branches in your 

system? 
  

  Can current products be sold out of the branch?   

  Is the warehouse empty or are you buying the inventory from the previous 
owners? 

  

  Will your current employees be able to sell material out of the branch?   
  If you have current products that can be sold, is there a current branch in your 

system that has demand you can be copy to the branch for use with suggested 
purchase orders? 

  

  Do you have special forms required for your documents, such as invoices, 
checks, statements and ship tickets? 
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Creating New Branch Entities  
(Setting up a New Branch, Step 1) 
When adding a any branch to your system, create a new record containing the name and address 
information for the new branch in Customer Maintenance. You need the branch record through Customer 
Maintenance to create an entity that represents the remit-to address for this new branch. If the remit-to 
address is the same as an existing branch you find it in Branch Maintenance. You then use Branch 
Maintenance to create the Branch ID itself (See, Creating Branch IDs, Step 2). 

To create a new branch entity: 

1. From Customer Maintenance, select Customer to display the Customer Maintenance window. 

2. Enter the branch information. 

3. In the Customer Type area, select Bill-To, Ship-To, and Branch. 

Note: Selecting these prompts sets the entity record apart from the standard customer and 
vendor records. 

 
4. From the Pricing menu, select Price Information to display the Customer Pricing Information. 

5. Set the Default Price Class field to a unique, branch-only class, such as 99. 
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Note: The internal ID number for your record displays on the main window at the bottom 
(25096 in the example above) to help in creating the branch ID. You need the 
branch record that represents the remit-to address for this new branch. If the remit-
to address is the same as an existing branch you find it in Branch Maintenance. 

6. Depending upon on how you are adding the branch, review the following: 

• Existing - If the branch is new to an existing company only one entity record is required. 

• Separate - If the branch is for a separate company, you will want to create two entity records. 
One for the branch where the inventory moves through and the other branch to define your 
remit-to address. 

7. Save your changes and exit the window. 
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Creating Branch IDs  
(Setting up a New Branch, Step 2) 
After creating the new branch's entity, create the new branch ID itself using Branch Maintenance. 

To create a new branch ID: 

1. From Maintenance > Branch menu, select Branch to display the Branch Maintenance window. 

2. Click New Branch. 

3. Complete the branch fields for the new branch paying particular attention to how your current 
branches are configured. 

4. For the Branch Entity and Remit-To ID fields, consider the following: 

• If you are creating a branch as part of the existing company, the remit-to ID may already exist 
and can be assigned to this new branch. Check another existing branch. 

• If you are creating a branch as a separate company, the remit-to ID may be the same as the 
Entity ID. If the remit-to address is different from the Entity ID, then create the entity record in 
Customer Maintenance and assign it in the new branch’s Remit-To ID field. 

5. Save your changes and exit the window. 

Additional Considerations 
The following should be noted when creating records for new branches: 

Area Description / Comment 
Ship Via When the branch record is updated, the system prompts you to load all valid ship-via 

records to the new branch record. Answer No at this prompt if your current ship-via records 
need to be reviewed before they are added to the new branch. 
For more information about how ship vias work, see Creating Ship Vias in Account Setup 
Maintenance in the online help documentation. 
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Area Description / Comment 
Inventory Inquiry 
Branches 

The system checks the user’s home branch when the user logs in. The system then checks 
the branch record that matches the home branch to determine what inventory inquiry 
branches display. 
If the user's profile has an Inventory Inquiry Branch/Territory assigned at the user level, that 
assignment takes priority. 

 
The order in which these branch numbers are listed is the order in which they display in the 
Inventory Inquiry screen. 

Note: Some companies create territories and assign Inventory Inquiry Branch/Territory 
settings to the user profile instead of using this functionality. The system always sorts the 
branches and territories in alphanumeric order regardless of how they are entered in 
Territory Maintenance. You can define which branches display in Inventory Inquiry. 

If you are creating the branch for an existing company, you need to update all the branches 
that have access to this new branch in Inventory Inquiry. If you followed the setup at the 
branch level as outlined in this document, then each branch record updates automatically. If 
your setup was done on a territory, then the territories need to be updated to include the new 
branch. 
If you are creating the branch as a separate company and the only inventory this new 
company should view is its own, only assign the stocking branch for the new branch on this 
screen. 

Branch Matrix 
Hierarchy 

The Matrix Hierarchy option off the Maintenance menu in Branch Maintenance is used to 
define territories that participate in the pricing hierarchy. If your company has pricing and 
your matrices are set up by territory for specific geographical locations, then you must need 
to list the territories that participate in the price check. 

Note: If all of your pricing is created and maintained at the DFLT branch level, then nothing 
is required here. If you plan to allow overwriting pricing in the new branch to use a territory, 
then review these settings after you have created your territories. 

You may want to revisit this record later to add or update information, such as Credit Card 
Processing and Check Verification. 
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Authorizing Users for New Branches  
(Setting up a New Branch, Step 3) 
Before enabling the new branch on your system for all users, you can limit access to a small number of 
users for testing. You can also limit some branches, such as branches you are only using for pricing 
purposes, to a small set of users. We recommend authorizing your own ID first. 

To authorize a user for a branch: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter your User ID, such as HBOYLE. 

3. From the Maintenance men, select Branch to display the User Accessible Branches window. 

4. Assign the new branch to the user's list. 

Note: You will need to log out and log back in to see the update for your user. 

5. In the Authorized column, you can limit the job function for the user in the branch. Select one of 
the following: 

• Only Inventory Inquiry - Allows users to view available quantities on the main Inventory 
Inquiry. The user cannot access the History Ledger or the Future Ledger. We recommend using 
this for those who run two separate companies on one Eclipse account. The users can see 
limited information and cannot see pricing for the new branch's products. 

• Sales Order/Inventory Inquiry - Allows users the same access and restrictions as Only 
Inventory Inquiry and lets the user ship material out of the branch. We recommend using this 
option if the new branch is part of your existing company. 

• Blank - Normal, full access to the branch included in reports run for ALL territory. 

Note: By selecting one Only Inventory Inquiry or Sales Order/Inventory Inquiry, 
you restrict users' branch access in other areas of the system, such as General 
Ledger. 

6. Repeat steps 2-4 for additional users. 

7. Save your changes and exit the window. 

For more information about authorizing users for branches, see Assigning Branches to Users in 
the Application Maintenance online help documentation. 

About Home Branches 
The home branch usually represents the branch ID in which the user primarily works. The system uses the 
home branch throughout for things such as reports and prompts the user for the home branch if not set. 
However, because the home branch prompt exists on Customer and Vendor records, some companies set 
the home branch prompt to a corporate branch value and not the actual branch for the user. 

Depending upon on how you are adding the branch, review the following: 
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• Existing - Verify how your current setup exists to determine whether new user profiles working in 
this branch should have the home branch assigned to the new branch or existing corporate branch 
ID. 

• Separate - Verify how you currently setup your corporate / branch structure and follow that 
structure for the new company setup. Decide if you want the home branch as the new company's 
corporate branch ID or as the branch in which the user actually works. 

About Home Territories 
When running separate companies on one system, it is easier to run reports for all branches in a territory, 
then to list them individually on a report. Larger companies may only have one company running on 
Eclipse, but take advantage of the home territory setting for this reason. You can create territories to be 
geographical or industry-specific, depending on your needs. 

Depending upon on how you are adding the branch, review the following: 

• Existing - Add the new branch to the territory assigned as the home territory. This field is optional. 
If this field is blank, do nothing. 

• Separate - You need to have two territories in the system. One that represents your existing 
company and all the branches and another that represents for the new company and all its branches. 
Each user should be assigned a home territory. 

About the Inventory Inquiry Territory Field 
On the User Accessible Branches window, the user profile generally defaults the Home Branch field to 1 
and the territory settings are blank. When a user logs into the system, the system checks the Inventory 
Inquiry settings for Branch 1 to verify what branches the user should see. If Branch 1 has not been 
updated to include the new branch, then the user does not see it in inventory Inquiry, but will have the 
ability to create a sales order for that branch. 

If the Inv Inq Territory prompt displays a territory, the new branch will not display on the Inventory 
Inquiry window until the territory is updated to include it. 

Depending upon on how you are adding the branch, review the following: 

• Existing - If you are using Inventory Inquiry Territory logic, add the new branch to the territory 
listed. 

• Separate - If the company should not see the branches for your existing company in the Inventory 
Inquiry, then user the branch ID Inventory Inquiry logic and point the new user profile to the home 
branch representing the new company branch ID or setup a new territory and assign through the 
user profile. 



Creating and Maintaining Branches and Territories 

45 

Creating and Updating Territories for New Branches  
(Setting up a New Branch, Step 4) 
After creating the new branch and authorizing the appropriate users, you must create or update any 
territories that may be used. 

To view current territories: 

1. From Files > Branch menu, select Territory. 

2. In the Territory Name field, click the Branches button or press F10. 

Note: If your valid territories is a long list, you can create a report through Report Writer 
using the TERRITORY file to report back the territories that exist and branches 
assigned. If Attribute 11 of this file is empty or blank, then it is a territory, 
otherwise it is a branch record. 

Reporting Territories 
You can create a territory for reporting purposes only. For example, you create a territory named 
STHWST and add all your branches in the southwest region. Then, when running a report you can report 
on all the branches in your southwest region without having to add each branch individually. 

You can also assign data to a territory name. All branches in that territory inherit that assignation. Since 
the same branch can exist in multiple territories, the branch hierarchy ensures the data is assigned 
accurately. 

Assigning Priorities 
When creating a territory for reporting purposes only, leave the priority level blank. If a priority level is 
set, the territory becomes part of a list of branches to assign data: 

 
Using these examples, the CB territory has a product priority of 50 assigned while the GLOBE territory 
has a product priority of 45 assigned. Items such as buy line targets or emergency vendors can be 
assigned to both territories and applies equally to all branches within the territory. The priority number 
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assigned determines how the system sorts the territory when sorting in descending order. A higher 
number makes the territory a higher priority. For these two territories, CB would be listed after GLOBE. 

For example, if different sell groups are assigned to both of these territories, when you create a sales order 
for branch 3, the system uses the sell group assigned to the CB territory because it has a higher priority, 
rather than the one assigned to the GLOBE territory. If you assign a sell group to the branch record, the 
system uses that sell group rather than those assigned to any territory. 

Note: The matrix hierarchy on the branch record is different from this logic. the order for 
which territories are assigned to the branch ID is the order for which the system 
checks for a price. The product priority does not need to be set when managing 
matrix hierarchies in Branch Maintenance. 

Depending upon on how you are adding the branch, review the following: 

• Existing - Add this branch to your existing territories when appropriate. 

Important: After creating or updating territories, the system prompts you to save your changes, 
but alerts you as follows: All branch cache records must be deleted for changes to 
take effect. Delete now? You must answer Yes to this prompt or the system does 
not respect the changes you made in Territory Maintenance. 

If your company has geographical price sheets that point to a territory ID, you must also run the 
Rebuild Price Sheet/Discount Class Cache utility. When you run the utility, leave the Price Line 
field blank to capture all of your price lines. If you have a limited number of price lines that have 
territory-assigned price sheets, you can run it for those lines only. 

Important: If this procedure is not completed, your pricing will not function properly. Both of 
these functions can be run during the day with no negative impact on the system. 

• Separate - The existing territories remain the same and the new territories are added for the new 
company. Because no changes are being made to the existing territories you do not need to delete 
the cache records and you do not need to rebuild the price sheets. 

Typically, separate companies may have different pricing on products because the multiplier may 
be different. Therefore your REP-COST is not the same. Eventually, a separate price sheet needs to 
be assigned to your products to keep the pricing separate from your current pricing. However, you 
can leverage your existing matrix discounts and your base values can be different for each item in 
the system. 
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Authorizing Customers and Vendors  
(Setting up a New Branch, Step 5) 
Some companies have set their branch authorization to all branches on the entity records. 

Depending upon on how you are adding the branch, review the following: 

• Existing - If you want to allow all customers and vendors to do business in the new branch, then no 
further settings are required. 

• Separate - Consider whether to authorize them for the new branch. In order for an existing 
customer to do business in a separate company, the record must be duplicated and new branch only 
authorized for the new company’s home branch and distribution branches. You cannot have the 
same Accounts Receivable account for two separate companies. 

Setting Active/Inactive Customers and Vendors 
The Accessible Branches window contains prompts related to the activation of the customer or vendor 
within the branch. Use the Display Customers/Vendors Who Are Inactive At a Branch control 
maintenance record to activate this functionality. 

In addition, review the following authorization keys and the levels associated with these prompts. 

• CUST.BR.AUTH.OVRD - Level 0-99. When a user enters a transaction from a branch not listed 
on the customer's Accessible Branches, the system displays the following prompts: Don't Activate, 
Activate for Branch, and Activate for Onetime Use. 

Users assigned an authorization level greater than or equal to the level entered in the Branch 
Activation Level field on the customer's Accessible Branches screen can activate the customer. 
When a user activates a customer, the system adds the branch to the customer's Accessible 
Branches and sets the Active field to Yes. 

• CUST.BR.AUTH.ONETIME - Level 0-99. The system verifies the user has this authorization key 
assigned with the appropriate level. If yes, then the user can activate a customer for a one-time-
only transaction in Sales Order Entry or Cash Receipts Entry, if the customer is not set up being 
active or inactive for the sales branch. 

The same two authorization keys exist for the vendor activation: 

• VEN.BR.AUTH.OVRD 

• VEN.BR.AUTH.ONETIME 

Mass Loading Authorized Branches to Entity File 
Use the Mass Load utility to enter authorized branches for an entity files all at one time. Your Mass Load 
settings should be very selective. For example, you have the entity record with access to branch 4 and 
access to branch 20. If all the entity records can have access then you can select out all customers and add 
the new branch to the list. 

Before you set up your mass load, display Dictionary Maintenance and verify that you have the following 
dictionary items in place: 

• File Name: ENTITY, DICT ID: AUTH_BR 
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• File Name: ENTITY, Dict ID: AUTH_BR_FLAG 

 
Below are examples of 6 methods for mass loading. When this mass load is run, the load must use Set, 
not Update. To test the load, select one record, run the load and verify the record updated as you 
expected. 

• Method 1 - Add Branch 

Using dictionary AUTH_BR, set value to “BRANCH” and that branch will be appended to the 
end of the current branch list with the ACTIVE flag set to “Y”. 

Example using branch 1: 
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• Method 2 - Add Branch Setting ACTIVE Flag to No 

Using dictionary AUTH_BR, set value to “BRANCH~N” and that branch will be appended to the 
end of the current list with the ACTIVE flag set to “N”. 

Example using branch 1: 

AUTH_BR S “1~N” 

 
• Method 3 - Delete Branch 

Using dictionary AUTH_BR, set value to “BRANCH~DEL” and that branch will be deleted from 
the list if it exists. 

Example using branch 1: 

AUTH_BR S “1~DEL” 
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• Method 4 - Change ACTIVE Flag 

You must to create a dictionary item for Attribute 24, Value 2 calling the same update routine 
AUTH_BR uses: DICT.ADD.ENTITY.BR. Set the value to “BRANCH~Y” or “BRANCH~N” 
and the ACTIVE flag changes for that branch. 

Example using branch 1 which will change ACTIVE flag from “Y” to “N”: 

AUTH_BR_FLAG S “1~N” 

 
• Method 5 - Delete ALL Branches 

Using dictionary AUTH_BR, set value to “” (null) and the entire branch list will be removed. 
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• Method 6 - Add ALL Territory 

Using dictionary AUTH_BR, set value to “ALL” and the ALL territory will be added to the list 
with ACTIVE flag set to “Y”. You could add “ALL~N” if you wanted to add the ALL territory 
but with the active flag set to “N”. 

Note: With this method you would do the following to make sure to clear out any branches that 
may exist in the list. 

AUTH_BR S “” 

AUTH_BR S “ALL” 

 
Depending upon on how you are adding the branch, review the following: 

• Existing - None of the above tasks or settings apply. 
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• Separate - The entity records must be added only to the new company setting. The system uses the 
control parameters related to the Customer Template when creating a new customer for a given 
branch. 

Create a template-only customer to be used as your template that has the proper branch 
authorization and assign it to the correct branch with the control parameters your company uses. 

If the new company is a “Start Up,” then typically customers are created on-the-fly through Sales 
Order Entry at the time of sale. 

If you have a list of customers that need to be added, then you can use the Customer Import 
functionality within your hold file. However, we recommend caution when using the customer 
upload functionality. It is immediate and permanent. If an error occurs it is difficult to undo or go 
back without restoring from a backup. There is no vendor update (import) utility in the system. 
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Authorizing Products and Price Lines  
(Setting up a New Branch, Step 6) 
Eclipse Release 8.0 and higher allows you to authorize products or price lines to display in a branch: 

• Disable Branch Specific Product Authorization In PDW Catalog Search Disable Branch Specific 
Product Authorization In PDW Catalog Search - Decide whether to override the settings in the 
Enable Branch Specific Products For control maintenance record. 

• Enable Branch Specific Products For Enable Branch Specific Products For- Select whether to 
enable branch access authorization for products and price lines by user branch or by price branch. 
This works with the authorized branches assigned to a user. 

After setting this control maintenance record, price lines and products can be assigned to the appropriate 
branches. Territories cannot be assigned. For example, the new branch is a separate company that 
provides a service. You create a price line for the service items and the authorized branch assigned is the 
service company you created. The service items do not display to anyone in the exiting company. Only 
staff members who create orders for the service company would see the service items. 

 
Note: If your company does not utilize this functionality and all products can be sold in 

all branches regardless if you have a separate company setup, then this function 
can remain disabled. 
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Geographical Price Sheets and Discount Classes  
(Setting up a New Branch, Step 7) 
You can assign geographical price sheets and discount classes by branch at the product level. The pricing 
on products can be different in the new branch you are setting up, if you are adding branches for a 
separate company. If you want the new branch to have separate LIST prices on products, then you must 
assign price sheets or discount classes at this level. 

Use the product file’s Product Price Maintenance window to assign a price sheet to a branch or territory: 

 
Note: To view this window, from the Product window, use the Pricing menu and select 

Product Price Maintenance. 

In the figure above, branches in the MASS territory use the price sheet called MA to determine the costs: 
LIST, REP-COST, STD-COST, etc. These basis values are used to formulate your customer discounts 
when applying the matrix formula. Display the Product Price Sheet Maintenance (from the Pricing menu, 
select Price Sheet) for the item above. The system prompts to choose the price sheet to view or edit. You 
must be assigned the PRICE.SHEET.ENTRY authorization key, level 2 or 3 to edit price sheets. 

For example, the default price sheet may have a LIST price of $10.00 for the item, but the MA sheet may 
have a list price of $10.78. In addition, one price sheet may have more effective dates than another. 
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Consider this setup like having two separate products for two different companies with separate pricing, 
but the system maintains everything on the same record. 

Mass Loading a Price Sheet to Products 
If your business requires separate pricing, you must mass load a price sheet to the territory for branches 
that will use the pricing. This mass load creates a blank price sheet. The system populates the pricing data 
when the territory information is completed with pricing information. 

Below is an example of a mass load for a price sheet within the product file. The selection is especially 
important if this mass load should only be assigned to certain product lines within the system. You must 
make sure you have pricing to populate to the sheet you are creating, otherwise transactions are not 
priced. 



Geographical Price Sheets and Discount Classes  
(Setting up a New Branch, Step 7) 

56 

 

Important:  After the mass load runs, from the Tools menu, select Rebuild Price 
Sheet/Discount Class Cache to make sure your price sheets are up to date. 

Discount Class 
Discount classes are sheet specific, not branch specific. That means that a discount class on a different 
sheet will not automatically move to the new sheet you create. 

The dictionary item to use when updating discount classes on the product file is DISCOUNT_CLASS. 
When the system prompts you for a branch, remember that it pertains to the sheet assigned to the branch 
you enter. That is why this dictionary item will not prompt to Ignore the Branch Hierarchy. 
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Geographical Sell Groups/Buy Groups  
(Setting up a New Branch, Step 7b - Optional) 
Use buy groups and sell groups to group similar products together for customer discounting purposes. 
The Pricing Matrix options in Eclipse help you set up these discounts. While customers are assigned to a 
price class, products are assigned sell groups. Formulas are created to discount costs based upon the sell 
group information. 

For example, a Price Class 6 customer may receive a 10% discount on your Watts Regulator items, 
whereas a Price Class 4 customer may only receive an 8% discount. The sell group assigned to products 
determines the group of items eligible for the discount to these types of customers. 

 
If sell groups are assigned to the ALL territory, the new branches added to the system automatically use 
the existing sell group. This auto-assignation saves maintenance, because discounts as outlined above are 
managed using the correct price sheet for each branch. A 10% discount in Branch 1 may use a $10.00 list 
price whereas a 10% discount in branch 20 may use a $12.00 list price. 

Most companies leverage existing matrix setups for use in the new branch regardless if it considered is a 
separate company or an existing company. Even if a new matrix cells need to be created for your new 
territory, the sell groups and price classes for customers are already in place. 

Note: If your sell groups are currently branch-specific, you can mass load sell groups 
onto the new branch or territory. If you have upgraded from Release 7.x.x to 
Release 8.0 or higher, then some items may be branch-specific and need to be 
addressed. 

If the sell group is the same in all branches, we recommend mass loading the sell group to the ALL 
territory so ongoing maintenance is not required. 



Branch-Specific and Territory-Specific Product Settings  
(Setting up a New Branch, Step 7c) 

58 

Branch-Specific and Territory-Specific Product Settings  
(Setting up a New Branch, Step 7c) 
After considering price settings for the new branch you are creating, you must consider specific product 
settings. 

There may be branch overrides on items that could be copied to the new branch. For example, the default 
demand setting for an item in a branch is non-seasonal. If the item should be flagged as a seasonal product 
in the branch, then use a mass load to set these items. You can save time by copying the settings from an 
existing branch into the new branch. 

Review the branch-specific, purchasing prompts first using the Forecast Parameters for Demand 
Calculation control maintenance record. 

Consider the following purchasing prompts: 

• Forecast Method 

• Seasonal flag and settings 

• Lost Sale setting 

• Exceptional Sales % 

• Trend % 

• EOQ $ 

• EOQ % 

After checking the other purchasing prompts, use the Primary Inventory Maintenance to review the 
setting for the Backorder Tolerance Quantity. 
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If this control maintenance record's parameters are set for the branch, the system uses the settings without 
requiring additional mass-loading of data. However, if there are certain products that have overrides to the 
default setting at the control maintenance record level, it is important that these settings are copied into 
the new branch and you will need to run a mass load to populate the data. 

Using Report Writer to Verify Data 
Information that does not copy or get automatically populated from the control file should be verified by 
creating a report through Report Writer that can be used as a mass load. 

Note: Report Writer is only available in the Eterm application as of Release 8.7.5. 

The data elements to review are: 

• BUY_PKG – Buy Package Quantity 

• BUY_PKG_DIVISIBLE – Buy Package divisibility setting 

• SELL_QTY – Minimum sales quantity 

• QTY_BRK_QTY - Multiple value quantity break quantities 

• QTY_BRK_UOM - Quantity Break UOM 

• COMM_GROUP – Commission Group 

• SERIAL – Serial Number Tracking Control 

• FREIGHT_CHG – Freight Charge 

• FREIGHT_FACTOR_PCT – Freight Factor Percentage 
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• PASS_DISC – Percentage for Pass Long Vendor Discount 

• LABEL_PER – Number of Labels to print 

• PRICE_SHEET_PRT – Price Sheet Print Flag 

• RESTRICT_PRICE_CHNG – Restrict Price changes in SOE 

Create report in Report Writer on the product file with these dictionary items and run it for a branch that 
will be similar to the new branch you created. Scan the report to determine if overrides exist. If so, set the 
data in the new branch to match the existing branch you want to copy. 

Below is an example of a Mass Load copying branch 2’s information into branch 20: 

 
The column data will be structured as follows: 
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Updating Procurement Groups  
(Setting up a New Branch, Step 8) 
Procurement groups control how products are replenished. Your company may have one or more 
procurement groups depending on how your system was set up. Consider reviewing and cleaning up 
duplications to make the procurement paths more manageable to maintain before continuing. We 
recommend consulting the purchasing department before making any changes to procurement group to 
ensure there are no adverse affects on how your inventory is purchased and transferred. 

Depending on your purchasing needs, procurement group setups can be very different. 

Example 1: 
Branch 1 buys and warehouses material for all other branches in the company. Branch 1 replenishes 
material to those branches using transfers. 

 
When adding a new branch to the system, you want to also update the procurement groups to include the 
new branch as part of the replenishment. 

For more information about procurement groups, see the following: 

• Replenishing Child Branches 

• Procurement Confirmation 

• Creating and Deleting Procurement Groups 

• Setting Up Transfer Branches for Procurement Groups 

• Product Procurement Details 

Note: In addition, you can refer to the Inventory Management Workbook materials 
available with the Inventory Management Eclipse University class. For more 
information, go to http://epicor.com/distribution/, click Customer Login at the 
top of the page and click Eclipse. 

Existing Company 
If Branch 20 is added to an existing company and Branch 1 is buying and warehousing for Branch 20 as it 
does for the other branches, then use the setup above. The ALL territory includes Branch 20 and, 
therefore, Branch 20 is automatically added to the network. The only updates to consider further would be 
for the Transfer Branches for emergency procurements. 

http://www.epicor.com/Industries/Distribution/Pages/Distribution-Software.aspx
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Separate Company 
When adding a new branch that is a separate company, then the material must be assigned as distributed 
for that company. 

 
As shown above, the new branch buys and warehouses for itself and cannot procure material by way of 
transfers from the existing company. Use the Procurement Group Branch Copy utility (Purchasing > 
Maintenance) to add this type of setup quickly and without the need of a mass load. 

 
If your company has a separate procurement group for every buy line for the purpose of posting the 
emergency procurement vendor to each group, then you may be able to eliminate the maintenance. 
Assigning *BUYLINE* to the emergency procure vendors screen alerts the system to look to the buy line 
record for the vendor. We recommend that using this feature and eliminating all the extra groups that are 
duplications. 
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Adding Targets and Buyers to Buy Lines  
(Setting up a New Branch, Step 9) 
Targets and buyers are purchasing-branch specific. Meaning, the system uses the buyer assigned to the 
Buy Br column in the Procurement Group set up. 

Existing Company 
If Branch 20 was added to an existing company and it becomes part of an existing central warehouse 
network, then Buy Line Maintenance does not need to be updated. All the framework exists on the buying 
branch and the new branch inherits the targets and buyers assigned. If Branch 20 was added to an existing 
company, but it will buy and warehouse inventory for itself, then the branch must be assigned a target and 
buyer in Buy Line Maintenance. 

Note: We recommend reviewing your procurement group setup and replenishment paths 
before reviewing the buy lines settings. 

Separate Company 
If the new branch is a separate company, then the branch buys and warehouses its own inventory. The 
target and buyer information in Buy Line Maintenance. For example, in the example above, Branch 20 is 
a distributive on the CW  procurement group, because the branch will buy and warehouse its own 
inventory. Therefore, buy lines that point to the CW procurement group need to have at least a target and 
buyer assigned. 

 
The buyer SCOTTR handles buying for the existing company and NICOLE is the buyer for the new 
company. Each buyer has his own suggested purchase order for the company for which they work. 

If procurement groups are assigned to your buy lines, then you can use mass load to remove the buy lines 
using the procurement group. This narrows your selection to those buy lines you need to update. In the 
example above, Branch 20 was added as a new branch and it was made a distributive branch for the CW 
procurement group. Therefore the mass load (shown below) updates Branch 20 for only buy lines 
assigned to the procurement group called CW. 
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In the figure above, all dictionary items have a Set Value with the exception of the TARGET_VALUE 
dictionary item. While the value is blank, the Type column is set to U for Update. This allows the user to 
type in the value for each buy line. 

 

 
When the mass load is run, users can enter the dollar amount for each buy line. 
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For more information about column types, see Designing Mass Load Layouts in Report Writer and Mass 
Load online documentation. 
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Updating Branch-Specific Control Parameters  
(Setting up a New Branch, Step 10) 
The Eclipse system uses control maintenance records to turn on and off different parts of the system 
based on your business needs. You should review the control maintenance records and set them up to be 
branch-specific parameters. To identify the control maintenance records in your system that are branch 
specific, you can use Report Writer/Mass Load to narrow down the search. 

First, run a report to locate the control maintenance records: 

 
The example above produces a report displaying the Category, Area, and Prompt. The results contain over 
200 branch-specific control settings to review. You must further define the report using sorting criteria 
defined for the report. Use the Begin Select hot key to display the following: 

 
The branch-specific control maintenance records display. Use this report address the control maintenance 
record parameters you need to review. The system automatically includes control maintenance records 
that pertain to RF. Depending on your warehouse setup, you may be able to skip those control 
maintenance records. We recommend reviewing the list with those who have expertise in the category and 
area defined. 

The remainder control maintenance record settings are for ALL branches regardless if you have a separate 
company running on the same Eclipse account. 
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To review a complete list of control maintenance records, see Control Maintenance Overview in the 
Control Maintenance Record online help. The records are separated by system areas. 
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Adding Demand to New Branches  
(Setting up a New Branch, Step 11 - Optional) 
When you create a new branch, there is no history attached to the branch and therefore no way to 
calculate demand for purchasing purposes. You can wait for the system to have enough history to 
calculate demand, or you can do one of the following: 

• Use manual minimum and maximum values and set them to expire after six months. The system 
calculates the demand based on these values. 

• Add the demand from an existing branch that you know will be similar to the new branch. You can 
have this value expire after 90 days and then let the branch calculate on its own after the expiration. 

If you are acquiring a new company or branch that includes inventory, then the on-hand values need to be 
updated for the new branch. Or you can conduct a Year End Physical Count to update the on-hand values. 
When the Update Demand program runs for the counts entered, the values should point to a G/L Account 
named Inventory. These counts will not affect G/L because you are debiting and crediting the same 
inventory account. 

A journal entry is made for the entire acquisition including the inventory you purchased. When the first, 
month-end process completes and you create your journal entry to tie your inventory back to your G/L 
account, any differences are  updated. 

If you decide to copy demand from an existing branch you need to setup a mass load to run and verify 
that the data elements are accurately set within your system. 

Mass Loading Add Demand to Items to a New Branch from an 
Existing Branch 
If the new branch you are adding already has information in the Add Demand window, use the following 
procedure to  keep the system from overwriting those values. 

To mass load add demand values to items: 

1. Create a dictionary item named COUNT_ADDDEM_PNS. 

 
This dictionary item counts the multi-valued list that exists in Attribute 64 of the Product file. 
This number indicates what multi-value number needs to be updated to when adding to the list. 
This dictionary must be marked as numeric so you can use it as part of your selection criteria.  
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2. Verify that the From Br and To Br dictionaries are defined.  
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After you have all of your dictionaries setup and verified, create your mass load. 

3. Use the following parameters to create the mass load: 

 
4. Make sure the ADD_DEMAND items have the Typ column set to S. 

5. Use the Phantom (scheduling) to run this mass load. Do not use the continue option. 

6. Test one product before running this for a group of items. 

7. Use the following select statement to narrows your list based upon the position that you will be 
updating in the product file. 

 
For example, the above selection parameters selects all A and B ranked items in Branch 2 that 
have one item already listed on the Add Demand screen in the product file. In order to add to the 
list without overriding what is already listed, the system updates value 2: 

 
8. Run the mass load report in summary mode set to break on the COUNT_ADDDEM_PNS. 

This format provides the number of add-demand values tied to your products and displays the 
largest number tied to an item. If the highest count is 6, then your first pass with the mass load 
should be to select items with the COUNT_ADDDEM_PNS = “6” to narrow your list. When 
updating, set your Column data to update Multi Value Pos = 7. 

9. With each pass, decrease the number on the Select and the Column Data by one (1). 

For more information about how demand works, see Adding Demand History to Products or How the 
System Calculates Demand per Day in the Forecasting online help documentation. 



Creating and Maintaining Branches and Territories 

71 

For more information about how report writer works, see Designing Mass Load Layouts in Report Writer 
and Mass Load online documentation. 
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Creating Transfer Matrix Cells  
(Setting up a New Branch, Step 12) 
You can create matrix cells for existing company parameters or separate company parameters. If you are 
planning to transfer material between branches, the system uses transfer order entry, suggested transfers, 
suggested transfer returns and surplus transfer returns. Matrix cells need to be in place to make sure that 
the system is transferring the material at the correct cost value. 

Existing Company 
Customer-specific matrix cells are higher on the matrix hierarchy than a Class / Group matrix cell. We 
recommend creating the matrix cell as customer-specific with your branch Customer ID and Group set to 
All. 

 
Note: The Customer ID for your branch is displayed in Branch Maintenance. 

Separate Company 
If you plan to ship material between two separate companies running on the same system, customer and 
vendor records need to be created for each company. The customer record is a bill-to / ship-to record and 
is different from the branch in the Customer Maintenance record. 

If company A needs to purchase material from Company B, a purchase order is generated in Company A. 
Company B, in turn creates a sales order to ship the material to Company A. Company B issues an 
Invoice to Company A, for which Company A pays for the invoice through A/P Entry. If special pricing 
must exist between the two companies, these are created through sell matrices and buy matrices so the 
purchase orders and the sales orders price accordingly. 
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Copying or Creating Matrix Cells  
(Setting up a New Branch, Step 13 - Optional) 

Note: If all of the matrix cells in the system can be used for the new branch and are set to 
the Default branch this process is not required and you can move to Deleting and 
Recreating Phantom Processes. 

The system uses the pricing branch’s price sheet to apply the formula it finds on a matrix cell. If all the 
formulas are different, then the existing matrix cell can be copied to the new branch or territory and the 
formulas can be adjusted accordingly. If you plan on using a territory then make sure the territory is listed 
on the Branch Maintenance screen for hierarchy purposes, otherwise the system has no source for pricing 
information. 

To copy a matrix cell: 

1. From the Maintenance > Price Maintenance menu, select Quick Sell Matrix. 

2. In the Class field, select the class you need to copy. 

3. From the File menu, select Copy. 

4. Adjust the formulas, if needed. For more information, see Adjusting Formulas in Quick Matrix 
Maintenance in Pricing Maintenance. 

5. Save your changes and exit the window. 

Important: Perform this procedure for each price class that is used in the new 
branch/company. 

Matrix files contain hierarchies and expiration capabilities and therefore cannot be mass-loaded into the 
system. 

However, if you wanted to start from scratch you can use the Matrix Upload Utility to load your matrix 
cells into the system. For more information on the Matrix Upload program see, Creating User-Defined 
Matrix Cells During Price Updates in the Pricing Management online help. There is also web-based 
training class available. 
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Deleting and Recreating Phantom Processes  
(Setting up a New Branch, Step 14) 
The system picks up any changes to territories by evaluating the territory when the report runs as opposed 
to when it is scheduled. Some reports can be edited directly from the phantom schedule without the cause 
for deletion. For example, the Inventory Valuation report can be edited and the driver can be updated 
from within the Phantom Job Scheduler. Therefore, before deleting the report, first access the edit 
function to determine if the branch can be added to the driver without the need of deleting. 

Note: This feature is available only after Release 8.7.2. While currently scheduled reports 
will still work, to use this feature the reports must be rescheduled once after taking 
the Release 8.7.2 upgrade. 

To display the scheduled phantom processes: 

1. From the System > Phantom Status to display the current phantoms. 

2. From the File menu, select Edit Schedule to display the Phantom Job Schedule Maintenance 
information. 

3. In the User ID field, enter the user ID for whose phantoms you need to delete, edit, or reschedule. 
Leave blank to view all phantoms currently scheduled. 

Note: If you are addressing phantoms for the entire branch, leave the field blank to make 
sure you do not miss any phantoms that should be rescheduled. 

 
4. Do one of the following: 

• From the Schedule menu, select Delete to delete the phantom altogether. 

• From the File menu, select Adjust to select a new date and time only. 

• From the Edit menu, select Copy to recreate the phantom. 

For more information about how phantoms work and what you can do with them, see Editing 
Phantom Process Schedules in the System Maintenance online help documentation. 

If a new phantom process must be initiated for the new branch, find the driver on your menu and schedule 
accordingly. For example, if your company does daily cycle counting and the new branch should follow 
the same procedures as your existing branches, this phantom would be its own separate scheduled event. 
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Creating Printer Locations  
(Setting up a New Branch, Step 15) 
You must have your printers set up and connected before assigning the printer a location in Eclipse. 
Printer locations are assigned to user profiles as well as terminals. The new printers created for the new 
branch require printer locations. When the user logs into the system, the system may default to a printer 
location based upon the terminal setup, or prompt the user upon login to choose a location. The location 
selected determines where Eclipse prints its forms. 

Use the following to help you setup your printer locations: 

For more information about... See... 
setting up printer locations for your 
new branch 

Defining Printer Locations in the Printers online help documentation. 

printer locations How Eclipse Determines Print Locations in the Printers online help 
documentation. 

assigning your printers in the system Assigning Printers to the System in the Printers online help 
documentation. 

print styles Maintaining Print Styles in the Printers online help documentation. 
terminal printer locations Changing a Terminal' s Printer Location in the Printers online help 

documentation. 

Note: Printer locations can be assigned to the ship via record for each branch, the branch 
assigned to the printer location, the default printer location control file and the 
terminal setup. 

To check and update fax settings, see Fax System Overview in the Fax online help documentation. 



Checking Terminal Settings  
(Setting up a New Branch, Step 16) 

76 

Checking Terminal Settings  
(Setting up a New Branch, Step 16) 
Both Solar and Eterm must have a terminal ID assigned in either the preferences or configuration. The 
terminal ID is used to set defaults in the system for the user to eliminate key strokes during processes, 
such as order entry. 

To display the Terminal Setup information, from the System > System Files menu, select Terminal 
Setup. 

 
To view more information about the fields displayed, press F9 when your cursor is on any of the 
columns. Following are several fields we recommend reviewing: 

• Terminal ID - Verify the terminal IDs you need. It is not necessary for each workstation to have a 
unique ID. For example, if your sales counter has three workstations and they use the same 
defaults, they can all use the same ID. To find a specific ID, right-click, select Search, and enter 
the terminal ID. You can also click the column header and sort the terminals alphabetically. Use 
the blank line at the bottom of the window to type a new terminal ID. 

• Printer Location - Select the printer location associated with this terminal ID. If you set a location 
in the Location column, it is the default printer location for the terminal when a user logs on to the 
terminal, accesses Sales Order Entry or Purchase Order Entry, or uses the change location function. 
If you leave the Location column blank for a terminal, the system prompts the user at log in and 
when they access order entry to select a location. If a physical branch is defined for the location 
using the Physical column, when you search, the list displays the locations within the physical 
branch first. Press F10 again to display a list of all locations you are authorized to use in User 
Maintenance. 

• Ship Via - Select the default method for transferring products ordered from this terminal to the 
customer. Ship vias are defined on the Ship Via Maintenance screen. If a customer does not have a 
default ship via assigned in Customer Maintenance and you leave this field blank, the system 
prompts the order taker at this terminal to enter a ship via for the customer's order. 

• Print to PDF - Select the check box if you want the user to be able to print documents and forms 
to PDF. Meaning, when you print, the system displays the form or document as a PDF on your 
computer. You can then decide if and how to print it. 
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Creating New G/L Accounts  
(Setting up a New Branch, Step 17) 
If the new branch requires additional G/L Accounts for posting, create the accounts in G/L Maintenance. 

The Profit & Loss and other General Ledger reports can all be run based upon branches. Therefore, if you 
have two separate companies running on the same system, each company would run their own report 
using their branch territory or branch numbers. For example, if the new branch has a sales source that is 
different or new, you will need the Sales and Cost General Ledger accounts to point to the new auto 
postings related to the new sales source. 

For more information about setting up general ledger reports, see Customized G/L Reports in the General 
Ledger online help documentation. 
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Verifying Ship Via Records Assigned  
(Setting up a New Branch, Step 18) 
After building the branch file, you must assign the ship via records to the new branch. Use Ship Via 
Branch Overrides from Branch Maintenance to assign the ship vias to the new branch record. You can 
also delete ship via records from the list that are not relevant to the branch. The system checks the 
shipping branch to determine what list of ship via records are available for use. 

 
You can also set the pick ticket printer location so that the system knows where the phantom should print 
these tickets. If you need unique ship vias for this new branch, first create the ship via in Ship Via 
Maintenance and then you can add it to the branch. 

For more information about branch records, see Creating Branch Records in this documentation. 
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Authorizing Users Using Mass Load  
(Setting up a New Branch, Step 19) 
After assigning ship vias and terminal settings, you need to authorize those users, who need to do 
business out of that branch, access to the branch. In other words, in order for the user to create 
transactions within the new branch, the user must be authorized to do so. If your user list is small, you can 
edit each user record accordingly through User Accessible Branches in User Maintenance. 

However if you have a large list to deal with you can need to create a mass load to update all the users' 
records: 

Note: Make sure that the AUTH_BR dictionary has the multi-value prompt set to No. If 
it is set to Yes and you have view-only access, copy the dictionary to a new name 
and set the multi-value prompt to No. Use the new dictionary item you created for 
your load. 

In the following figure, the mass load is setting all the branches the user will have access to. Model your 
mass load along these lines. If your company has too many branches, and you cannot list them in this 
format you can add the new branch you want to the end of the list. 

For example: 

 
The system adds a value marker to the existing data on the Authorized Branch list, and then adds the new 
branch to the end of the list with a mass load like the one shown here: 

 
This process keeps the integrity of the data and branches that are already authorized in place and simply 
adds the new branch to the end. 

Setting Territory Flags 
If users should have reporting, editing, viewing authority associated with territories that exist in the 
system, review the following example. 
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Enter Y on the Override Automatic Build and Authorized for All Terrs prompt for all three settings. 

 
However, if users should only be assigned these rights to a list of territories, the mass load would look 
like the one shown here: 

 
The end result display on the user file as follows: 
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We recommend testing your mass load on a single record before setting all values for your employees. 
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Verifying Product Families  
(Setting up a New Branch, Step 20) 
Product Families are a list of products that are frequently sold together. Verify the Multiply Product 
Family Quantities By The Order Quantity control maintenance record is set to Yes. 

If your existing product families can be used in the new branch, there is nothing that you need to do. 
However, if you have unique families that should only display in the new branch, specify the branch for 
which it pertains when setting up the family. 

Review Product Family Maintenance as follows: 

 
Product Families may display in Web Order Entry. For more information, see Web Commerce Overview 
in the Web Commerce online help documentation. 
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